Performance Issues using Envelope Generators



  • Thanks for your comments.

    Michel, I am using Isadora Core and i've tried reducing the size of the image even to the point of it looking very pixelated. the speed i tried was pretty slow -- 20 seconds for a small image of a cloud to travel from left to right....
    vanakaru, yes, that's what i mean by manipulating the images. and the image you used is much larger than anything i've tried. can you think of why it's not as smooth as silk for ME?!
    eight, is that fluidity really impossible to achieve in Isadora? 
    still not sure how to fix the problem. further advice appreciated!


  • Hi Would you put a screenshot of your patch that we see witch actors you use to manipulate the images Best Mehdi



  • Hi Mehdi

    i've tried it these two ways....
    thanks
    raha

    ba58e3-screen-shot-2012-09-09-at-7.09.22-pm-2.png bc2128-screen-shot-2012-09-09-at-7.14.04-pm-2.png



  • I tried once again with few different pictures. It works just like before - great. And my mac is not as fast as yours.

    How do you connect to the projector(actually I tried on external monitor, projectors settings play a role sometimes as well). 
    Could you check what the Console is telling you when the video stutters.
    BTW I get on Status Window Cycl:256 VPO:0.0 FPS:30\. How about you?
    And lets check what you have on Isadora Preferences?


  • vanakaru, thanks so much for all that.

    i've tried an external monitor, but it also does it on the small stage preview screen (when i click force stage preview) 
    last project when i had the same problem, it did it whether it was through the projector, on the external monitor, or in the small stage preview on the iMac monitor. it always stutters in the exact same places...
    my status window VPO: 0.0 and FPS: 30, but the Cycles fluctuate a lot between near 230 and 270....however after trying several times, i can't notice a pattern in whether they drop or skyrocket at the places where it jitters -- it's just constantly changing.
    could that have something to do with it?
    i've attached screen shots of my preferences....please let me know if you notice anything relevant!
    thanks

    8a9b70-isadora-preferences-1.png 6e865a-isadora-preferences-2.png 698ff4-isadora-preferences-3.png c673dc-isadora-preferences-4.png 2ab46f-isadora-preferences-5.png



  • I thought you may have Threaded Movie playback checked. Uncheck this and see if you get better results. If I remember right Picture player specially does not like it.



  • tried.

    unfortunately, still jumpy...


  • I really is puzzling. I have the same settings, same preferences and lesser mac?

    Try this. You do not need to log in to download the zip(16.07mb). I put the Isadora patch and a picture file I was testing with in it.
    http://www.mediafire.com/?r3x495zzw82614c


  • if you change all the rate times to 10 seconds is it still as smooth?



  • Yes. Run it 20 sec if you like.



  • mine's jumpy when i do 20 secs



  • The one thing I noticed when I tried to record a screen for you with iShowU HD. It started stutter just a bit because this app takes lotsa CPU. So I wonder if you have something running in background that competes with Isadora.

    I am on 10.6.8\. i wonder if this makes difference. I have Lion installed on external drive(never got to use it) that I may give a try.

  • Tech Staff

    My Mac which is super old couldn't handle that patch you created @vanakru but I expected it with a 8000x8000 pixel image.

    What are you playing the file off? An external HD if so is it USB/Firewire, etc?


  • I don't know if my mac classifies as super old as well, but I have just tried to play the same JPG off my main drive SSD and off 1tb HDD in optibay(PATA!!!). No difference, runs great.


  • Tech Staff

    I just tested the patch on my windows machine with a 1920x1920 image.
    I tried a few different settings configs and can't get it to play smooth.
    It is inconsistent as to when and how the stutters occur, but they are there.

    running f24.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.