assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Please help artist to solve crashes and output issue, (shows is coming, we can't rehearse)



  • Dear Vanakaru,

    thanks for answer....sorry for being confusing. Patch is attached. What worries me the most are crashes of Izzy (and not to be able to update Quick/install ProVideo as recommended), low performance and problem to recognize video output.

    I can not really attach video file as its explicit and raw. Working on it. But please if you can look at the patch, I will be thankful.

    48f58f-working-01.izz



  • I Downloaded and opened your Izzy patch. I loaded a .mp4 video file. Your Opening scene and Edgewalk scene runs at 27fps on my laptop.



  • First of all make sure you have mov's in good health and the size of your beamer(projector) native size. This "Video files: from Black Magic rendered into H264, cca 6MB/s bitrate" sounds suspicious - not 6MB/s but Black Magic?.There is a good topic about rendering H264 on this forum.Try different codec as HAP, ProRes, DXV(Resolume). I think you can install FCP X to obtain Pro codec. Installing Resolume demo will give you DXV and HAP is free.

    But said all that you may be better off using PhotoJPG codec after-all since you project relies heavily on Dots Actor. This actor is CPU only and will tax your system hard.
    So looking at your patch I would try few things. Do not use scaling in Dots - set it 1\. This will affect the performance really bad. The other thing I notice when I set Player optimise to interactive(not performance) I get framerate jump from 15 to 55(I have target frame rate set 60) on my old MBP 2008.
    These are some tips I would try from my experience running on old macs.

  • Tech Staff

    @em_tx

    @vanakaru 's tips are all very good to be followed.

    I also tried your patch with .h264 (9MB/s), photoJPG at 50% (I don't think you need more, because of the dots actor you can even go as low as 25%) and apple pro res 422lt all 1080p. Isadora set to 60fps (important if your media is 25fps set Isadora to 25 or 50, if its 30fps set Isadora to 30 or 60fps), everything is playing around 50fps. Because you set the speed of the movie player to 0.16 .h264 will not play so smooth even though the frame rate is as high as with the other codecs but .h264 does not contain the full image in every frame as photoJPG or apple pro res does, so .h264 is not recomended for this use.

    MPEG Streamclip is very handy to convert into different codecs. Handbrake is my favorite choice converting into .h264.

    Best Michel



  • Are you getting confused with where to locate your output stages?

    Hook up your beamer. Open Izzy. Head to Isadora > Preferences > Stage Tab. From the dropdown choose what stage outputs on which display.
    Now go and start the stages. Make sure your projector actor is set to the stage which correlates to the beamer.


  • And download and install this: https://support.apple.com/kb/DL1396?locale=en_US

    ...then see if you still have issues with the player crashing.


  • "Am I able to run audio file and create time cues changes on scenes on audio file (like having a time line upon I can work with)"

    Not as straightforward as that, but yes. Start a timer with the start of your audio file and use comparator actors to trigger at appropriate times... or calculated the position in the timeline in percent and just take the position output to your comparator actors then to activate scene triggers.


  • AND... is this a legit Mac or a Hackintosh?



  • Marci:
    Its Mac Book Pro late '13
    Thank you for help in terms of Timer - I look at that. I am still quite beginner, so I will see what I can do.
    It does not allow me to Install Pro Video formats - please see attachment. I do not have Final Cut, Motion or compressor.
    Thanks for help for hooking beamer - I managed!

    a4e001-screen-shot-2015-09-27-at-15.06.53.png



  • Michel:
    I know its not smooth - this does not bother me. Idea is that actually its not smooth. Overlay of 2 videos and dots creates patterns whom I am after. I guess (maybe wrongly) that with excess of power my mac has even not effective I should still get around on 1 beamer.

    I am looking at the different codec. I use Premier Pro, I see what I can do to go maybe to Pro Res as all videos are shot at Pro Res.



  • Vanakaru:
    I try to change to go to Pro Res. I see this after I reencode the videos.

    However there is big improvement in terms of changing mode from performance to Interactive on player.



  • All:
    **
    THANK YOU VERY MUCH FOR HELP.** I GO WITH YOUR ADVISES AND PLEASE I POST MORE QUESTION IF I AM STILL IN TROUBLE!!!



  • Just to make sure: you know that scaling in Dots is for buffer size - the higher number the better quality, but also more power demand? I see no difference in quality if set to 1 or 2.

    Also the effect you are after may be available with other Actors. Although I do not know what it is you are after - just a thought.
    BTW FinalCut X trial http://www.apple.com/final-cut-pro/trial/


  • @ vanakaru

    I thought about different actors - just did not get through them.

    Effect is - 1 vid. - square, 2 vid.  dots, very small, by re-positioning matching their default place and let them influence/overlay each other. Its very particular to videos I use, otherwise its not amazing at all.

    When I run ISA with new patch, which is much more complicated I have low performance, but still +75% of CPU and +50% RAM free. Maybe there is something I am not aware and cause limitations. Is there a way to check buffer size & use?

    I go and encode overnight into ProRes and lets see what happens in new patch.

    I got advice workaround for codecs. I tried to avoid trials as I have only 1 computer for all, so I try to keep clean. Maybe just superstition with this trial.



  • Tested your patch - specifically 'Opening' scene...

    Using 2x 4Gb MOVs (720p 24fps, H264 MP4, VBR Encoded) on 2015 Retina MBP in my sig, it runs at 5fps.
    With a pair of 400Mb MOVs (Photo JPEG Encoded), it runs at 12fps.
    If I set 'optimize' on your movie players to 'interactive' instead of 'performance', Pb engine switches from AV to QT,  & the first 2x 4Gb MOVs rise to 15fps, whilst the Photo JPEG MOVs rise to 23fps.


  • Marci Thanks! OK. I see. I just do not get why 75% of my computer performance is still free...why the soft does not pull out more of comp....
    Anyway, I rebuild patch. Easier, lighter, looks better and runs well.

    I just do have a very simple question. How I can get rid of the Menu bar at the output? I can not find it and I am had a little stress here.
    Thanks many times.


  • Tech Staff

    @em_tx

    I answered the menu bar question in your other post. Please ask the same questions only in one thread, other wise answers get scattered around different posts and are not easy for you and for other to follow up.

    Best Michel



  • THANK YOU VERY MUCH ALL FOR YOUR HELP AND TIME. I AM IMPROVING EVERY DAY WITH YOUR HELP AS WELL VISUALS.
    As its not a sharp premier, but still public performance it was great help.

    I was working so far with analog video and Win. machines, so I guess I had to read bit strange, but eventually result is quite ok, despite I guess I have not done it most efficient way.

    As I was searching, I found out about renicing - changing priority for application in Mac Os by third party app. (atMonitor this case) - I wonder if that would help the performance.

    Once again thanks to you all and have a nice weekend!!!



  • Is it showing 100% of 1 CPU being used (the 75% being the other 3 CPUs not being very busy) Your computer has 4 CPUs, but an individual program may be able to make use of multiple CPUs to speed up it's executon (not because the programmer hasn't bother to implement that, but because some tasks do not work well across multiple parallel processors - for example I can't run as fast as Mr Bolt,get three more copies of me won't make any difference. But if I'm digging a large garden three more of me would be great). Isadora is closer to running a race than digging a garden



  • Nick, thanks:
    well thats a really good one. My Isadora core is running on 18% of 1 core of CPU, than I see reserve.
    However my MBP had an issue with overclocking - which was requested to be serviced, but not serviced. I wonder if there could be a problem, which could be a contributing factor.
    Is Isadora able to run Isa core on one core and rest of the players on another cores?
    Thanks...- I go and test more races. ;)


 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.