MacOS Sierra: If You're Having Trouble - Let Mark Know Here

  • Dear All,

    After solving initial reports of frame rate slow downs on macOS Sierra, I have gotten at least one direct report of the "spinning beach ball of death" appearing when doing something as simple as clicking an actor. None of the team, on a variety of Macs, can reproduce this behavior. But, also, none of us have the very latest Mac Book Pro machines (the ones with the gimmicky touch bar.)
    If after downloading the 2.5 beta from this link you are experiencing problems, please post here. We need to know the following:
    1) A precise description of the symptoms
    2) The exact model of your mac
    3) If possible, an example file that shows the behavior
    This issue is at the top of my priority list now. So please tell us what's going wrong and I will get it solved.
    Best Wishes,

  • @selittle,

    You were one of the people having trouble with Sierra. Please answer the questions above so I can narrow down the problem.
    Best Wishes,

  • For the record, one person reports trouble with this model:

    new Macbook Pro 2016 retina 13 inch, i7 model without Touchbar, and the Intel Iris Graphics 540.
    Best Wishes,

  • @barneybroomer,

    At one point your reported slowdowns of Sierra, but I believe those were the drawing problems we solved. Does the 2.5 beta work fine for you these days?
    Best Wishes,

  • Hi @Mark I am having issues with slow frame rates etc.

    My current system with Isadora 2.5 running in beta mode - I have lost my password : (
    MacBook Pro 15" 2016
    2.7GHz Intel Core i7
    16GB 2133MHz LPDDR3 RAM
    Radeon Pro 455 2GB VRAM
    512 GB SSD
    Sierra 10.12.2
    You may remember that I submitted a support ticket in October about the very same matter - posted video of the symptoms on the forum. 
    At the time other forum members were not experiencing the same issue and I put it down to my relatively old 2011 MacBook Pro with only 256MB of dedicated graphics memory. I returned to El Capitan and Isadora ran perfectly. However my new Mac is displaying exactly the same symptoms as I attempt to drag an actor across workspace.
    Best regards,

  • Dear @Paz,

    Just to check: you have the very latest v2.5 build, yes? (Available at
    Are your patches particularly complex, e.g., lots and lots of patch cords? (If you have a patch that is troublesome that you'd be willing to share, I'd like to get it. Send me a PM about that, or post here if it is something you don't mind others seeing.)
    Best Wishes,

  • Hi @Mark,

    I'm experiencing issues with the latest build which I downloaded today. 
    The Izzy workspace is empty - containing no patch. Just dragging in an actor causes lag. Back in October I posted a video of my experience - same problem is occurring today []( 
    Thanks for your help

  • @Paz,

    Thanks for that. I have just realized that I had Sierra 10.12.0, not 10.12.2 – for some reason the update didn't automatically appear in the Updates section of Mac OS. (Strange.) I'm downloading it now and will report here if the upgrade allows me to see the problems.
    Best Wishes,

  • Ok guys, so here it goes.

    Model Name: MacBook Pro

    Model Identifier: MacBookPro9,2

    Processor Name: Intel Core i7

    Processor Speed: 2.9 GHz

    Number of Processors: 1

    Total Number of Cores: 2

    L2 Cache (per Core): 256 KB

    L3 Cache: 4 MB

    Memory: 8 GB

    Kinect: 1414

    Maybe someone else has mentionned this

    Problem A (not so serious); I start Isadora and the whole laptop starts warming up too fast and using the fans way too early (even before starting to put actors).

    Problem B: So here is the moment when it all crushes.

    I have followed succesfully part 1 + 2 of the isadora kinect tutorials.

    I am now starting with part 3, I go up until step 4 and it crushes.. I insert 'syphonreceiver' and the moment i change the server to 'depth' it all crushes.

    Problem C: In the beginning I was also running a kinect v2 with a syphon2, and when I was changing between the 3 servers it was also crushing. I don't remember exactly my setup but it was fairly simply. Just the syphon2 and the project. then i was changing between the 3 kinect2 servers. I didn't pay too much attention then, but since it resembles problem B, I thought I should mention it.

    I hope it helps.


  • Dear @groovakos (Pavlos),

    Regarding the Kinect crash: you are using the version available here, yes?
    If not, please make this free upgrade and try the Syphon Receiver actor again.
    Best Wishes,

  • thanks @mark,

     I have tried on version 1.something (i can't remember now which one I have and don't know where to find it) and also on 2.5 
    It certainly crushes on both. 
    But now that you mentioned it here. I went back to the 2.5, I tried it, and it worked for 5-10 seconds, then it crushed. 

  • Morning,

    Just installed the 2.5 version you linked above.
    Still seeing the same lag and frame rate drop when dragging a particles actor around on the otherwise bare stage. 
    This is on my:
    MacBook Pro (Retina, Mid 2012)
    OS: 10.12.2
    2.6 Intel Core i7
    16 GB 1600 Mhz DDR3
    NVIDIA GeForce GT 650 1024 MB
    Intel HD Graphics 4000 1536 MB

  • I have only gone to 10.12 on my mac mini

    Mac mini (Mid 2011)

    2.7 GHz Intel Core i7

    16 GB 1333 MHz DDR3

    AMD Radeon HD 6630M 256 MB

    Just a little baby I know but Izzy used to run smooth, now I have jerky unresponsive activity from dragging the fist actor on.

  • Hi Mark,

    I downloaded the most recent 2.5 version from the link, but am still experiencing frame drop and slow downs. This is not patch specific and happens even with a new patch. (The performance returns to 60fps when I switch to control mode, which for me is alway empty. I guess it's not drawing the actors on the screen anymore?)
    Here is a video:
    I have a 15" Macbook Pro (late-2016). 2.9Ghz i7 + Radeon Pro 460\. I'm on 10.12.2

    Model Name: MacBook Pro

    Model Identifier: MacBookPro13,3

    Processor Name: Intel Core i7

    Processor Speed: 2.9 GHz

    Number of Processors: 1

    Total Number of Cores: 4

    L2 Cache (per Core): 256 KB

    L3 Cache: 8 MB

    Memory: 16 GB

    Boot ROM Version: MBP133.0226.B08

    SMC Version (system): 2.38f6

    Beyond these problems, Isadora takes much longer than it did to open. The splash screen will come up, go away--and then nothing for a while--before the "untitled" blank project opens.
    Please let me know if I can let you know about anything else that might be useful! 

  • Hey there,

    I was just able to check the new 2.5 download above on my newer (not the newest) machine.
    As I reported on the last version of 2.45 (?) I **do not** see a significant slow down on this machine.
    If I really start moving a particle actor around (basically shaking the mouse around as fast as I can)  it will drop down from 30 to around 26-27 fps. . . but it isn't noticeable unless I am watching the FPS meter. Have not had a chance to do anything but open a clean patch and just add the one actor.
    Here are the specs:
    Os: 10.12.2 

    Model Name: MacBook Pro

    Model Identifier: MacBookPro11,5

    Processor Name: Intel Core i7

    Processor Speed: 2.8 GHz

    Number of Processors: 1

    Total Number of Cores: 4

    L2 Cache (per Core): 256 KB

    L3 Cache: 6 MB

    Memory: 16 GB

    Boot ROM Version: MBP114.0172.B10

    SMC Version (system): 2.30f2

    15.4-inch (2880 x 1800)

    AMD Radeon R9 M370X 2048 MB

    This one is
  • Beta Gold

    Hello @Mark,

    I started to use Izzy a little more under Sierra and am having trouble just launching it (I have the latest beta) It takes a lot of time especially if I open patches from older versions. The waiting time is even longer if Isadora doesn't find the serial port device the patch was supposed to be connected to
    MacBook Pro (Retina, 15-inch, Mid 2015), 2.5 GHz Intel Core i7, 6 GB 1600 MHz DDR3, AMD Radeon R9 M370X 2048 MB

    Intel Iris Pro 1536 MB

  • Hi,
    MacBook Pro (15-inch, 2016)
    Processor 2,7 GHz Intel Core i7
    Memory 16 GB 2133 MHz LPDDR3
    Graphics Radeon Pro 460 4096MB & Intel HD Graphics 530 1536 MB
    I'm having problems with the version 2.5.1, the start up of the application takes long time with the spinning rainbow wheel, and then opening a project the same thing (with the spinning rainbow wheel ), and in the end the project might run or not, usually not – it just gets stuck, and relaunching the project might start it running, usually not. Sorry, not very precise.

  • @mark

    Hi Mark,

    I hope all is well with you ... but .... 

    I am afraid that I too am having trouble with Isadora start-up on my MacBook Pro.  It works perfectly on my (older) Mac Mini, but takes between 50 secs and a minute to initialise, and then another 30 secs or so to open the Isadora file on the MacBook.  I am not working on a complicated system (very simple in fact)  ... and as I say it all works fine on the Mac Mini.

    The specs for the Macbook are .... 

    Retina 13" Early 2015:    Procesor 2.9Ghz Intel Core i5:   8gb Memory 1867 MHz DDR3:Graphics Intel Iris Graphics 6100 1536 MB

    The Specs for the MacMini are

    Mac Mini Late 2012:  Processor 2.3GHz:   16GB 1600MHz: Startup Disk Macintosh HD Graphics 4000 1536MB

    I'm running Isadora Core 2.5.1 on the MacBook and Isadora USB 2.5.1  on the Mac Mini (I daren't change that until after the exhibition is over - and can't find the new 2).  

    Hope it is not just me being a klutz.

    Sarah (Rubidge)


  • Tech Staff


    Please send us a support ticket with these details. We'd be happy to help you find a solution.