Issues using Spout in Isadora (Kinect connection)



  • Hi,

    Im trying to connect Kinect to Isadora via Processing and Spout. I have a Kinect 1414 which works fine with Processing - the camera is up and running. I have been walking through the tutorial on Isadoras webpage (https://troikatronix.freshdesk...), but have had to make some adjustments (such as using an older version of Spout, as the newer ones dont include a PROCESSING folder). 

    The problem shows up when I open the Isadora Skeleton Test Win (from the tutorial). Isadora tells me that SpoutReciever2 (ID=4C4A3438) is an actor that could not be loaded. If I open Isadora anyway, we find all the actors in place, but when we open the Stage Preview the screen is black.

    I have tried going through the Using Spout FFGL etc tutorial on the web page. But when I open the Spout demo sender Spout just crashes. 

    Do I need to use the newest version of Spout? In that case, how do I get it to work with Isadora (as the online tutorial only concerns the older version)

    I am still very new to this; so sorry if i dont understand everything about this process. 

    Thank you for the help!


  • Tech Staff

    have you added the spout ffgl to your freeframe folder?



  • Yes i have. I have actually found a solution to the original problem, but have now found a new one:

    It seems like Spout is not communicating correctly with Processing and Isadora. On the one hand, Processing works just fine, and i can see the Kinect video outside of Isadora though Processing. Inside Isadora i can find the SpoutReciever actor, and can use the Spout demo-sender inside Isadora no problem. But it does not seem to transmit the Kinect-image from Processing to Isadora. I will gladly give more information if anyone has any idea what could be wrong. 

    Thank you


  • Tech Staff

    If I understand you correctly, you are saying that Isadora can see the video feed from the Spout demo sender (using the Spout receiver actor)?
    If that is the case then, Isadora is configured correctly. It would seem then, that Processing is not correctly sending the video output via Spout.



  • Thank you again for the reply.

    I dont know if i should make another forum post, or just continue on this one, because now i have switched from Processing to Ni-Mate.

    Ni-mate has been working great, but i am still having problems with Spout in to Isadora. I can easily detect the skeleton from Ni-Mate into OSC listener. But i would like to spout the live-video from Ni-Mate into Isadora. But again, i cant seem to get Spout to work. I will attach a picture so you can see the problem: 

    As you can see, in the spout panel available though the Isadora SpoutReciever2-actor, the Ni-Mate live-video is not showing up. I dont know how to make Spout receive the "signal" from Ni-Mate inside Isadora. 

    Sorry for posting three separate problems in one forum post, but its a continual process where i am finding problems/solutions as i continue working. Thank you for all the help!


  • Tech Staff

    I know its a long shot but just click 'update' on the spout actor and see if anything appears?



  • @Skulpture

    Hit update, still nothing im afraid 



  • Ive been following your tutorial on this by the way: https://www.youtube.com/watch?...

    That is how i discovered there was a problem (and probably a solution!) 


  • Tech Staff

    I wonder why it isn't sending any video. Your set up is exactly the same as mine... hmmm. Need to think about this.



  • I worked it out! 

    I had two Common Files folders, One in the x86 folder, and one in the regular one, i had simply made the FreeFrame folder with the reciever/sender files in the wrong one. 

    Just a stupid little mistake, thank you for the help anyway!



  • I got a show where I was able to do it in W10. 

    Things to remember to set: Isadora, spout and ni-mate all seted as high performances on your graphic card settings. then some time you have to change the directx transfer mode, on my laptop i got some sort of bug that allow me to use spout and isadora only in CPU share mode (but on my desktop dx mode works), so try to change it and do some tests.


  • Tech Staff

    @anrost said:

    I worked it out! 
    I had two Common Files folders, One in the x86 folder, and one in the regular one, i had simply made the FreeFrame folder with the reciever/sender files in the wrong one. 
    Just a stupid little mistake, thank you for the help anyway!

     Ah great news! So glad! 

    This will be helpful for new users reading this thread in times to come!


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.