Kinect to izzy

  • Tech Staff

    Figures.. I always seem to get left out. I won't have time to look into this until the new year at least. hmm.

  • Tech Staff

    A few links;
    Can't help with openframe works though sorry.

  • Tech Staff

    That might be just the thing to get me back into OF. Have really been meaning to get back into some C++.
    Has anyone on the forum had success using OF within the Izzy SDK that you can remember?

  • Search for "Nono" !

  • Tech Staff

    Urrr this?
    Top hit in google for nono was 'products for hair removal, acne clearance and skin care....' haha! (Made me laugh out loud anyway!)

  • OK, I've got a little present for you all -- a totally "unofficial" release. But if you accept my gift, you must accept the following conditions:

    1) If it doesn't work, **you won't complain at all**
    2) If it doesn't yet have the features you need, **you won't ask for them** (at least not yet.)
    Got it? Do you promise? OK...
    Attached you'll find a little actor that directly pulls the depth image from the Kinect, and brings it into Isadora as a normal 'video' image. I finished this yesterday, as it's part of my research for my new piece (working title SWARM) which I'm currently developing at La Manufacture in Lausanne, Switzerland. For this plugin, I'll be releasing the source code soon so that intrepid coders can take it in other directions if they like.
    To install, put the plugin in this folder:
    /Library/Application Support/TroikaTronix/Isadora Plugins
    You **_are_** allowed to tell me if it works or not for you, and that it's great, etc. ;-)
    So give it a try if the function it provides seems useful.
    Best Wishes,
    P.S. Mac only at the moment... sorry!

  • Tech Staff

    Not showing up in Isadora 1.3.0f25 or f24.

    Not complaining just feedback :-)

  • Yes, same here(also1.30f26).

  • Hmmmm.... well, I had to install a bunch of weird stuff to be able to compile this. I'll have to try it on a "fresh" machine to see if it works. I'll let you know.

    Best Wishes,

  • @Skulpture  Isadora User "Nono"  - do a site search.

  • Tech Staff

    Same; 1.30f26 also.

  • Its working for me!

    OS X 10.7.5,   2.4GHz Intel Core i7
    Izzy, 1.3.0f25
    fantastic! no more messing around to get it in! plug and play!  
    Thanks mark! 
    Im sure everyone here has looked at these things before however i just found this book preview thats compiled all the things that have so far been achieved with the kinect, thought it might be interesting.


  • @Lanz you must have something installed that I do not have to make this happen. I tried boot from 10.7.3 as well and no luck.

  • @vanakaru i must admit i have been throwing around so much kinect stuff lately to get things working i couldn't say which bits are getting this to work.

  • I thought so. So maybe I should install everything I can find about kinect. Probably there is some library needed. but first I shall try to boot to the state I had in summer when I messed with kinect too. Did not get too far though.

  • Tech Staff

    Since we are talking about kinect's.... how interesting is this?

  • That's fun ! let's have the phone ringing & vibrating on the kinect all the time !

  • Tech Staff

    hahaha!! Good idea!

  • Hi Folks,
    Where did you get Isadora 1.30f26 ?!


  • So I'm trying to determine what packages you need to install to get this to work. Basically, the way I did it is to do a bunch of nasty and arcane unix style installs for libusb and OpenNI and others. A wonderful colleague called Andrew Sempere who is working here in Lausanne has a package that installs his Kinect app along with the required libraries and drivers using a normal installer. He offered to modify the installer to just install only the required libraries, and not his app. So I'll work with him to try to get that to happen in the next days. My suspicion is that it worked for Lanz because he had this stuff installed.

    If you are really dying to use this, you can bite the bullet and install the packages required by following instructions on the page given below. But let me warn you that I have **no idea** **how to uninstall this stuff** once you've added it to your system. It shouldn't cause any trouble, but please consider that you're installing low level drivers, etc., that have the potential to cause unforeseen problems.
    **NOTE 1:** You can stop before the step of installing NITE -- as this is not needed.)
    **NOTE 2:** when installing libusb-devel, I had to do the following before it would work properly
    sudo rm -f /opt/local/lib/libusb-1.0.0.dylib sudo port clean libusb sudo port install libusb +universal
    Good luck!
    Best Wishes,