assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Missing CI Actor



  • HELP!  Today I started up Isadora (core) 1.3.0f25 and got this message:

    **_The following actors couldn't be located:

    CI Mask to Alpha

    _**
    So i tried Isadora 1.3.0f24 as well, same problem.  I hadn't seen this problem before.  Any ideas?

    Thanks,

    ur,ummmmmmm.............................................eric 6fa711-screen-shot-2013-01-02-at-18.06.27.png


  • Tech Staff

    I can't help you on this, because I don't know where the CI actors are saved.
    @Mark?

    Best,
    Michel



  • Help?!!! Anybody?



  • Core Image filters are part of the system or developer tools.

    https://developer.apple.com/library/mac/#documentation/graphicsimaging/reference/CoreImageFilterReference/Reference/reference.html
    Maybe you need to reinstall dev.


  • Hmmmm.  I don't know why this one CI filter would just disappear, and don't know how reinstall dev.  Thanks for the heads up.  I hope there is a simpler way to deal with this.

    ur,ummmmmmm.......................................eric



  • ursullivision:  I'm getting the same error message.  Any word on this?



  • Dear Eric,

    First of all, you don't need to install the developer tools. These filters are "built in" since 10.4 (I believe that's when they started.)
    Could it be simply that the Core Update is not active for some reason? Are there other Core Image actors in the patch? Can you add a CI actor in your current setup?
    As you can see on this page, Mask to Alpha is part of the standard set of filters provided.
    http://developer.apple.com/library/mac/#documentation/GraphicsImaging/Reference/CoreImageFilterReference/Reference/reference.html#//apple_ref/doc/filter/ci/CIMaskToAlpha
    So I don't think you can really "un-install" it. But here's another way to check: go to your Dashboard, hit the "+" button, and enable the CIFilterBrowser. This will give you a list of all CI Plugins installed on the system. Type "Mask to Alpha" in the search box at the top, and see if the filter is really gone.
    If not, it's something else.
    Best Wishes,
    Mark


  • @Mark,

    The filter shows up in the CIFilterBrowser.

    Hmmmm......

    Funny, I was certain that I posted this answer yesterday, but it wasn't in the discussion today.  Perhaps I forgot to hit Post Comment.

    ur,ummmm......................................eric



  • I checked today, and I can load the actor (CI Mask to Alpha) from the toolbox, but it does not pass an image thru (no image comes out), and when I click on the actor I don't have any options for actor help.  It appears to be broken.  (Also 1.3.0f24)

    ur,ummmmm..............................eric



  • Dear Eric,

    Well, first thing, there isn't any help for the CI actors because I'm appropriating them from Core Image -- Apple doesn't provide any help.
    Can you try the attached patch? You should see a white square on a red background.
    Best Wishes,
    Mark

    42c2be-ci-mask-to-alpha-example.izz



  • @Mark,

    Hi Mark,

    thanks for getting back to me.  Weird, your patch works.  it loads without the error message, and I see a white square on a red background.  Must be a corrupted patch on my part? Hmmm.

    Thanks again,

    ur,ummmmm..................................eric


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.