USB Key connection lost

  • Low tech options-

    save your work before a long period of inactivity
    turn off sleep i  energy saving preference, or set it to not kick in for a long time, like 1 hour (it can be set for never - I always set a show machine machine to never sleep computer, never sleep display, especially if you dont use mouse and keyboard to drive the show

  • @nick yep I'm using 10.7.5. I'll try the saving work technique sounds like a good idea.

  • I was teaching a workshop on Isadora a couple of weeks ago and had the same problem. Half of the computers at the school were using the key version and Isadora would revert to the demo. Running 1.3.0f.24 on both iMacs and Retina MacBook Pros all running Mountain Lion. As I recall it was related to the computer going to sleep, but never really pinpointed the cause. A one last save option would be great.

  • Beta Tester

    I have all of a sudden started running into this issue as well. It has been happening with a Mac Mini running 10.8 and IsadoraCore 1.3.0f27. The USB key is plugged directly into the computer not a hub or anything like that. The issue is definitely associated with long periods of inactivity as we are currently in tech and it has been happening in the middle of cuing which is obviously rather problematic. Quitting Isadora, unplugging the key, reinserting it, and restarting Isadora fixes the problem until it happens again. There doesn't seem to be any pattern to when it happens and it has probably happened three or four times over the past few days.

  • Dear MatthewH,

    Is the computer ever going to sleep?
    I have tested this on 10.8, putting the computer to sleep and waking it again repeatedly. This all works well.
    Would you suggest that I simply leave the USB plugged in and let the computer sit for a long period -- not going to sleep, but simply sitting there? Is that the recreate?
    Best Wishes,

  • Beta Tester

    The computer definitely isn't going to sleep. It also hasn't happened since I posted so I'm not really sure what's up with that. The whole thing is rather perplexing.

  • "The whole thing is rather perplexing." -- to say the least! I've tried to repro this and just can't!

    -- M

  • I've also had this problem.  There are no other usb connections, the computer never goes to sleep or any other energy saving things.  Moving the usb key around doesn't get it to reconnect.  No solution other than rebooting has worked. (though I gather quitting Isadora and re-fitting the key is possible)

    The usual terms apply, Save Early Save Often.

    For most computers during a rehearsal process I do not shut things down.  This computer is the exception, it gets shut down between uses for this reason.

  • I've had similar problems at my work where we use the USB Version of Isadora. I also can't reproduce the error but I also had disconnection problems with the key, even when directly attached to the computer and on different computers. I have to say I'm generally pretty unhappy with the usb solution we bought, because I expected I would have to install the usb drivers and isadora, then use the key on whatever computer I want. But I still have to activate any computer with a long license code before I can even use my usb key and then there comes the problem on this thread. If I forgot to save for a couple of minutes and the connection is lost, there is no way to save my work. I would appreciate a behaviour where the software works as usual again when you put the key back in. I totally understand, that the software reverts do demo mode when you unplug the key, but I don't understand that when the key is plugged back, there is still nothing I can do until I restart the software. I have three USB dongles on my keychain, one for Max(iLok), one for Cubase (eLicenser) and one for Izzy (yet another system) and sometimes when things like this behaviour in Isadora happen or when I have to carry a USB hub with me just to plug my dongles, I feel unhappy as a honest user who legally buys professional software. If the market could only agree on ONE dongle solution..

    I'll watch the dongle behaviour further and  I'll post it here when I find something that might help reproducing this bug.

  • Dear Daniel,

    Well, first, if you're unhappy you can return the key and I'll offer you a refund. You could then switch to the standard licensing system.
    But actually, you don't have to register if you're using Mac OS. Just register the app, and then zip it and put it on a USB stick. The registration file lives inside the app "package" itself. When you unzip the app on another computer, voilà, it's registered.
    On Windows I can't really do this because the installation procedure is pretty much required to get the .izz file type to be recognized, etc. So unfortunately on Windows it's you really must register each time.
    Best Wishes,

  • Thanks, Mark! I didn't know it would work this way! I don't own the license myself, it belongs to the theatre I'm working at, but I installed Izzy on my personal computer as well, because I need to do some work on my projects at home as well, that's why we have the USB key version. I just downloaded the USB version from the website here and when I tried to use it with the key, it asked me to register with a code which surprised me. I'll tell my boss of your method, this sounds good for the way we work with Isadora. I will buy the program without the dongle for myself at one point I guess, because I don't have access to the USB key all the time when I have an idea at night :)

    Sorry if I sounded a little unfair here -  it's not really an Isadora problem, it's a general problem with all the different licensing methods, but that's a completely different discussion..

  • I am having this problem as well and I don't have the option to save one last time after the connection is lost.  When will that be implemented?

  • I wonder if it is related to a certain batch of USB keys. As I had this problem with a bunch of newer keys belonging to a school I teach at, but when I worked on a project recently with my personal key (purchased maybe two or three years ago) I didn't see this problem once and it was during a tech week with lots of inactive time. The computer never went to sleep, but was certainly sitting there for long periods of time.



  • @cam - In my experience it relates to the machine not the key e.g. it happens with our 2008 Mac Pro running (os1.7) but not on a 2010 Mac Pro (os1.6).

  • I'm having the same issue.  Running on Macbook pro 2008, OXS 10.8.3

  • Dear All,

    Obviously this is an intermittent bug, one that may or may not be related to Isadora. I've written the company that makes the USB keys to ask for their help on this, and will report back as soon as I know something more.
    Thanks for your patience.
    Best Wishes,

  • hello i revival this post. i have the same problem. im on maverick 10.9.3 and isadora 1.3.0f24. i lost the connection with usb dongle and i need to rebbot you have any idéas about this?


  • Dear @cocoberdu,

    Please try downloading the latest drivers from this page
    End User > Sentinal HASP > Mac/Win (as appropriate) / Runtime & Device Driver
    You want the one called "

  • Hi Folks, I realise this is an old thread but I have noticed my USB licence has started doing the same thing, on 1.30f6, Snow Leopard. I just updated the HASP driver to the latest available from Sentinel and no change.
    If the machine goes to sleep then Isadora reverts to demo mode. Happens consistently, and reliably. I rarely allow my computer to sleep when I am working so this is why I haven't noticed this before now.
    Was there a solution found to this, or is it a rare issue?

  • Dear Jamie,

    This is on 10.6.8? Or?
    Best Wishes,