Intermittent problem with timecode triggering

  • Do you have xbee devices in multiple places - if thats the case then using wired serial instead is more difficult as you would need a serial adapter for each device, or add code to pass messages on from one device through another on an additional software serial port on the arduino. This would be TTL serial (at 5 volts), wont manage long distances in noisy electrical enviroments well. If its a bog standard uno then a long usb cable to it will give you a serial connection to the board, but usb can be problematic over long distance as well. Each board could plug in, you would need to configure multiple serial ports, and send the relevent messages to the correct serial port.

    Protocols like midi and dmx are basically ways of transmitting serial data between devices with more electrical protection/robustness. Dmx includes support for multiple devices on a cable run, midi can do it if devices have passthrough on them.
    Probably difficult to implement in time for this run, but dmx would be the route I would be inclined to look at for wiring them up in the long term.

  • Tech Staff

    Yes my send serial actors are inside a user actor and it works. You can see an example HERE.


  • I'm sorry to hear about the dowser problem. I must say that I am personally always dubious about using RF for anything unless absolutely necessary. As you experienced, the physical layout of the space -- and even the number of people in the audience -- can negatively affect the situation. I could list my own personal disasters in this regard here, but perhaps it suffices to say they happened to me in the past. "Once burned, twice shy" as we say in English.

    That being said, I wanted to add one note to Michel's previous post. First this is what wikipedia has to say about RS-232 cable length:
    _The standard does not define a maximum cable length but instead defines the maximum capacitance that a compliant drive circuit must tolerate. A widely used rule of thumb indicates that cables more than 50 feet (15 m) long will have too much capacitance, unless special cables are used. By using low-capacitance cables, full speed communication can be maintained over larger distances up to about 1,000 feet (300 m).[9] For longer distances, other signal standards are better suited to maintain high speed. (See
    RS-485 serial (where you have a balanced/twisted pair, like an XLR mic cable) can go much further. At 9600 baud, you can apparently have a cable length of over 2000m. (See formula here: The higher the frequency, the short the maximum length. (They say on the same page that at 3 mega-baud (3000 kbaud) you can still have a 100m cable.
    So if RS-485 is an option, one should go in that direction.
    Best Wishes,

  • dmx uses rs-485

    rs232 is the full old school serial spec with 12v signalling (can be done with microcontrollers but needs translation chip - if you are doing that you may as well go to rs-485) serial at 5v is likely to get lower ranges than that

  • Unfortunately I don't have the time to reconfigure the devices to be wired this week, but for the future this will happen. I will probably go with a RS-485 option. I did located some extended range 2.4ghz antenna and implemented that yesterday, also moved the transmitter higher up, and pointed all the antenna towards the transmitter. it all worked. But i was still uneasy about it. I know what i'll be working on next week! Also I'll be getting some aluminum to wrap my head with.
    Thanks for all the comments!

  • Well the week wrapped up well. We had 3 flawless shows on sunday night. everything worked as it was supposed to. I have no idea. But i will modify the system so there's a physical backup system in place that can control the stuff.
    Thank you for all the feedback.

  • Flawless shows... that's music to my ears.


  • So an update on this whole thing. I had to get a new computer, old one had logic board problems and was probably part of the issue. It works great and stable. Ran it for 2 weeks all day long at home. I took it to the magic castle this week and it worked for rehearsal and then went nuts during the shows. Now the time code triggers all go off randomly. When I hit play everything goes off. All the sound, music and video files triggered over and over again. Effects that I had remotely controlled all went off as well. I don't know what happened between tuesday night and wednesday afternoon. It sort of worked on tuesday, i was able to get through 2 shows, but wednesday afternoon i went in early to test things and trouble shoot and ended up with a completely useless program. I uninstalled it and reinstalled it half a dozen times. I ended up, after a long, long process, exporting the video out and making a sound track with video for the one main scene I needed. So now I hit play in Quicktime player, it plays one music track and then the video. I am manually activating a few things that I was able to make manually controlled. I have a scrim that comes in on stage, and then travels off stage. used to work with electronics, now there's a string you pull off stage to release the drop, then i have worked my choreography to pull the scrim open rather than having it open on it's own. the other stuff i am just doing without. So at this point I have no idea what is causing all the time code triggers to trigger. there's two sound files that play one after the other. there's timecode triggers connected to each sound player. why would timecode triggers go off when the sound file they are attached to isn't playing? also just now i opened the file and ran the mouse across the menu items selecting "Output" and it triggered some sound effects? (can't replicate it now) what is going on? all this happened after a great 2 weeks of hard core testing and leaving it on for hours on end. I had NO problems. it was all 100% then i go take it to the magic castle on monday and it all goes to hell. At this point I can't use the program at all. I even tried making a new file, which would take hours, but i started it and tried the first few items and it still went nuts. it's like there's something inside the computer and it moved in on monday and for some reason it's not letting me do stuff that i want to do, only what it wants to do.

    2013 macbook air 11" with mavericks(could be problem?) thinking about putting mountain lion on it, but it was working great till show time!
    Out putting serial via xbee to other xbee's connected to arduino's and a projector connected with a vga to rca converter box.

    I read someone partitioned a mountain lion os on their comp. maybe that's an option, also how do i properly uninstall and reinstall Isadora. Are there prefs that maybe are screwed up? or some files that need to be removed manually? again I did nothing to this except take it to the venue and plug it into power and it all went nuts over the course of 3 days. worse an worse each day to the point now that the program doesn't work.

  • Hello @magicdominic
    Which version of Isadora are you using?

    Here is a knowledge base link to installing more than one version of Isadora.
    Also to let you know there is a new pre-release version available publicly since yesterday, with some Maverick fixes.

    It would be good at this point perhaps, if you could send a Bug Report (select topic 'Bug report'), so we can start a ticket to investigate.

  • @magicdominik - When you say "I took it to the magic castle this week and it worked for rehearsal and then went nuts during the shows," I am inclined to think it was not an Isadora issue, i.e., that something changed in the setup from the rehearsal to the show. But let's make sure. @primaldivine can you please follow up with @magicdominik directly to get a more complete report and to find out what went wrong? Thanks.
    Best Wishes,

  • I dont know how many of your problems were for events that were related to xbee communicated parameters but for those that were xbees are not really suitable for high density rf environments. A room full of people with smartphones and other wireless devices can easily ruin your xbee communication. 

    Onyx Ashanti talks about it here (as well as his switch to RNXV over xbee - these instructions have a few mistakes though).
    This also has its problems, but can be easier to deal with in combating the hipster force field than xbees. Apart from cell phones other devices (large motors for moving stage elements) can also give off enough interference to kill xbee communication. They are not really venue safe.

  • I have spoken with someone who knows things about electricity and ground faults and is aware of issues at a specific venue I mentioned. It's a theory that could go like this. I had a projector in a lighting balcony over the audience. it was plugged into a grounded outlet. The RCA cable ran from there to my laptop on stage right which was plugged into a "clean power outlet" and it was only plugged in with a two blade plug, the usb hub was also plugged in with a two blade wall wart, the projector RCA cable was plugged into a vga to rca convert which was plugged in with a two blade plug. The computer was then plugged into the sound board which created a ground to power through the sound system. The sound system is not a balanced system. there is a hum. My friends suggestion for next time is to either un ground the projector, or run an extension cord to the same power outlet that the computer is plugged into.
    On tuesday there was a scan line that ran through my video. It was in the  59/60 hz range as it ran every minute. At the end of the night I jiggled to connector and found it was loose so i tightened it. Scan line disappeared. I had to run the video in quicktime and abandoned isadora completely weds-sunday. It worked. In my free time I tried isadora, it would just trigger everything at once, it was crazy. I reinstalled it and it didn't make a difference.
    The building has many air conditioners, exhaust fans, 4 lighting dimmers in the theatre, sound system with a buzz, coffee machines, microwaves, florescent lights, hundreds of people with cell phones, several walkie talkies, and probably many more things capable of noise.
    I spoke with an engineer at DIgi(xbee makers) and he said there's no issue with cell phones and wifi networks. I'm not sure i believe him. However now that the computer is working again and isadora is running properly I'm inclined to take it in one night and see what happens with it in various states of being plugged in, and see at what point things go nuts.
    I have partitioned the computer and installed mountain lion with a fresh install of isadora. it is working, but i did find that if i double-clicked on the timecode trigger 1.0 module to see what was inside it, and then closed it, the thing would start acting up. so i had to rebuild the entire show file from scratch. It is working. but if i use an enter scene trigger it triggers everything, which is weird because i don't think it should.
    Version of isadora is 1.3.0f24 on partitioned mountain lion macbook air 11". VGA to RCA converter plugged into displayport, usb powered hub with an x-bee plugged into it. Mono sound jack plugged into sound system.
    What ever the problem is it affected my other laptop when i plugged it into the "setup". it caused isadora to go crazy too. I'm back home and I had to reinstall it all and it's working now that i rebuilt the show file again. Fortunately it's going to be a while before I do this again. so i am hopeful i can get it sorted out. It would be nice to do a show the way it was rehearsed.

  • @magicdominik
    " that the computer is working again and isadora is running properly I'm inclined to take it in one night and see what happens with it in various states of being plugged in, and see at what point things go nuts."
    I think that is probably the best thing to do.
    It is hard for anyone else to set up any effective tests without having a similar situation at hand.
    I can tell you that I once had a serious issue on an opera show, in two large civic theatres in Canada that were using Radio sets that were too powerful. In the end I had to ban crew with walkies from standing within 10 feet of my computer. As long as they obeyed, everything was fine! However it was very hard to troubleshoot. I was lucky. Finally one of them stood right in front of me and pressed to talk on the radio and the bug happened immediately. I got him to repeat it and tried again and again until I was sure it was the issue. Then I tested with him stepping further and further away, until he was far enough for it to have no effect, and the issue never ever repeated after that.
    Crazy stuff you cant find out from a manual!

  • @MagikDominik

    "... there was a scan line that ran through my video. It was in the  59/60 hz range as it ran every minute. At the end of the night I jiggled to connector and found it was loose so i tightened it. Scan line disappeared."
    Jiggling the cable might have been a coincidence, with the real issue more likely to be that your video cable crossed a power line. If your cable has to coross a power line try to force it to cross at 90 degrees across it, rather than alongside it. This can help.

    I'd be happy to troubleshoot the set up further with you. I'll start a support ticket and email you that way.