[SOLVED] Communication problems between two computers

  • @mark Thousand Thanks for your reply!

    Sorry, I wasn't thorough enough in my description. Actually the problem probably is not the crosswired cable, because the issue happens also with a router + normal cables. Also, Isadora on my MacPro (with normal ethernet socket) gets an IP address (I can see that in Isadora preferences). And that IP address is the same as in Mac System Preferences.

    However, whether going with the crosswired cable or a router, Isadora on my MacBookPro (with the Satechi multiport adapter/hooking ethernet cable to it) does not get an IP address – or it is (contradicting to Mac System Preferences that shows a valid IP address).

    In addition, as I told before NDI/Syphon connection works both with crosswired cable AND router.

    Any other ideas?

    Thanks in advance,


  • @Lauri 

    NDI most likely uses TCP/IP not multicasting, so the fact that it works doesn't necessarily have any impact on the Net Broadcaster.

    I really don't know what to say. I'm sitting here with my Mac Book Pro and a Mac Mini right across the room; started up and had transmission in both directions without issue. The fact that Isadora doesn't show an IP number is however telling. Is there some other software that might be using IP Port 1234?

    Quit Isadora and try typing this into the Mac OS terminal:

    lsof -Pn -i4

    and then hit return. A long list will appear... look for *.1234.

    For example, when I'm running Isadora, I see

    Isadora   XXXXX XXXXX   34u  IPv4 0x400e15edb828689      0t0  UDP *:53712
    Isadora   XXXXX XXXXX   37u  IPv4 0x400e15ec3a99d29      0t0  UDP *:1234

    which shows that ports 53712 and 1234 are being used by Isadora. The question is, is port 1234 being used by some other program when Isadora is not running? If so, that would explain the problem. You can't have one port being used by two programs at the same time.

    Regardless, try going to the Isadora Preferences -> MIDI/Net and changing the port number to 8000. Then restart Isadora and see if there is an IP address shown in the Prefs.

    Best Wishes,

  • @mark 

    Thank you for your reply. Sorry, but I'm now only with my MBP (which has the problem), I don't have MacPro here (which didn't have the problem). So, I'm testing only with MBP. I made the tests both with WiFi and the Satechi multiport USB-C adapter (which has an ethernet port).

    I did as you asked, quit Isadora, and saw that no other program used IP Port 1234 (UDP *:1234).

    Then I started Isadora 2.6.1b4 (port set to 1234), and Terminal resulted to:


    Isadora   XXXXX XXXXX   12u  IPv4 0x7fc007e82d1aaef1      0t0  UDP *:61605

    Isadora   XXXXX XXXXX   17u  IPv4 0x7fc007e82d1a7131      0t0  UDP *:1234


    Then changed Isadora 2.6.1b4 (port set to 8000), and Terminal resulted to:


    Isadora   XXXXX XXXXX   12u  IPv4 0x7fc007e82c319691      0t0  UDP *:57105

    Isadora   XXXXX XXXXX   17u  IPv4 0x7fc007e82c319431      0t0  UDP *:1234

    Isadora   XXXXX XXXXX   20u  IPv4 0x7fc007e82c31b0b1      0t0  UDP *:8000


    Then I made the same with Isadora 2.5.2

    Isadora 2.5.2 port 1234


    Isadora   XXXXX XXXXX   12u  IPv4 0x7fc007e82c319691      0t0  UDP *:51854

    Isadora   XXXXX XXXXX   16u  IPv4 0x7fc007e82c319431      0t0  UDP *:1234


    Isadora 2.5.2 changed the port to 8000


    Isadora   XXXXX XXXXX   12u  IPv4 0x7fc007e82c319691      0t0  UDP *:52714

    Isadora   XXXXX XXXXX   16u  IPv4 0x7fc007e82c319431      0t0  UDP *:1234

    Isadora   XXXXX XXXXX   19u  IPv4 0x7fc007e82c31b0b1      0t0  UDP *:8000


    But in any of these cases, I did not see the same port used by another application. Hope this helps. Let me know if you need more tests.



  • Oh, and I didn't get an IP address to Isadora prefs (neither v.2.6.1b4, nor v.2.5.2) in MacBookPro.



  • @lauri sometimes the location presets in the network part of apple system preferences get corrupted. It can be good to delete this whole present and make another one. You will have to add each network adaptor again and make new manual IP addresses and netmasks (by the way do these match between systems?). I have had this several times and the new preset sorted it.

  • @Fred Thanks for your advice. Not sure what presets you mean, are you referring to remove these (see image below)?

    I removed the "Wi-Fi" and "USB10/100/1000 LAN" (from the "-" button), applied changes, restarted the Mac, "rebuilt" the network connections, but nothing changed. 

    When either (USB-ERthernet adapter or Wifi) is on, I'm getting an IP address in the System Prefs (and internet works perfectly. However, I still don't get an IP address in Isadora prefs.

    @Fred, please let me know if you meant something else.

  • ... forgot to say that the Location is set to Automatic, as well as Configure IPv4: Using DHCP (which is automatic). So, the IP address is not set manually – should it be, and if so, why?

  • Beta Gold

    But you say you got a ip adress on wifi or lan? Did you enabled fixed IP on your lan connections between the 2 computers? 

  • @barneybroomer Thanks for your reply.

    Yes, I got an IP address in Mac System Prefs on both computers (see the messages above), but Isadora recognised the IP address only in the other computer (MacPro).

    No, I did not enable fixed IP on either computer, and still Isadora on the other computer (MacPro) recognised the IP address.

    And, in my understanding, with Net Broadcaster – Listener pair fixed IP is not needed either.

  • ... and I got the IP address on Mac System Prefs on both machines, both with wifi and lan.

  • Dear @lauri and All,

    This is such a mystifying problem. The fact that Lauri's machine shows a valid IP address in the system prefs, and that the she does not get one in Isadora is just really strange. It can only indicate that the creation of the UDP communications channels is failing for some reason... which could happen if the port was already in use, but the information Lauri provided above seems to indicate that's not the case.

    Can you start by checking your firewall to ensure that you are allowing outgoing connections on the problematic computer.

    If your firewall is open on that machine, then please follow the procedure here to allow apps from "anywhere" to run and let me know if that changes anything. (You can change it back after you've tried this by using "sudo spctl --master-enable" instead of "sudo spctl --master-disable")

    To be clear for everyone, you don't need to move to a fixed IP address if you are using the Net Broadcaster and listener. A IP4 / DHCP connection is fine, as long as the router that is connecting the two computers supports multicasting, which normally it would.

    As I said, I'm kind of stumped about this. I'm sorry for the bother Lauri, but this simply hasn't come up before. In situations like this where I'm really stuck, I usually ask users for access to their machine (under their observation of course) using TeamViewer. If you're open to that possibility let me know.

    Otherwise, I'm probably going to have to compile a special version that outputs some kind of extra information that might show me what's going wrong when Isadora attempts to create its UDP communications ports.

    Best Wishes,

  • Ive had this issues before when using windows and mac machines not too long ago, I don't have a definitive answer on how we managed to get it working but we were suspecting issues with thunderbolt to Ethernet adapters and possibly when a mac is boot camped (and possibly using thunderbolt to Ethernet adapter). In the end after numerous restarts of machines they started working again, that was using a switch and static ips.

    Sorry that isnt much help


  • @edjoynson on bootcamp the cable and adapted has to be plugged in before boot no matter what the IP configuration.

  • @Fred yes I found this out the hard way quite a while back, even when plugged in before hand we still had issues. 

  • @lauri I was referring to the drop down menu that now says location automatic. Make a new location. Also to try make things simpler use only a wired network, no wifi, just one network connection as well. 

  • @edjoynson not sure what this was then. The plug in before boot is documented in the manufactures windows driver limitations.

  • It sounds like very similar issues to what Lauri is having, we didn't think anything of it when it happened. The computer had an ip and could be seen by other computers when pinging them. But like described before, it didn't show an IP in Isadora. It happened on the mac for sure, cant remember about the windows machine. 

  • @mark & all,

    Thousand thanks for your replies and help.

    I did what you Mark asked, and found the following:

    System Prefs Firewall options Isadora was set to “Block incoming connections”. Sorry, should have thought about that. Changed Firewall options to “Allow incoming connections” for all Isadora versions, and got the IP address in Isadora prefs v2.6 and v.2.6.1b4. Although, the same procedure to Isadora v.2.5.2 this did not help – IP address shows in Isadora 2.5.2 prefs.

    However, the procedure to “allow apps from anywhere” did the trick – once. I had the same IP address in Isadora v.2.5.2 and system prefs once, and then I did this “sudo spctl --master-enable” and then “sudo spctl --master-disable” to again “allow apps from anywhere”, and IP address in v.2.5.2 prefs shows

    But what’s strange is that the Net Broadcaster - listener pair works in v.2.5.2, even in Isadora prefs the IP address shows So, v.2.5.2 seems erroneously showing a wrong IP address in prefs. Anyway, now the Net Broadcaster - listener pair works in all versions I have (2.5.2, 2.6 and 2.6.1b4).

    This all applies both to wi-fi and router (MacBookPro ethernet via a Satechi multiport adapter and a MacMini I’ve got at home). So it works in wi-fi network too, if both machines are in the same wifi network. I did not have the crossword ethernet cable with me now, so have to try that later.

    I’m leaving for a longer trip the day after tomorrow, and now extremely busy, so cannot make a TeamViewer session now, sorry. Let’s think about that after my return in March, if still needed.

    @mark Thank you again for your superb help!!!!



  • Troubleshooting Network Issues with Isadora@lauri said:

    Anyway, now the Net Broadcaster - listener pair works in all versions I have (2.5.2, 2.6 and 2.6.1b4).

    OK glad to hear that we finally got you up and running.

    Team: @Michel @Skulpture @DusX @mc_monte @crystalhorizon - please keep this in mind for the future

    I've just written this support article called "Troubleshooting Network Issues with Isadora" -- you can refer users to that if this comes up again.

    Best Wishes,

  • @mark said:

    Troubleshooting Network Issues with Isadora@lauri said:
    Anyway, now the Net Broadcaster - listener pair works in all versions I have (2.5.2, 2.6 and 2.6.1b4).
    OK glad to hear that we finally got you up and running.
    Team: @Michel @Skulpture @DusX @mc_monte @crystalhorizon - please keep this in mind for the future
    I've just written this support article called "Troubleshooting Network Issues with Isadora" -- you can refer users to that if this comes up again.
    Best Wishes,

     Sorry Marc, if I'm intervening here, with all respect but i think the support article is a bit misleading about the multicast point!
    I'm not 100% sure about how Isadora and the net Broadcaster is handling this, but how usually multicast software should do it. And as I already used the net broadcaster with several dumb hubs, I'm pretty sure that this works fine. And if I'm wrong about that, I would like to know how this is handled, because I want to know, why I need to buy expensive routers and/or switches with a specific function, unless I have a lot of traffic! Not talking to use several routers in one network, just to split it even without routing to another subnet.

    This is how I understand multicast and effecting network devices (taken from here, as it was the most simple description I found):


    Hubs, routers, and switches

    Configuring a network to work with multicasting requires configuring the
    physical devices that connect the computers to each other. These are
    hubs, routers, and switches. A network uses hubs, routers, and switches
    to send information from one part of the network to another part. Hubs
    pass all the information they receive, without filtering it. Routers may
    filter some information, and switches usually filter information.

    In most cases, hubs do not require any configuration. Configuration is
    required only in hubs that include capabilities that are normally found
    only in routers or switches.

    Configuring for multicasting

    Configuring a router or switch to use multicasting requires that the
    router or switch be IGMP capable. The specific steps that are used for
    configuring any particular router or switch require information that is
    specific to that router or switch. Information is usually available in
    the documentation that accompanies the router or switch, or from the
    manufacturer's Web site.

    More information

    If you suspect that your router or switch might not be correctly
    configured for multicasting, you can test this possibility by using a
    hub instead of a router or switch. If multicasting works when the
    computers are connected through a hub, and not when they are connected
    through a router or switch, the problem is probably due to the
    configuration of the router or switch or to the number of hops between
    the two computers.


    For my understanding, a full working, by all network devices supported multicast network is needed only, if you have a lot of traffic between them, like streaming video, or transmitting a lot of parameters parallel, etc.

    And my personal extra bit is, that a simple non managed switch should usually work like a hub in this case and just broadcast the multicast signal. Only more expensive managed switches should have these issues.

    Again, I might be wrong about this, but thus meaning everything I learned about RTP or audio protocol issues, like dante or  Motu might not be right, so I would be happy to get an update about this!