assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Classic Video-In Watcher no longer working



  • Hey All

    I work with a dance group that's been using some of the same izzy patches and files since izzy 1.0 and unfortunately haven't had the time to update them since they're almost constantly using them in performances. Just recently the Classic Video-In Watcher has stopped outputting the video feed. They recently ran the same show using Izzy 2.6.1 and had no problems but as of last week with seemingly no changes the Classic Video In Watcher won't show anything. Any advice? I know the best solution would be to rebuild the patch but unfortuantely I don't have the time and they're not fluent enough in programming to feel comfortable doing it.

    In some instance we have simply replaced the Classic Watcher with the modern one but it then completely tanks the FPS.

    Any suggestions welcome! (They're using a first gen Mac Pro)



  • @jericksondesign said:

    They recently ran the same show using Izzy 2.6.1 and had no problems but as of last week with seemingly no changes the Classic Video In Watcher won't show anything.

    Questions:

    1) What version of Mac OS or Windows are you using
    2) What version of Isadora are you using (I gather it's 2.6.1... but please verify)
    3) What is the capture source? Webcam? Blackmagic Device?

    You say that "as of last week with seemingly no changes" -- are you saying that they didn't change the patch, or the version of Isadora they are using, and the video input stopped working?

    What do you see in the Live Capture Settings once you start capturing? Do you see a moving video thumbnail for the channel on which you're capturing?

    Are you capturing on the wrong channel? For example, here's me capturing on channel 2 instead of channel 1

    If that were the case, and the Video In Watcher was set to channel 1, you wouldn't see aything.

    Please answer questions and check the capture channel, and then write back.

    Best Wishes,
    Mark



  • Hey Mark, thanks as always for responding

    1. Yosemite 10.10.5

    2. Izzy 2.6.1

    3. The capture source is cameras going through a BlackMagic

    Correct. They ran the show a few weeks back. Saved it. And now this week they were planning on rehearsing the piece but were unable to. It isn't a channel problem because they're using the same settings when swapping to the updated Video In Watcher. And even before that in the live capture settings you can see the thumbnails. 

    Really I just wanted to make sure there wasn't some sort-of update in 2.6.1 that would disable the Classic Video Watcher.

    Now that we've switched from Classic Video In to the updated actor it's suddenly started jumping scenes.



  • @jericksondesign said:

    Really I just wanted to make sure there wasn't some sort-of update in 2.6.1 that would disable the Classic Video Watcher.

     No, we haven't changed 2.6.1 in a long time. It is not some kind of update -- unless they somehow changed their Blackmagic drivers.

    1) Please make sure they can see the Blackmagic input in Blackmagic Media Express
    2) When they successfully do that, please make sure that the format settings in Isadora are set to match

    Unfortunately I'm in bed with a cold and not near a black magic device, so I can't really test at the moment.

    @DusX -- can you try the Classic Video Watcher with a Blackmagic? I doubt the macOS version makes a difference.

    Best Wishes,
    Mark



  • @jericksondesign said:

    Now that we've switched from Classic Video In to the updated actor it's suddenly started jumping scenes.

     That's bizarre. Are you willing to post your patch so we can see? Is the video output or trigger output connected to a Jump actor by accident?

    Best Wishes,
    Mark