assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Guru Session #14: Intro to Projection Mapping with IzzyMap (Fri May 15th, 6pm CEST/5pm GMT/12pm EDT/9am PDT)


  • Tech Staff

    @demetri79

    well they are not layered. If you look closely they are blended in additive mode. The eye you see at the "stage 1" output is slightly brighter than the one you have in the "virtual stage" window.To see that in your example: duplicate the "Stage 1" actor and move the connection of the "get stage image" from the MultiMix to the copied Projector actor. You will instantly see the brightness of the eye drop.

    Best Michel



  • @demetri79 said:

    curious if people have done testing already and have insight into what method to be generally more processor cost effective to achieve realtime fx manipulation

    I cannot say that we've done specific testing on this. But my guess would be that rendering each video to a virtual stage, and then pulling it back using Get Stage Image would be more efficient than doing several Chopper actors and then Matte++ actors to put the image back together. There's fewer layers in the former suggestion.

    the layer param of the projector feeding the virtual stage does not make a difference

     This statement is not true. Look at this example patch below, where I've got four Shapes actors feeding the virtual stage.

    On the left side, the top Projector is on layer 0 and the bottom left projector is on layer 1. Thus the green circle (the bottom shape)  is rendered on top of the white circle.

    On the right side, the top Projector is on layer 1 and the bottom projector is on layer 0. Thus the white square (the top shape) is rendered on top of the white circle.

    Note, however, for this to work, the blend mode must be set to 'transparent', If it set to additive, you will not see any layering.

    Best Wishes,
    Mark

    Best Wishes,
    Mark



  • @clement said:

    MacOS is 10.11 but I will install 10.14 soon, so I will post comment if the issue left due to OS.

     @Woland is the 10.11 expert since he's got that OS on his machine. @Woland can you answer @Clement 's question?

    Best Wishes,
    Mark


  • Tech Staff

    @clement said:

    Does someone have slowdown in Izzymap when moving shapes handles on MacBook Pro with graphic card NVIDIA GeForce GT 750M ?The issue appeared with V3 upgrade, and weird graphic lines fill the shapes now…MacOS is 10.11 but I will install 10.14 soon, so I will post comment if the issue left due to OS.

     I've never seen that before. Can you post a gif or a screenshot showing the issue? 



  • @Woland  Hi Lucas,

    Thank you for your answer, I updated my OS so I can tell what is happening in Izzymap / Isadora 3 :
    ( I first upgrade to Mojave, but I didn’t know that Nvidia Graphic cards were not well managed since this OS, so I downgraded to Sierra, not so easy…)

    - MacOS 10.11.6  /  El Capitan : Lag when moving handle + Display issue
    - MacOS 10.12.6  /  Sierra : Display issue
    - MacOS 10.14.6  /  Mojave : Display issue

    With MacOS Sierra the lag mentioned above disappeared but the weird graphic lines are still there ( see attached files ).

    I tested and noticed that if Isadora Preferences > Video > OpenGL > Full Frame antialiasing is checked, the graphic lines issue is gone, but can this option have an effect on computer resources ?

    A strange thing is there is no problem with Isadora 2, on El Capitan or higher.
    Maybe the issue comes from the NVIDIA GeForce GT 750M card drivers and the way apple is replacing OpenGL by Metal : I made the few updates available for Cuda drivers, this laptop is not the newest but is still a good hardware for single task.

    I sent a support ticket before the post above and Ryan Webber answered that he will look into it, but I wanted to know the experience of users with the same computer and graphic card.

    A last thing, I don’t see the notifications “@Clement“ on top of the forum, but others like “votes“ work, perhaps due to the web browser ?

    Thanks ! Best wishes.
    Clement


  • Tech Staff

    I can't seem to replicate this issue (even when enabling the setting you mentioned). I remember seeing something similar in a version earlier than 3.0.7, but can't repro this in 3.0.7 nor in the current beta. Either way, it seems to be a purely cosmetic issue in that the lines only show up inside the izzymap window and not on your output. I'd be interested to know if anyone else has seen this too.

    @clement said:

    A last thing, I don’t see the notifications “@Clement“ on top of the forum, but others like “votes“ work, perhaps due to the web browser ?

     This can be changed if you click on your profile and go and modify your settings



  • @Woland

    Thank you Lucas for your answer, the issue is just cosmetic while it was laggy on MacOS 10.11, and checking “Full Frame antialiasing“ in the Preferences can temporarily help in case of complex mapping.
    I think the way Isadora works with OpenGL and the graphic card's drivers are involved, but it's not so annoying.

    And Thanks for the Notification Tip, I'm not sure I ever looked at this setting page before ;)

    Bye !



  • Hi Folks

    I finally found time to look at the guru #14 (projection mapping is something I do quite a bit) and have a question... the output slices seem jagged. I always have a problem with it especially with large scale projections (to be expected to some degree) when the slice is tilted at a slight angle. I have tried different output resolutions and aligning with my projector's resolution but really it just is noticeably jagged. I have far less problem when using another well-known mapping program. Am I going about this incorrectly? Are there settings inside Isadora that I've missed?


    Thanks for any assistance, and special thanks to Mark et. al. for these wonderful guru sessions!  - John


  • Beta Tester

    1st thanks a lot @mark for those session they are really useful !
    I had the same problem than @JJHP3 with stairs appearing when you change a corner position
    turning the line to a slight diagonal makes saw tooth, I thought It was because of my projector definition,
    could it come from something else?

    Bests


  • Tech Staff

    @jjhp3 said:

    Am I going about this incorrectly? Are there settings inside Isadora that I've missed?

    We'd need to know what your current settings are in order to answer that. Make sure that the output of your Projector actor matches your Stage and physical display's resolution (bottom right in Izzymap), and make sure that your Stage's resolution matches your physical display's resolution (in Stage Setup). 

    If you could send a simple test file with a mapped image that produces a jagged edge that would be helpful, I can't seem to produce a very sawtoothed edge on my displays with either angled slices or slices that have been rotated.


  • Tech Staff

    @bennnid said:

    I thought It was because of my projector definition

     What is your projector definition? The higher the resolution the better (obviously) but also understand that the larger the image you're trying to project on a surface, the more visible the individual pixels will be.