• hey everyone,

    when i try loading data with data array actor, i simply can't. after watching the guru session #3, i downloaded the tutorial files, and the first thing i tried was adding a new line to the file: 


    but data array didn't update and read the modified file with added data. then i tried simply copy-paste'ing the data found in the original file, but i failed loading that either. as a matter of fact, even if i deleted or changed the name of the original file with the set, data array actor kept working as if the file was still in its place :/ 

    is there a very fundamental step i might have overlooked before using data array actor and alikes? the first thing came to my mind was that maybe isadora required some kind of permission to have access to folders in my computer, but then, the original file in the tutorial folder was able to be loaded, so i guess it's not that.

    also, when i try to access a txt file in another folder, "/"s i use in typing the file path for the "file path" input of the data array turn into "_"s. is this what's supposed to happen, or maybe there is a problem with the way my keyboard inputs are transmitted to the isadora universe?

    thnx for your help!!! ❤💛💚

  • Beta Platinum


    There are some things that need to be considered to get new data into the Data Array module. The first is while debugging, to temporarily disable the option for ‘local copy’ - as this is storing a memory of the contents of a txt file. Although triggering the parameter ‘read’ is intended to rescan the associated txt file. If this is not happening you might consider checking your files to make sure the Isadora  file and the txt file are in the same directory of your computer. At the moment, from what I understand, the Data Array reads individual lines as a single output. Those lines can have multiple items of data that are tab separated. Any new data entered into the text file is either on a new line or after a tab in an existing line. However, if you have lines in your txt document with data points separated by tab - you will also want to set the parameter option for ‘items’ to create outputs on the Data Array to see them. Otherwise, by default, only the first item in a tab separated line will be sent to the module output. 

    I did look up the Data Array in the Isadora Manual but it has not been updated to include all of the current parameters.

    What computer platform are you using? It may help if you provide /upload the txt file that you have edited/modified.

    Best wishes


  • @bonemap thanks a lot for your reply! i slept on it for a night, and then disabled the local copy option as you suggested, and now i can get the updated data with the data array actor. 

    yet, i am still unable to open a file that is not in the same folder as my working izz file. say, my izz file is in a folder, and a folder is inside that folder ("folderB") that has got the dataset with a name "dataset.txt". when i type "folderB/dataset.txt", data array actor converts my input into this format: 


    and doesn't read the file named dataset.txt, but keeps reading the old values -if there has been a dataset which was read by the actor before, even when local copy option is disabled. 

    i am on mac os big sur 11.2.3. here is the file and the datasets i used to try this: deneme.izz I can't upload txt files but here they are, just plain numbers and letters in 10 columns, 3 rows.

    deneme.txt was this file (columns separated with tabs and rows with return): 11 22 33 44 55 66 77 AA BB CC 88 99 1010 1111 1212 1313 1414 DD EE FF 1515 1616 1717 1818 1919 2020 2121 GG HH II
    dataset.txt was this file (columns separated with tabs and rows with return): 1 2 3 4 5 6 7 A B C 8 9 10 11 12 13 14 D E F 15 16 17 18 19 20 21 G H I

    having said that, i am content with being able to change or update the data file and data array actor being updated for the moment.

    best 💖

  • Tech Staff


    Hi there!

    Just seeing this thread; are you still having issues with the Data Array actor? If you do, please send in a Support ticket by filling out the following form:


    Sadly I'm a Windows user, but our technical team has a lot of Mac users :)