Scene Jump / MoviePlayer and SoundPlayer out of sync?


  • Hallo everyone,

    I'am very new to Isadora, so please forgive me I don't know what I am doing.

    I am making a Audio/Video Installation where I have to project with 4 beamers onto all 4 walls, but the 4 walls are actually Fabric with curved corners... and sound is played by a 8 channel rig evenly distributed around the projection.

    Its' 84 Talking heads of different people of a small german city, the have been interviewed and now they 'talk' to each other about various topics.

    So I am rendering 4 Videos without sound, and separat (out of stupid workflow reasons) 3 channel audio (LCR) for every of those videos, but they all are intended to play along in sync, like they would be one media file.

    Maybe I don't know how, but it seems to me the MoviePlayer is not able to rout the LCR like a SoundPlayer, that's why i am splitting the files into sound and video.

    But now to the real problem:

    I have quit a lot of before mentioned scenes wich I would like to trigger with a Jump Actor on MovieLoop end. But it seems, every time the jump actor jumps to a new scene the audio gets a bit out of sync. If I jump manually (with spacebar) this seems not to be the case...

    I am confused. What would be the right way to build this kind of patch? 

    Sorry for my confused english, I hope it's even understandable... but I am tired and the deadline is pretty soon :)

    Thanks in advance...

  • Tech Staff

    @unmenge said:

    how

     This is actually a bit of a difficult project since the Movie Player doesn't yet have the new multi-channel features the Sound Player has in Isadora 3.0.8

    The best way to keep 4 videos in sync is actually to make them into 1 video (eg: 4 hd videso tiled, makes a standard 4k video) and then Chop it into its separate 4 video streams inside Isadora using the Chopper actor. The movie player can play multi-channel audio, and should support 8 channels if they are setup in the standard way for 7.1 audio.

    This help article should help you create a test video file with 7.1 audio https://support.troikatronix.c...
    If you can get a test file working, then I would suggest putting all 4 videos and the audio into 1 file. This will keep all media streams in sync.