@aidan said:

Many thanks for the concise and immediate response!I will try your proposed soultions and approach, Mark.Stay safe! Aidan

 Dear Aidan,

I sort of couldn't let this go. I actually tried my feature request, but it didn't really improve anything. In the end, it comes down to the accuracy of the Pulse Generator, which will also vary very slightly for the same reasons listed above about the callback.

That said, I realized your patch has a flaw: you were only allocating 10 particles. Sometimes, this means they never reached the fade out time and simply disappeared... which might be part of the flicker you see. I've modified your patch to work a slightly different way: instead of using the size to make the circles get bigger, I used the 'z velocity' input. I also ensured that there are enough particles. You can vary how many circles you see by changing the 'hold time' input.

In addition to trying this patch, try setting the Isadora Preferences > Frame Rate/Tasks > Display Refresh Lock to 'Off' instead of "Scaled"

There's still some visible jitter. But I'm not seeing the flicker as much given the fixes I made to your patch.

Best Wishes,