Cmd+Shift+C toggles between seeing the Control Panel and the Scene Editor Cmd+Shift+S toggles Control/Actor Split Cmd+G hides stages Cmd+Shift+F shows stages.  If you press Cmd+Shift+F twice and see no output, go to Isadora > Preferences > Stages and make sure you have your Stages set up properly. If you don't have a display assigned to the stages, nothing will show up. Also make sure that your video source is connected to a Projector actor, and that the Projector actor's intesity is 100 and that it's "active" input parameter is set to "on". Best wishes, Woland