Looping problem in v2.0 with Sound Movie Player

  • Hi folks,
    I've submitted a bug report, and Ryan is on it, but I thought I'd throw out this incredibly strange problem I've encountered.  So as you can see in the screenshot I attached, I have three looping sound movie players playing an mp3, routed to a different audio source, and each with a different play start position.  As the track which starts at 80 hits the 100 position, there is a slight hitch before it loops back around to position 0 and keeps on playing.  And then, when the track starting at 50 hits the 100 position, a hitch on this player as well.  And then when the track which starts at 0 hits 100, there is a much larger hitch from all three players.  I looped through them once, and around when the track starting at 50 was at about 44, all audio output stopped. The position indicator kept moving until it hit 50, and stopped.  The other two players's positions started running backward!  The track which started at 80 counted down until it hit 0, and stopped, but the track which started at 0 ran backwards and looped back to 100 when it hit 0, and kept playing (again, all of this without sound output).  Does this all make sense?  I thought it was a looping problem related to this specific file, so I edited the file externally to create a very long file, thus bypassing the need to loop within Isadora.
    However, in my run this evening, all audio cut out in a scene which did not have this particular file playing.  It did not occur at a loop point this time.  However, when the audio cut out, the position on all of the sound movie players continued until 100, and then started to play backward.  The movie player in this scene was unaffected.  I've included a screenshot of this scene as well.
    It's a rather complicated show, and I'm not sure I have the time to re-cue the entire show using movie player or sound player.  It would be easier for me to edit all of my looping files externally to negate the need for looping, if this is indeed a looping problem, and not a problem with sound movie player itself.  Anyone have any thoughts?  I'm going to transfer the entire show to another computer, just in case it is hardware related.  And if it's helpful, I'm on a Mac Mini running Mavericks and triggering Isadora via an ETC Element lightboard, and an old MOTU 828 Mk 1 as a firewire audio interface.  Thanks in advance!
  • Izzy Guru

    No screenshot attached i'm afraid.

  • Oops, let's try this again... 37008d-screen-shot-2014-10-14-at-10.30.35-am.png 65c3f8-screen-shot-2014-10-14-at-10.26.14-am.png

  • Welp...I'm an idiot, and I've discovered the common denominator in the scenes where my audio would cut out.  In all of these scenes, I was using files that I edited with Soundtrack Pro, rather than with Logic.  I knew Soundtrack Pro is no longer officially supported in Mavericks, but the program still works for me, and I prefer to use it for very specific purposes.  So for whatever reason, these files are corrupted, but I guess I don't understand why all audio would cut out and the strange behavior with the position would occur on all of the sound movie players, not just the one with the corrupted file.  So maybe this is a bug, or maybe just chalk it up to user error.  Opened all of the corrupt files and bounced them in Logic, and everything ran as it should.

  • Izzy Guru

    Really? Wow I was not expecting that?

    That's pretty crazy!

  • @knowtheater

    It would be good if you could provide us a Soundtrack Pro and Logic version of the same audio file. This seems really really strange, and I'd like the team to have a look. Please stay in contact with Ryan about this and give him the files.

    Best Wishes,

  • Files have been sent along.  Like I said before, the show ran just fine for two runs yesterday with these changes, but based on your responses I'm hoping I didn't attribute a false causation to the Soundtrack files, and the problem will rear its head again for tonight's show with an audience.  But again, it seemed like it was the only commonality between the scenes that were crashing, so I don't know.  Thanks for looking into this!

  • Well, just to keep folks updated, it looks like the Soundtrack Pro theory was just a red herring (though I guess it's really time to chuck stpro anyway...).  Everything ran flawlessly for three days, and as I was making some final edits, the problem arose again.  Multiple crashes, as well as audio cutting out with no crashes.  We got through the show okay, but there were a few tense moments!
    So once the show was open, and I had some time to investigate further, I noticed that all of the sound movie players which are initialized as "off" show the positions either at the end of their loop or a random number, although this was not always recreatable.  For the most part, the players will still play properly when they receive the on trigger.  I can also turn the player on, and then back off, and the position shows 0.  And if I jump out of the scene after it is reset to 0 and then jump back in, the position still indicates 0.  However if I jump to a new scene without activating the players, the position still indicates the non-zero number. 
    I then remembered a bug I had encountered about a year ago that I had posted to the forum [HERE](http://troikatronix.com/troikatronixforum/discussion/827/audio-playing-even-when-movie-player-visibility-is-off#Item_8), and it might hold the clue for a possible workaround.  What if I set all of the players to "on," set the speed to "0", and then trigger everything to start playing by changing the speed to "1"?  Mark mentioned that there was a bug in the preloading code for audio, but since this was from several versions ago, I figured that it would have been fixed.  And from what little I could understand of my crash reports, it seems like the "background preloader" is the problem; I wasn't using any manual preloading.  I made these changes, and haven't had a crash since, though I did have to use a manual scene preload before jumping into a few of the larger scenes.
    Is using the speed to control when players turn on and off standard operating procedure?  Have I been programming incorrectly all this while?  It just seemed more intuitive to toggle on/off.  What I love about Isadora is that there are so many different ways of going about achieving the desired effect, and yet since I'm self-taught, I'm sure my patches are often inefficient and byzantine.
    Thanks again for all your help.  Overall v2.0 is awesome, and your support team has been top notch!

  • Dear @knowtheater,

    Please file a formal bug report to ensure this gets investigated and solved. http://troikatronix.com/support/isadora/
    Once we open a ticket in the help desk system, you can .zip and send us your bug reports so I can have a look.
  • Tech Staff


    there is an ongoing ticket for this already. I am still trying to recreate the problems at this time, and investigating audio preload as well.

  • And, once again, I spoke too soon.  After making the initialization changes and having it run perfectly for a few days, I'm once again greeted with crashes and sound cutting out.  I'm not up in arms about the issue, as I know it's a pre-release and Ryan is investigating, but it's really frustrating that I can't recreate the problem reliably, and every work around seems to work, until we are in a show and it doesn't!  As we still have a few weeks until we close this show, @mark is there any way to download a v2.0 for windows, just to see if that will get us through the run?  Or perhaps use an older version of Isadora, as I'm not really utilizing any of the v2.0 features?  What is the most stable pre-release out there?

  • Beta Platinum

    Its easy to install different Isadora versions. There should be one out there, that will do the job.

  • @feinsinn, yeah I installed ver 1.3.1f06, and while I was a bit worried about compatibility going from a show programmed in ver 2.0 to an older version, everything seemed to run just fine, except the few instances of the Movie Player Actor, which I needed to swap out with the 1.3 Movie Player.  We've another show this afternoon, so here's hoping all goes well!

  • Tech Staff

    Details on installing multiple versions of Isadora are available here:

    Usually a very good idea, while using pre-release/beta software.

  • @knowtheatre
    Did you by any chance add markers to the tracks in the Soundtrack Pro file/s?
    I saw a VERY similar but possibly unrelated issue in a support ticket for someone who has added special markers to their file. It is still an ongoing ticket in the support system as well...

  • Hmm, I did use markers in those tracks mixed by STPro, but I was still experiencing the same issues after I had swapped all of those files for tracks mixed in Logic, so I don't think that's the issue.  I did go back to ver 1.3, and everything ran smoothly for the rest of the run.  Ryan sent me a test file that I've been running, and I am getting errors within that test file.  But the errors occur so sporadically, I can't get a lock on what's causing it.  Seems to happen more with audio-only quicktime than with .mp3, though.  I'm also experiencing some really weird display things going on.  Check out this screen shot from after an error in Ryan's test patch. 671bb9-screen-shot-2014-10-30-at-8.43.03-am.png

  • Tech Staff

    Hi @knowtheatre

    This issue has been a hard one to nail down, I just can't get predictable results yet.
    I have flagged it for @mark to look at (ticket 1731549 ), hopefully he will have some additional insight.
    In the meantime I have tried some more targeted tests, still with unpredictable results.

  • Yeah, everything about this is very odd.  I ran the rest of the show on ver. 1.3 without any problems.  Programmed the next show (still in 1.3), and ran through tech and the first week of shows without issue, and then prior to this morning's matinee, the SM called me saying the problem had come back, with scenes playing just a second of audio and then cutting out.  After a restart of Isadora, the show ran fine.  I was hoping switching to ver 1.3 had solved it, but I guess not.  @mark, do you have any thoughts?  This isn't a problem with my specific hardware or patching, right @DusX?  You are seeing the problem, you just can't consistently recreate it?  Should I switch to running audio via the sound player actor rather than the sound movie player?  I really prefer the sound movie player actor features, but if the sound player is more stable, I can change the way I patch...

  • Tech Staff


    can you post an update to the support ticket? I really want to solve this.

  • Sorry for the delay; my daughter decided it was time to come into the world last week!  To update the support ticket, do I just need to reply to the previous emails?  I've been informed that we have had a few more audio cut out problems in the past week, but nowhere near the difficulty we had with the previous show.