assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Testing ffmpeg–>syphon–>isadora app




  • For my drone project I have quickly assembled a ffmpeg to syphon app, which allows to access drone camera using tcp://192.168.1.1:5555 url. I found that ffmpeg player is quite versatile in what it can play, and although I have not finished testing this app with the drone (for example, there is no sound coming out of drone tcp stream, and I am not sure how this app will handle that absence).

    There are a lot of third-party libraries packaged with this app, and **I would appreciate if fellow-isadorians could quickly load it on their macs** and confirm that it works/does not.
    By default it will load the bunny rtsp stream we all come to love, and if that works, that's all I am asking to test at this point.
    However, one can also drag and drop movie files on the app to see if that works, or change the url of the stream in 
    ardrone-ffmpeg.app/Contents/Resources/settings.xml (right click on the app –> show package contents ––> etc)
    Thanks for your help.
    Once I am happy with this app, I would like to opensource it and release the binary.
    Thanks.
    --8

    f0a57c-screen-shot-2015-10-26-at-5.33.01-pm.png


  • Tech Staff

    @eight

    ardrone-ffmpeg not opening on my system el capitan.

    Best Michel



  • @Michel : Thanks! It runs on two of my macs OS X 10.10 and 10.11. Would you mind openning terminal, executing 

    PATH_TO/ardrone-ffmpeg.app/Contents/MacOS/ardrone-ffmpeg
    And posting the error you are getting?
    Thanks again for your help.
    --8

  • Tech Staff

    @eight

    Here you go:

    dyld: Library not loaded: /usr/local/lib/libboost_thread-mt.dylib Referenced from: /Users/michelweber/Desktop/ardrone-ffmpeg.app/Contents/MacOS/ardrone-ffmpeg Reason: image not found Trace/BPT trap: 5



  • @Michel: Thanks! That's exactly the kind of thing I hoped to discover.

    --8


  • @Michel: if you have a free minute, I would appreciate your trying to open the new version. Thanks.

    --8

  • Tech Staff

    @eight

    Minimal different error message.

    dyld: Library not loaded: @loader_path/libboost_system-mt.dylib Referenced from: /Users/michelweber/Desktop/ardrone-ffmpeg.app/Contents/MacOS/libboost_thread-mt.dylib Reason: image not found Trace/BPT trap: 5



  • @Michel: Thanks! I think i fixed that problem too. Could you give it a last go?

    Thanks for your help..
    --8

  • Tech Staff

    @eight

    It works fine now, also dropped a .h264 movie on it and it worked as well. Though it does not fill the Isadora preview screen to full. See attached image. Great Job.

    Best Michel
    1e0bb4-bildschirmfoto-2015-10-28-um-19.15.44.png



  • @Michel: Thanks a lot for your help!

    Re: preview screen: It behaves OK on the Izzy I am testing it with (it leaves black vertical bars, which is to be expected due to how the preview window size set in Isadora preferences). Beside the Isadora version, it may depend on the syphon actor in theory (I am using _Syphon Receiver_). Syphon's Simple Client works OK too.
    In the attached version **xml settings** **have been fixed**: play on top, set window resizability (does not affect the syphon stream size), set the initial window dimensions.
    There are still some fixes to be done vis-a-vis videostreams with no sound. 
    **EDIT**: Just noticed that in my original screen shot there are black bars on all four sides of the Isadora preview –– that screen shot was done on a different computer, perhaps with a different Isadora version.
    --8

    deecc9-screen-shot-2015-10-28-at-3.19.15-pm.png


  • Tech Staff

    @eight

    Checked again, if I set the height and the width in the xml file to the movie size it looks fine in Isadora.

    Best Michel



  • @Michel : I added a default option, which sets the window size to that of the movie. I think this is best for preserving texture resolution throughout the entire movie–>ffmpeg player->syphon pipeline. This behaviour can be changed in the settings.xml

    The only remaining issue, I think, is the videos without sound.
    --8

    a49005-ardrone-ffmpeg.zip


  • Tech Staff

    great work @eight !!


  • Tech Staff

    @eight

    Perfect.



  • Attached is the application, which handles streams without sound.

    I added some control options, described in the settings.xml
    Confirmed working with Ar Drone 2.
    Thanks @Michel and @DusX for your help and encouragement.
    --8

    184eda-ardrone-ffmpeg.app.zip



  • Hi

    Just want to add that this works perfectly with a **rtsp** stream from my drone as well
    thanks!


  • Isadora and drones. You all never cease to amaze me. ;-) Good work @eight.