assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[Solved] Video don't plays smoothly, while Isadora shows more then 50FPS.



  • Dear developers, Today i tested isadora with gtx 730 cards (I plan to buy gtx 1070 instead my current card gs 8400). It works great! FPS shows me more then 50 fps, while playing 4x720p videos simultaneously. I was delighted! BUT, I've found, that while FPS are good, output video(also on preview control) start to twitch. It looks like isadora drops few frames. Could you help me to know what is cause of this issue? It happens when I plays 2 and more 720p videos simultaneously. My output resolutions were 1280x720 and 1920x1080. Source files was 1280x720 mov photo-jpeg (tomorrow I will try dxv also). I've tried to change preference settings (vertical sync, service task and other), but no result. I can make video-illustration of this twitching on my mobile if it's need. Thanks in advance.


  • Tech Staff

    photo-jpeg videos at HD sizes are very large. My first guess is that the hard-drive couldn't keep up with the data transfer.

    Also, you mention DXV, this format will be no better, and offers no advantages. I would suggest using HAP instead of dvx and photojpeg.
    But note HAP files are also large.. so the data transfer issue will not go away.
    If you have multiple drives, you can move half the content to each and stream them this way. That will decrease the load on the drives and allow better/smoother transfer.
    Also, its worth considering during setup/design the usage of each video. If a video is not going to be interactively manipulated in a show, you are likely better off using another codec like h264 (.mov on Mac will use AV foundation acceleration, and on PC .wmv will use DirectShow's acceleration)
    These compressed files will use less of your hard-drives transfer capability, but will use more processor for decompression (however, AV foundation and Direct Show utilize all CPU cores very well)

  • Tech Staff

    A good SSD; even an external one via USB 3 or Thunderbolt will work.

    As DusX said I would look at codecs. photo-jpeg is not the best. 

  • Tech Staff

    Under Tip 4:

    For HD resolution the Apple Pro Res codec (APR 422 or 4444) has performed best in our tests on both Mac OS and Windows, especially when running off an SSD hard drive.


  • Tech Staff

    Yes, APR plays well on Windows via the QT engine.. the downside is they are harder to make on Windows.



  • Is there any difference between APR 422 and APR 422 LT? I always use the LT version for size reasons but have not idea if LT compromises playback in 2.2.

    Thanks 


  • We've solved this issue, after upgrade video card to gf 1070. it seems VRAM size plays major role to solve this issue.

    Now I able to play up to 6 separate videos simultaneously without any dropped frames.


  • Hi All,
    I have same kind of issues with a MBP 15' Retine 2,2 GHz Intel Core i7, 16 Go 1600 MHz DDR3,  Intel Iris Pro 1536 Mo.
    Stage 1 :  1280x720 via HDMI out and Stage 2: 1024x768 via minidisplay port. No effects, isadora prefs 1280x720 / 25fps.
    Movies are : 1280x720 / 25fps - Apple ProResLT.
    Sometimes I send a movie to Stage 1 only, and there are lots of random mini-lags, sometimes less, while Isadora status is solid 25fps.
    Sometimes I send  a single movie to both Stages, same behaviour, sometimes noticeable lags, sometimes less.

    Movies are playing fine in QT and VLC
    Forcing Isadora to 50fps seems to settle a little bit things, but not completely.

    Do you think it's a video card related problem (VRam) ? (I think maybe I should stop use laptops for video..!)

    Any advice ?

    Thanks.
    Philippe



  • After testing 3 deferent cards (old gf 8500/2GB VRAM, gf 730/2gb VRAM and gf 1070/16GB VRAM), also on my laptop(gf 750M/2gb VRam), my thought is VRAM - main issue of dropping frames(while isadora shows normal fps) when playing several videos simultaneously(or playing video on several stages). I suppose this is main reason in this case. Try to use "proccess explorer"(small tool for analyse PC-processes ) to determine GPU-usage, when this lags appears. Also, this tool helps you to determine HDD activity(speed of reading) to know if hdd transfer speed achieve maximum. In my case all cards with 2Gb VRAM shows me 80% of GPU using, when this lags happened. Hdd speed was not too much(less then 10mb/sec). Which video card and how many VRAM installed on your laptop? And please note, this is only my thought.



  • The video card is an Intel Iris Pro 5200 with shared VRam (Max 1,5Go) (as everymac.com says :http://www.everymac.com/systems/apple/macbook_pro/specs/macbook-pro-core-i7-2.2-15-iris-only-mid-2015-retina-display-specs.html)

    Can we say that to avoid lag, we must avoid videocards with shared VRam ?

    Best
    Philippe



  • @ fifou I would suggest having a dedicated video card for any media playback system. Unfortunately apple have really dropped the ball on this and only the most expensive machines now have these (I see a lot of cheaper end PC laptops with 2 and 4 gig cards - from $800, but the first apple machine with a real and pretty low spec GFX card is $2,400). I think it can be a hardware guide for Isadora, but I can see a lot of complaints of why cant my $2000 apple laptop play back these files....reason is obvious but users are unhappy as they paid too much for the laptop).



  • Same behaviour with my 2012 MBP - 2,6 GHz Intel Core i7- 16 Go 1600 MHz DDR3 - NVIDIA GeForce GT 650M 1024 Mo VRam - 2 SSD Drives.
    Reading one single 1280x720 movie @ 25fps (Apple ProRes LT) on a single 1024x768 Projector (simple mapping with one quad rectangle).
    Sometimes lags occurs at the entrance of the scene, sometimes lags appear after 10-30 secs playing (and not at the begining) and then dissapear..

    I don't understand why my computer isn't able to archieve this correctly..



  • @fifou can you try hap?



  • Not for now (rehearsals), but I will..



  • I've tried HAP.
    Players are switching to QT but the overall result is better (not perfect), 95Mbps for a single 720p movie..
    There must be better solutions for reading a single movie without a single lag.
    I wish I could find the culprit..



  • @fifou, I am not sure how to help you further, I could get smooth playback of HD from my old core 2 Duo machine with a 512 mb GFX card with Isadora and with my retina with 2 gig nvidia GFX I get 4x full HD or 4k smooth. Is there anything else running on your system using resources?



  • @Fred

    What frame rate do you use for the videos? I often had this issue in Isadora as well as in other live mixing software. Even playing them on big media server's like watchout or Pandora's. What most times seem to help is, rendering the content with at least 50/s.
    Best
    Delil


  • @ DillTheKraut  use 1.5g data rates as I have only had 1.5 infrastructure mostly so that means 25p or 50i. I have been doing much more 50p lately. I am definitely not a fan of pandora and it does not have a great reputation for playback. A lot of the time I have written my own software for playback and have not had problems either....not that this helps you, just to say that the hardware is sufficient.

    I get good 4k playback with hap except for its poor colour banding on gradients, this is inherent in the hap codec.
    Pro-res LT is often my go to codec at 1080p25 it works just great. I think a lot of others have a similar experience with Izzy, especially since version 2\. Sometimes I will put Izzy to a target of 50 fps for the 25fps playback and it gets smoother (if I have had problems).
    Maybe you can send me a sample and patch and I can test it on other hardware?
    Fred


  • @Thank you for offering help. It's not an actual issue, but something me and others experienced allot. Pandoras is only one example, given Millumin, resolume, etc.

    My experiences are based on a Mac Pro 2013 with 48GB and two firepro300.
    What I didn't try yet, is enabling/ disabling vsync. Curious if this option is available on OSX anyways.
    Best
    Delil


  • @Fred
    No, cpu activity is very low when playing movie (almost nothing on the 8 cores).
    Movies are on the internal SSD.
    Movies are 25fps, Isadora target framerate is 50fps (It works better this way) and stays @ 50fps during playback.
    I'm talking about micro freezes in the movements, sometimes. never at the same time.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.