assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Mac OS Sierra



  • Hi, anyone knows about Mac OS Sierra compatibility ?


  • Tech Staff

    I've been running it for a week or two with no issues.



  • Ok, thanks !



  • Yes no issues for now



  • So, I updated to macOS Sierra. Now Isadora is launching incredibly slooooooowwwly. The color wheel is rolling for teen number of seconds. Not a big deal because at least it works but it doesn't seems safe :((



  • Here is what exactly append :

    When I launch Isadora the startup window opens. If freeze on **_Networking : Initialising_** for 15 sec, then the process continue, freezing a bit on **_Midi : initializing_****,** then startup window disappear and the **color wheel roll during 45 sec** before the soft get ready. Next, when **I launch my patch, it takes 40 sec** to open the window with all my connection.
    At this point, I have to tell that this don't append on the iMac 27 but only on the Macbook Pro. The iMac also ride a macOS Sierra but in this case all works fine.
    Has anybody a way to explore ?
    Thank you very much


  • If someone is interested with the console log file, here are the last lines that tells about BUG:

    Sep 23 11:45:09 Retina-de-Fabrice VTDecoderXPCService[1099]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked

    Sep 23 11:45:09 Retina-de-Fabrice VTDecoderXPCService[1101]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked

    Sep 23 11:45:10 Retina-de-Fabrice VTDecoderXPCService[1100]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked

    Sep 23 11:45:25 Retina-de-Fabrice MIDIServer[1103]: +MIDI NewMIDIDriver  0x00000000

    Sep 23 11:45:25 Retina-de-Fabrice MIDIServer[1103]:   +MIDI PtUSBMIDIDriver::PtUSBMIDIDriver 0x00402B30

    Sep 23 11:45:25 Retina-de-Fabrice MIDIServer[1103]:   -MIDI PtUSBMIDIDriver::PtUSBMIDIDriver

    _Sep 23 11:45:25 Retina-de-Fabrice MIDIServer[1103]: -MIDI NewMIDIDriver _

    Sep 23 11:45:25 Retina-de-Fabrice MIDIServer[1103]: +MIDI MIDIDriverStart 0x00402B38

    Sep 23 11:45:25 Retina-de-Fabrice MIDIServer[1103]:   +MIDI PtUSBMIDIDriver::Start 0x00402B30

    Sep 23 11:45:25 Retina-de-Fabrice MIDIServer[1103]:     MIDIDeviceListGetNumberOfDevices returned 1

    Sep 23 11:45:26 Retina-de-Fabrice MIDIServer[1103]:   -MIDI PtUSBMIDIDriver::Start

    Sep 23 11:45:26 Retina-de-Fabrice MIDIServer[1103]: -MIDI MIDIDriverStart

    Sep 23 11:46:07 Retina-de-Fabrice IsadoraCore[1088]: Antidote - Texteurs: Module texteur installé dans /Applications/Isadora/IsadoraCore.app (com.troikatronix.isadora)

    Focus on the time, it takes near 1 min to achieve the start process !


  • Hello everyone,

    Izzy is displaying quite a significant lag when I place actors in workspace (actor does not follow mouse smoothly). Framerate drops to under 10fps during this process as well. Hopefully this screen capture will demonstrate my problem. Any ideas?
    Many thanks

    9914e7-izzy.mp4



  • Hi ! Anyone knows about this ? :

    BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked
    Thanks !


  • Dear All,

    I'll be testing with Mac OS Sierra starting tonight and report back. (I hadn't upgraded yet.)
    Best Wishes,
    Mark


  • Dear All,

    I've done some work on @Paz 's problem, and have a build that I am willing to give out if you've 1) experienced this slow drawing issue and 2) are willing to try a relatively unstable build so I can get some feedback.
    If you're willing to give it a go, please PM me.
    @hatfab: were you disconnected from the Internet entirely when you saw this long delay? I cannot recreate this problem, and as least a couple of people indicated above, they've been running Sierra without any difficulty. @hatfab, please file a formal bug report with the team so that we can get your Isadora file in case that's part of the problem.
    Has anyone else seen delays of this nature when starting up or opening a patch? 
    Best Wishes,
    Mark


  • Hi Mark !

    What is a formal bug report ? Is there a form somewhere ?
    I've installed a clean macOS Sierra on an erased Hard Disk on a Mac Book Pro :
    - MacBook Pro (Retina, mi-2012)
    2,7 GHz Intel Core i7
    16 Go 1600 MHz DDR3
    NVIDIA GeForce GT 650M 1024 Mo / Intel HD Graphics 4000 1536 Mo
    - Monitor 15,4 pouces (2880 x 1800)
    **All that append is discribed here :**
    When I launch Isadora the startup window opens. If freeze on Networking : Initialising for 15 sec, then the process continue, freezing a bit on Midi : initializingthen startup window disappear and the **color wheel roll during 45 sec** before the soft get ready. Next, when **I launch my patch, it takes 40 sec** to open the window with all my connection.
    At this point, I have to tell that this don't append on the iMac 27 but only on the Macbook Pro. The iMac also ride a macOS Sierra but in this case all works fine.
    Help please !
    Thank you

  • Tech Staff

    @hatfab

    you can find the link in my signature.
    Best Michel

  • Tech Staff

    @hatfab

    Since the machine has 2 video cards, are you able to define (usually in the nvidia control panel) for Isadora (the application) to only use the nVidia card.
    This may solve a common problem caused by a power saving feature, where the video card used is swapped back and forth to save power.
    Just a thought.


  • @Michel

    What do you want to show me with your link ?
    Thanks

  • Tech Staff

    Well this was your question: **What is a formal bug report ? Is there a form somewhere ?** and the link in my signature brings you to the page with the form.
    Best Michel


  • To be super clear, click on "Bug Report/Feature Request FORM" in Michel's signature and you'll be led to the form. The link to http://www.filmprojekt.ch is Michel's personal page.



  • @Hatfab,

    We still have not been able to recreate the long delay problem.
    Regarding this in the console: kevent[EVFILT_MACHPORT] – this is not an Isadora problem. It's a Sierra problem. See this article where developers are seeing this in lots of places: http://apple.stackexchange.com/questions/254188/rmbp-unable-shut-down-after-upgrading-to-macos-10-12-sierra-16a323/254400#254400
    Similarly, the messages about "PtUSBMIDIDriver" are not coming from Isadora. More likely, it is a MIDI driver installed on your system that is invoked when Isadora opens up the MIDI ports.  Could "Pt" stand for Pro Tools maybe? Go to /Library/Audio/MIDI Drivers and see what drivers you see there. Do you see one called PtUSBMIDIDriver? What happens if you remove it? Perhaps this driver is not compatible with Sierra?
    Best Wishes,
    Mark


  • @Michel @Mark

    Ok, I didn't see it, Thanks
    @Marc
    - I've tried with both _isadoramac-245b10-std_ & _isadoracore222f00-std_ on **macOS Sierra** and both have the same issue
    - I've done a clean install of **macOS Sierra **so no drivers for anything are installed
    - I'm back with a clean install of **Mac OS X El Capitan** and all works well.
    I've no time to go further, I'll wait for an update of **Sierra** that perhaps will fix this issue.
    Thank you for your help !


  • Hello,

    I'm un der Sierra since June and don't have this problem.

    Armando

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.