assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

How to stop continous crashing on start due to crash report itself ?



  • Did not work for me. Isadora still crashes immediately. All preferences removed, free frame uninstalled. :(



  • :( I am using an old version of isadora : 1f3 on USB key. Maybe that makes a difference ?


  • Tech Staff

    @chrisdel

    even though you only have a version 1.x license I would recommend downloading version 2.x, there are a lot of fixes in there also for license 1.x owners. The only thing is that you will not benefit of the newest features.
    Best Michel

  • Tech Staff

    @chrisdel

    If you are running a older version of Isadora, it does not support the new freeframeGL format, only the older freeframe format. 
    The downloads available are Petes freeframes (older version) and the Newer Isadora FreefraeGL collection.
    Without seeing the error report I can only guess. But I would suggest trying the most recent beta, since it may have a fix that addresses your issue:
    http://troikatronix.com/isa25beta/


  • @chrisdel yes i've been trying the beta, it didn't work on my windows 10 machine, and recently freezes and is inoperable on my windows 8.1 intel i7 16GB ram nVidea GTX 960m workhorse. I uninstalled isadora 2.5 beta, removed preferences as per instructions on this forum, restarted machine, installed isadora 1.3, restarted, opened isadora.... crashes immediately.

    I will now try to install the older freeframe format and see if that helps, is there a procedure for removing the freeframe GL collection?
    i am considering completely wiping this computer, reformatting and starting over, but honestly i shouldn't have to do that, on two completely different machines?
    How can I send you an error report?
    thanks for the help,
    rr


  • crash report attached @chrisdel

    -rr

    7a12cf-isadora-crashreport.zip



  • OK, the freeframe uninstall and reinstall of the non GL collection worked on my i7 windows 8.1 machine.

    did the same thing on my i5 windows 10 backup, still crashed immediately. see crash report attached.
    rr

    d08d2a-isadoracrashwindows10.zip



  • @michel,  In fact I had old files in v1 that were working very fine on windows XP. And to port them on windows 10 with isadora v.2.0 gave me so many problems.... that I prefer to carry on with the good old tools.   my feeling is that isadora v 2.0 is not fully ready for windows 10.... I will wait a bit more...

    @rayroyiii, i'm not developper so you should adress the crash report to @dusX   Good luck with solving your problem !

    @dusX   thanks for your help ! Let me know when isadora 2.0 has been tested by many users and working fine on windows 10. I had many problems of stability with the Black Magic Intensity driver. Maybe the problems comes from the driver itself ? Anyway I went back to the good old tools : firewire capture card, isadora v0.9 (much more efficient than the v1.3 for video tracking, the difference in CPU use is very important) on windows XP, maybe windows 7 (I am testing at the moment and it seems to be working fine also.


  • Tech Staff

    I have had a very small number of users ever have issues like these on Windows 10.

    In my experience, the problems generally stem from either video card drivers, or 3rd party linked files (freeframe, FFGL, GLSL, and User Actors).
    For this reason the first 3 things I ask users having an issue like this are:
    1. Delete your preferences.
    2. Rename the folders of any 3rd party modules (eg: C:\Program Files (x86)\Common Files\FreeFrame )
    3. Ensure you have the latest driver/s from the video cards' manufacturer. (often not supplied by the systems' manufacturer/brand)
    If your system uses an Intel video card, there may be issues with Isadora v2.2 and earlier, but the latest beta has corrected these edge cases.
    Recently I have taught Isadora v2 to a class almost entirely using Windows 8 thru 10. 
    Isadora proved very stable once a few simple system configuration changes were made. (Turning off nVidia Optimus, was the number change required)


  • @DusX : Ok, thanks for the advices !
    In fact I had 2 problems : stability of Isadora and the stability of isadora in combination with using the black magic intensity video capture.

    So let's say that we can fix isadora V2.2 and above to be stable on windows 10, what would be the video capture card you recommand to use then ?



  • @DusX : Ok, thanks for the advices !
    In fact I had 2 problems : stability of Isadora and the stability of isadora in combination with using the black magic intensity video capture.

    So let's say that we can fix isadora V2.2 and above to be stable on windows 10, what would be the video capture card you recommand to use then ?


  • Tech Staff

    Black magic is likely the fastest choice. ( natice driver support) However these can be very picky about the hardware supported, and in the case of the usb 3 versions only work with a small number of usb3 host controllers. Others may work but poorly. I have used these with Isadora and windows to great effect previously but have also returned product after testing and finding that it was impossible to us BM intensity with my computer at the time.



  • Hello,

    @Dusx  , Please could you tell how you disable optimus ?

    Thank you :)
    Victor

  • Tech Staff

    @Victreux

    If your system has optimus, generally in the nVidia control panel, there is a 3D tab which has a section that allows you to define how 3D is managed for different applications.
    You need to add Isadora.exe to this list and set it to ONLY use the Dedicated video card (nVidia).
    This will set Isadora to ignore any onboard Intel video.
    On some machines (not very common) it is possible to disable Optimus in the Bios.
    Sorry, I can't provide any further instruction for this option.


  • @Dusx

    Thank you for your answer. 
    I have built a computer _ Win 10 _ for a project with two Nvidia GTX 950 pluged to the motherboard ( I need 5 output  ). 
    Do you think i will have a better stability if i disable the GPU calculation for one of them ( If i configure : "CUDA _graphic processor Geforce GTX 950 (1 on 2) " for Isadora.
    I also think to go back to win 7 for better stability. What is you opinion about it .
    Thank to tell me if you have any suggestions.
    Best,
    Victor


  • @Dusx

    Thank you for your answer. 
    I have built a computer _ Win 10 _ for a project with two Nvidia GTX 950 pluged to the motherboard ( I need 5 output  ). 
    Do you think i will have a better stability if i disable the GPU calculation for one of them ( If i configure : "CUDA _graphic processor Geforce GTX 950 (1 on 2) " for Isadora.
    I also think to go back to win 7 for better stability. What is you opinion about it .
    Thank to tell me if you have any suggestions.
    Best,
    Victor


  • @chrisdel The blackmagic capture cards are picky, but not unreliable. The cards require a full speed USB3 connection, many cheaper and or older motherboards use a lower quality USB3.0 chip that does not actually support full speed throughput. This is not a problem with blackmagic, windows or any Isadora release, but rather the hardware manufacturer of the motherboard or USB3 chip (or writing the drivers) cutting corners. A full list of compatability for the hardware can be found on the blackmagic site. You need to go to https://www.blackmagicdesign.com/support and then select capture and playback devices and then in the centre column in below are support notes, then go to the heading USB 3.0 System Requirements.  Again, the actual spec of USB3.0 allows for enough bandwidth for uncompressed HD video ingestion, but many systems cannot meet the full spec, but will work for most uses, like better hard drive access speeds, or using other lower bandwidth USB3.0 devices. It is always worth checking out details of hardware requirements when buying anything other than a mouse or USB stick to make sure it will work well with your system. Overall if I were you I would move directly to windows 10 and Isadora 2.5 and go with the blackmagic capture card if your hardware is capable. Both Isadora 2.5 and Win 10 are lightyears ahead for stability and performance, just check you have the right hardware, GPU processing is another world and new tools that have appeared in later versions are super useful.

    @[Victreux](http://troikatronix.com/troikatronixforum/profile/367/Victreux)  Isadora does not use CUDA and has difficulty using 2 gfx cards (as do pretty much all live softwares, even things like SLI, generally half the speed of the system but add power) . CUDA is much better at distributed calculation, like a render that does not require real time processes. 2 GFX cards will give you more outputs, but will be hard to manage. A better way is to use a more powerful card and something like a matrox or datapath to get the extra outputs, or of course a card like the firepro w9100 that has the outputs already.

  • Tech Staff

    I agree with Fred in regards to windows 10.

    His suggested config is likely the best option. I prefer to use a single video card since the 'shared opengl resources' feature is VERY convenient, and isn't available with multiple video cards.
    That said, with this feature turned off, multiple cards should be possible.


  • Hello,

    Thank you for help.
    I confirm, not very stable with 2 gpu (all the output work but slowdown and frames problemes... crash etc ...) even with the option to use only one gpu for processing . 
    I left only one card with 7000 pixels and a triple head DP . It work great with a blackmagic duo ( 120 ms latency with a sdi cam 720P50 ) and all the movie in photojpeg.
    The last beta work much better for me than the 2.2.2 with win 10  _ last production with window was hard_
    Good job. Thank you. Feel safe for the next three weeks i have to work.
    Victor