assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

crashing with movie playback, urgent



  • I thought Isadora could handle a very simple show I am doing, I am playing back 1 movie per scene, nothing more

    The videos are prores LT 5760*1080 (triple wide HD) with 4 discrete audio tracks (sync has to be tight). Of course playback is fine, even for 2 at once with quicktime. I need to crossfade the movies at cues, could not be more basic. There are 3 projectors attached to a retina MacBook Pro with a gtx750m video card.

    Isadora crashes randomly when advancing scenes or jumping into scenes. It crashes with no report…..so there is nothing to learn.

    At times the patch does not respond to editing, I can click on scenes, they highlight but the content of the scene editor window stays. The keyboard watcher ceases to work and now and then movies also cease to respond or play when entering a scene. Generally Isadora halts completely.

    I have tried HAP, H264, process and process LT, LT is fine for our purposes.

    I am using 2.5.1, making the patch on Sierra 10.12.4 and the playback machine is exactly the same but running 10.11.6

    All have 512 built in storage and 16 gig ram and 2gig video memory.

    We are in rehearsals at the moment and I am really looking for a solution.

    I have shared video resources enabled and am using layers to achieve a hard cut video with audio cross fade (3 second fade outs and 0 second fade ins).

    I know mark has been messing with the code to make Izzy sierra compatible, as I only need to playback on el capitan if there is a working version it would be great.

    As a note in activity monitor I see multiple (15 izzymovieplayer64 playback applications and 4 izzymovieplayer32 - I would expect they would all be 64??), even though there is only ever one movie playing and one crossfading at a time and all are 

    I see some other anomalies, like Isadora cannot see multichannel audio unless it is added as discrete tracks, whereas the apple default is discrete tracks bundled in a single audio track.

    At times going into a scene the movie player will seem active but will freeze on the first frame. Also there are a total of 8 movies in the entire show. Crashing happens on scene change always, but once a movie is playing it is OK, although compared to playing the movie in any other software Izzy makes the fans sound like the laptop is trying to launch a rocket.

    Fred


  • Tech Staff

    @Fred

    Well I cannot answer all your questions but following points. 

    Isadora always launches four 64 and four 32 playback applications even though you don't use any movie player at all in your patch.

    I do not know what causes your crash but must say we had a similar problem here. For the youth film festival we were using Isadora 2.5.0f1 with El Capitan on a MacPro (Black Tube) all media was AppleProRes 422 1920x1080 and we had no problems. Then a week later we only played one .h264 movie on a different MacPro (black tube) with El Capitan and Isadora 2.5.0f1. First scene black second scene movie third and last scene black. Isadora crashed nearly every time when we finished one run through (being at the last scene) and then clicking on the first black scene. After upgrading to Sierra this problem disappeared.

    We have no Idea if something was awkward on the installation of the OS and the update fixed it.

    Best Michel



  • @Michel

    So I guess the release has a pretty serious problem if it is generating 15 izzymovieplayer64 playback applications and 4 izzymovieplayer32...

    So is there a version of Izzy that has stable movie playback on El Capitan?


  • Tech Staff

    @Fred

    sent you a pm.


  • Tech Staff

    This sounds like an issue our latest beta may address.

    Please open a support ticket and request the latest beta.

    This beta gives additional control over the background processes (set the count of each) as well as improved stability.



  • in a break switched to the Sierra laptop, seems stable..But of course it's going to crash when the cast comes back in ;)



  • @Michel

    So i upgraded the other laptop to Sierra and it had another problem, movies would not play at all, just stick on the first frame. If i connect to WiFi then it is all fine and stable. So 2.5.1 is very problematic on 10.11.6 and on Sierra does not work without a network connection. This is kind of ok for me for the next days but in general is a nasty bug. No time for a bug report now but it would be great to see this fixed.


  • Tech Staff

    @Fred

    Yeah, I have had 2 users now confirm the issue of requiring a Wifi connection. 
    Do you have anything like creative cloud or dropbox on that machine? 



  • @DusX No, no creative cloud or dropbox.



  • For everyone's information, this MacOS issues  has come up for a couple of other users, and we have a beta that solves it. @Fred has already indicated to me that the beta I sent him seems to have solved it for him too. We're going through tests to ensure all is well with this version and we'll release it ASAP.

    -- Mark



  • not quite a reply but a question

    so I am using 2017 MBP

    2.2 GHz Core i7

    250 GB SSD 

    16 GB 1600 MHz DDR3 

    Intel Pro 1536 MB 

    running Sierra 10.12.3

    Video files are 1920 x 1080 AppleProRes 422

    I am having huge problems with getting Isadora to start on the machine, even before I try to configure with the video files. Isadora lags for quite awhile on start up, lots of pinwheel while I wait for it to open, would say it takes a good 3 minutes to finally open. This doesn't seem right. 

    Next I set up a scene using simple playback-three movie player to projector, set optimize to  performance so that I am using the correct playback-AVFoundation.

    Set up a jump to scene with keyboard trigger via space bar and...

    Everything lags and when the scene does open nothing plays, or it plays and  then stutters or in so cases plays all the way through but never twice in a row-Lines connecting output to projector are almost always red. If I switch to optimize interaction, it will play sometimes but then starts to stutter about half way through. Frame rate stays at 30. The weird thing is is that it worked fine last night, even had it running through a triplehead2go se that worked well once I set the resolution correctly. Thought that it might be giving me trouble so I disconnected the laptop from it but it didn't change a thing. I was running from an external hard drive with usb 3 and again it worked fine last night but nothing doing today. I tried loading all the files onto the laptop, greatly reducing my hard drive space(25 GB left after all the files were loaded) but still nothing. I was ablt to get my 2008 macbook 13" to run the files in 2.2 albeit with frame rate drop to about 13 and cycles down to about 50. I am at a loss as to what might be causing the MBP to behave in such a way-Show opens Thursday and we are supposed to run tomorrow but I am having my doubts. ANy suggestions or ideas?

    Thanks

     



  • @dodioflo

    Please read this and see of the suggestions affect your situation.

    https://support.troikatronix.c...

    Best Wishes,
    Mark



  • I am using a stripped down MBP,it is a rental without much third party software aside from Microsoft office. Not sure what else to do aside from turning off timemachine. This is a huge problem right now.



  • @dodioflo what exact version of Isadora are you using? The 25 gig free should not be an issue, I would go for using the fast storage on the mac over the external usb3 any day, even if it left less space. 

    To be honest although this should work (but, please don't compare it with just playing the files with quicktime or VLC, the process for what Isadora does is quite different), I would avoid using an integrated video card for a show with multiple screens, not what you want to hear now, but for the future. This laptop does have 4x thunderbolt 3 ports, can you ditch the triple head and go with native outputs via a thunderbolt 3 to HDMI convertor? Also remove the triple head software and drivers (there is an uninstaller there somewhere).

    The last problem I encountered was connected to the network. I could not get the system to play without an active network connection, it did not need to be connected to the internet, but just getting an ip address and route. Do you have the ability to create a wifi network, maybe with your phone and test?



  • @Fred

    using version 2.5.1 and I might be able to switch stuff out for the thunderbolt connection I will check with the rental house. So this note about a network-is possible that I shut off the network, you say all it needs is an ip but no internet connection, this I can definitely try. I have used Isadora for many years, especially in this type of configuration so I am baffled as to why it won't work. I have to admit that I am a little behind with thunderbolt, I have not been able to upgrade to anything since my 2011 laptop so I am a bit behind, hence the triplehead2go.

    I will try your suggestions and thanks. Is it a specific cable, the thunderbolt 3 to hdmi converter or is it more of a conversion box?

    Michael



  • @dodioflo

    Just ran down this model and it is from 2015 not 2017 and has 2 thunderbolt 2 and one hdmi display outputs, not the four that was originally implied when I thought it was a 2017 machine. Not sure what to do next but will be working on it today.

    thanks for the help

    Michael


  • Tech Staff

    @dodioflo 

    have you opened a support ticket?



  • @dodioflo


    I sent you a beta in a PM. Please try it and report back.

    Best Wishes,
    Mark



  • @dodioflo go with the beta mark sent, i used it on a similar machine (but one with a relationship video card) and it worked great. The adapters you need are something like this https://www.apple.com/shop/pro...

    The old triple head that worked with your 2011 machine will most likely not work with this one, and the video card will give you limitations, check the matrox site, it has compatability wizard that shows what models work and what resolutions they can do.

    For me i had to have a network connection, so WiFi needed to be on (i had no ports left to use an ethernet adaptor) and connected to a router, no internet was needed.

    Fred



  • well went back and everything worked-shut off the matrox controller on the desktop, had a network connection, and ran the show with no glitches. Was wrong about the MPB, it was from 2015 and the triplehead2go worked seamlessly, I have gotten used to  tech deciding to be uncooperative i the worst moments. So right now everything is working and i am able to edit and run so we will see. thanks for all of the suggestions and the help.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.