• not quite a reply but a question

    so I am using 2017 MBP

    2.2 GHz Core i7

    250 GB SSD 

    16 GB 1600 MHz DDR3 

    Intel Pro 1536 MB 

    running Sierra 10.12.3

    Video files are 1920 x 1080 AppleProRes 422

    I am having huge problems with getting Isadora to start on the machine, even before I try to configure with the video files. Isadora lags for quite awhile on start up, lots of pinwheel while I wait for it to open, would say it takes a good 3 minutes to finally open. This doesn't seem right. 

    Next I set up a scene using simple playback-three movie player to projector, set optimize to  performance so that I am using the correct playback-AVFoundation.

    Set up a jump to scene with keyboard trigger via space bar and...

    Everything lags and when the scene does open nothing plays, or it plays and  then stutters or in so cases plays all the way through but never twice in a row-Lines connecting output to projector are almost always red. If I switch to optimize interaction, it will play sometimes but then starts to stutter about half way through. Frame rate stays at 30. The weird thing is is that it worked fine last night, even had it running through a triplehead2go se that worked well once I set the resolution correctly. Thought that it might be giving me trouble so I disconnected the laptop from it but it didn't change a thing. I was running from an external hard drive with usb 3 and again it worked fine last night but nothing doing today. I tried loading all the files onto the laptop, greatly reducing my hard drive space(25 GB left after all the files were loaded) but still nothing. I was ablt to get my 2008 macbook 13" to run the files in 2.2 albeit with frame rate drop to about 13 and cycles down to about 50. I am at a loss as to what might be causing the MBP to behave in such a way-Show opens Thursday and we are supposed to run tomorrow but I am having my doubts. ANy suggestions or ideas?

    Thanks

     


  • @dodioflo

    Please read this and see of the suggestions affect your situation.

    https://support.troikatronix.c...

    Best Wishes,
    Mark


  • I am using a stripped down MBP,it is a rental without much third party software aside from Microsoft office. Not sure what else to do aside from turning off timemachine. This is a huge problem right now.


  • @dodioflo what exact version of Isadora are you using? The 25 gig free should not be an issue, I would go for using the fast storage on the mac over the external usb3 any day, even if it left less space. 

    To be honest although this should work (but, please don't compare it with just playing the files with quicktime or VLC, the process for what Isadora does is quite different), I would avoid using an integrated video card for a show with multiple screens, not what you want to hear now, but for the future. This laptop does have 4x thunderbolt 3 ports, can you ditch the triple head and go with native outputs via a thunderbolt 3 to HDMI convertor? Also remove the triple head software and drivers (there is an uninstaller there somewhere).

    The last problem I encountered was connected to the network. I could not get the system to play without an active network connection, it did not need to be connected to the internet, but just getting an ip address and route. Do you have the ability to create a wifi network, maybe with your phone and test?


  • @Fred

    using version 2.5.1 and I might be able to switch stuff out for the thunderbolt connection I will check with the rental house. So this note about a network-is possible that I shut off the network, you say all it needs is an ip but no internet connection, this I can definitely try. I have used Isadora for many years, especially in this type of configuration so I am baffled as to why it won't work. I have to admit that I am a little behind with thunderbolt, I have not been able to upgrade to anything since my 2011 laptop so I am a bit behind, hence the triplehead2go.

    I will try your suggestions and thanks. Is it a specific cable, the thunderbolt 3 to hdmi converter or is it more of a conversion box?

    Michael


  • @dodioflo

    Just ran down this model and it is from 2015 not 2017 and has 2 thunderbolt 2 and one hdmi display outputs, not the four that was originally implied when I thought it was a 2017 machine. Not sure what to do next but will be working on it today.

    thanks for the help

    Michael

  • Tech Staff

    @dodioflo 

    have you opened a support ticket?


  • @dodioflo


    I sent you a beta in a PM. Please try it and report back.

    Best Wishes,
    Mark


  • @dodioflo go with the beta mark sent, i used it on a similar machine (but one with a relationship video card) and it worked great. The adapters you need are something like this https://www.apple.com/shop/pro...

    The old triple head that worked with your 2011 machine will most likely not work with this one, and the video card will give you limitations, check the matrox site, it has compatability wizard that shows what models work and what resolutions they can do.

    For me i had to have a network connection, so WiFi needed to be on (i had no ports left to use an ethernet adaptor) and connected to a router, no internet was needed.

    Fred


  • well went back and everything worked-shut off the matrox controller on the desktop, had a network connection, and ran the show with no glitches. Was wrong about the MPB, it was from 2015 and the triplehead2go worked seamlessly, I have gotten used to  tech deciding to be uncooperative i the worst moments. So right now everything is working and i am able to edit and run so we will see. thanks for all of the suggestions and the help.


  • @DusX

    Hello,

    I am having a similar problem with playback and am hoping you beta patch will correct it.

    I am playing a HAP movie.  El Capitan.  When switching to scene it is taking close to 20 seconds to switch and then doesn't play the movie file.

    Can you send me the beta patch?  let me know if you need additional info.

    Thanks!


  • Here is the message I am receiving.

    6/1/17 5:17:17.278 PM IzzyMoviePlayer64[1060]: [17:17:17.278] itemasync_SetProperty signalled err=-12785 (kFigBaseObjectError_Invalidated) (invalidated) at /Library/Caches/com.apple.xbs/Sources/CoreMedia/CoreMedia-1731.15.206/Prototypes/Player/FigPlayer_Async.c line 2306


  • @Cory

    The beta is no longer beta, it's v2.5.2. The links are here

    https://community.troikatronix...

    The message you listed  is not meaningful. It is a warning given by AVFoundation. If you google "itemasync_SetProperty signalled err=-12785" you'll see loads of matches spread far and wide for many different software apps.

    So that particular error is not something that can be fixed, because it's in Apple's code.

    Best Wishes,
    Mark