assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

PJLink Troubleshooting



  • Hi All

    I have a new Optoma projector that is coming up with the error 'initial response not PJLINK' when trying to send anything to the projector using the PJlink actor. However with a PJlink tester you can download, it is able to execute the commands. 

    The IP address and port number is the same and there is no password.

    I haven't been able to find anything on the error online so any help is appreciated.

    Thanks

    Andy


  • Beta Platinum

    Please tell us the exact model projector that you have, then we can assist you further. Also what command are you sending ?



  • Hi 

    Thanks, the projector is the Optoma ZH406ST (https://www.optoma.co.uk/product-details/zh406st) its a very new projector and says is has PJlink capabilities.


  • Tech Staff

    @andy-demaine-iic

    As Juriaan asked, what command are you sending?



  • @woland
    Hello, I'm having the exact same problem with the exact same projector model - did you ever figure it out? I'm trying to send POWER ON and POWER OFF commands.



  • @maki


    @andy-demaine-iic said:

    The IP address and port number is the same and there is no password

     What exactly is the port number you are using? Regarding to this fresh forum thread by @eamon, he experienced the very same error "initial response not PJlink". It was found, that the port number he used was connected to some else service published by the projector, but PJlink beeing published on a different port number than misunderstandably suggested by the manual. Regarding to the Optomas users manual, the Port where the PJLink service is listening on, is 4352. Which is the exact same as used by Panasonic projectors and seams to be the default Projector Link service port: http://tcp-udp-ports.com/port-...

    Best Dill


  • Tech Staff

    From our PJLink knowledge base article:

    IMPORTANT NOTE: THE IP PORT FOR PJ LINK IS ALMOST ALWAYS 4352!
    According to the PJ Link Specification, the default IP Port used for PJ Link is 4352. The menus/user interfaces on some projectors (notably Panasonic) might lead you to believe that you can change the PJ Link port number. But our experience and user feedback indicate this is almost never the case. Always try 4352 first!

    If changing the port to 4352 doesn't work, try working through the steps in the article one by one.

    Best wishes,

    Woland



  • @woland Sorry I missed your replies. I'm pretty sure the port was set to 4352, but I'm not in the studio now. Will verify tomorrow. By the way, PJLink worked perfectly with the test application and also over telnet using the same port. No luck from Isadora though. However it does work fine from Isadora for my Epson Projectors. Thanks so much for the help!



  • @Woland just to confirm - the port in the Isadora PJLink actor is set to 4352. Using the test application or Telnet, I can turn the projector on and off using this port. Isadora gives me the "initial response not PJLINK" error message. When I change the IP address in the actor to one of my Epson projectors, everything works. Let me know if I can do anything to troubleshoot, I'm happy to invest some time getting this to work. The installation will only be launched in September so it would be wonderful to find a solution until then. Alternatively I'm considering writing a shell or Python script to automate power on/off, but it would be amazing to have everything within Isadora. Thank you!


  • Tech Staff

    From the manual for the Optoma ZH406ST:

    This projector supports all commands of PJLink Class1 (Version 1.00).
    http://pjlink.jbmia.or.jp/english/

    That being said, could you please: 

    1. Try this test file with your two projectors PJLink Test.izz.zip
    2. Let me know the model number of your Epson projectors
    3. Let me know the IP address of your Optoma and Epson projectors