assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Possible crop actor bug...



  • Duh, YUV mode solved it... Sorry, back to business... :)) Thanks again Michel. I will confirm the crop actor problem solved later when I am back to my rehearsal set-up in the theater...

    cheers,
    bozzy


  • Wow, this upgrade didn't do good for me... I am having all kind of problems with .png files not being transparent anymore, the video mixer distorting the images with .jpg files...


  • Tech Staff

    Tried .png file with transparency, it is working fine. Do your jpg files have different resolutions? What are you resolution settings in Isadora preferences, if you are updating Isadora you have to set all the preferences new.

    Can you send me your patch or a screenshot?

    Best
    Michel



  • Thanks Michel:

    First of all I will test the MIDI slider tonight and let you know if upgrading helped or not.
    Other stuff: 
    Screenshot 1: When I trigger 'a' the picture player should send a png file on top of the jpg but it doesn't come up transparent or it doesn't come at all.
    Screenshot 2: There is a png and a video running behind giving that cheesy window effect. If I enable YUV png is not being transparent anymore and scrambles the video behind
    And in general when I do not enable YUV two simple picture players connected to a video mixer and then to a projector do not stream the output without distorting the image.
    My resolution for now is 854 X 480...
    Thanks for all your help and time!
    cheers,
    bozzy

    23b911-screenshot1.png bb4439-screenshot2.png


  • Tech Staff

    first I would enable "keep aspect" in the projector actor. I would say the video mixer actor does have a bug, but you can get around that using two projectors and using an absolute value actor going into the intensity inputs of the two projectors, on the bottom one you have to swap the scale min and scale max of the intensity settings so it reacts oposite of its input. And you have to define the min an max scale value of the "Absolute value" to 0 and 100.

    You are right, in YUV mode the png file is not transparent anymore. But in none YUV mode it is transperent.

    Best
    Michel
    57fe5f-video-mixer.png 040ccc-videomixer.izz



  • Thank you for the patch idea... I will definitely replace my video mixer with that when I am in trouble. Maybe then I don't have to be in YUV mode and pngs won't be a problem anymore.

    On the other hand I don't think upgrading solved the problem of the crop actor... You will see the screenshots attached, they are both from the same scene. If the second stream of the crop actor is running underneath it still jumps in and out in weird triangular shapes. I will try to "keep aspect" in the projector meanwhile maybe it will help. 
    Thanks a gain a bunch Michel!!!
    cheers,
    bozzy

    ad46b2-screenshota.png 0f48b4-screenshotb.png



  • Dear Bozzy,

    Regarding YUV: YUV has no transparency information. If you turn on YUV mode, any alpha channel information with the picture will be lost. If you want to keep your transparency, then don't use YUV.
    Also, I would try a TIFF instead of a PNG to see if that makes any difference.
    Finally, is the resolution of every picture and every video 854 x 480? If you will send me your patch at mark [atta] troikatronix [dotta] com I will investigate.
    Best Wishes,
    Mark


  • Dear Mark,

    Unfortunately the resolutions I use are all over the place. Only my default resolution is 854 x 480 and I am on "scale to smallest image" mode.
    cheers,
    bozzy


  • Ummm... then it will be difficult for me to reproduce the problem, because it could be related to the various resolutions. If you want me to look into this, please find a scene where the problem exists, and list the resolution of each Movie or Picture. If you give me that, I'll recreate these and see what I can find out.

    That being said, I brought some pictures into your patches.
    Scene 1.1 in DistractedProjector.izz works as expected -- no flickering of any kind.
    Scene 4 of DistractedTVs.izz also seems fine. The Crop works as expected.
    I was also running both patches at the same time (as seems to be the case in your original post) and this showed no negative effects.
    However, there was a bug at one point where a movie playing at slower than normal speed would flicker when played above another image that was changing less frequently. This might explain the problem with DistractedTVs.izz, as it most definitely creates this very situation. However, I tested in 1.3.0f26 and saw no problems.
    I would suggest at this point that you move to the latest pre-release (1.3.0f32 at the time of this writing) -- bugs in the 1.3.0f26 pre-release have for sure been fixed. See http://troikatronix.com/download/isadora-pre-releases/
    Best Wishes,
    Mark


  • Let me look at the first two scenes I am having trouble with... One of the scenes: video1 is 720 X 480 and video2 is 488 X 348. A second one: video1 is 480 X 344 and video2 is 640 X 360.

    cheers,
    bozzy


  • Which scenes in which file? The ones I mentioned above? Distracted Projector/Scene 1.1 has a movie and a picture, not a movie and a movie.

    Best Wishes,
    Mark


  • Actually the bug you have described above is spot on. Because if I put several triggers around and pause the movies when they are not shown and stay below I can avoid the problem.

    The scenes I was referring to were: DistractedTV's Scene2, Scene 2.1 and Scene 5.1...
    Actually to move back to 0f25 might not be a bad idea if it will give the video mixers back to me but I am being extremely nervous since I am going to tech on Saturday.
    Thanks for all your help Mark!
    b.


  • Actually you can also see the video mixer bug in DistractedProjector.izz. For example if the YUV mode is disabled Scene 2 output is all distorted. It is ok on YUV mode but then I am loosing the transparency of the .png images...

    b.


  • Dear Bozzy,

    what do you mean by "all distorted" ? I've just gone in to DistractedProjector.izz / Scene 2 again, and tried to make something not work -- but it all works as expected. (I even put Scaler actors after every picture player to change with width / height to crazy values... regardless, it always works as expected.)
    I've really tried hard to recreate this bug, but I simply cannot do it. Since it doesn't seem like your media files are too big, it would be great if you could WeTransfer me all the media so I can try to sort this out.
    Best Wishes,
    Mark


  • Hey Mark,

    I created a single stage patch with the same bug. It is attached... 
    By the way I cleaned all my patches from bugs for the show. So, I am not in a rush with this anymore but curious why I am the only one that can see this thing. :)
    Thanks again for all your help.
    cheers,
    bozzy

    b9aead-creatingbug.zip



  • What should I see? I see three different images: the second one appears automatically, the third after I press 'n'.

    Should I see flickering? or?
    Best,
    M
    P.S. Thanks a lot for sending me the bug example -- it drives me crazy when I can't replicate a bug!

    bf33e1-ss1.png dda284-ss2.png 9d62a0-ss3.png



  • Wow, this is getting very mysterious. :) Here is what I see...

    b.

    bcce9b-bugshot.jpg



  • Well, could be video driver related. Tell me: in the Apple System Profiler (called "System Information" on 10.8) can you "Save" a copy of the information, .zip it, and send it to mark [atta] troikatronix [dotta] com? I'd like to look over your graphics cards and drivers. Also, if you have multiple graphics cards on that computer, I'd like to know which one was active.

    I am testing this on my MacBookPro i7, (which is a much later version, MacBookPro8,2). But I may have a 4,1 around that I can try.

    Thanks,
    Mark



  • Will do... I am using a MacBook Pro (2.7 GHz Intel Core i7) (OS X 10.8.3) with no external cards. FYI...

    cheers,
    b.


  • Dear All,

    Bozzy and I have been collaborating on solving this problem, and it is solved -- the new version that solves the problem will be up by May 10, 2013 at the latest.
    Thank you Bozzy for all your help!
    Best Wishes,
    Mark