assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Guru Session #13: Body Tracking with Depth Cameras (Fri May 8th, 6pm CEST/5pm GMT/12pm EDT/9am PDT)



  • @mark said:

    Do people find this confusing? Should I change it so that, if the mode is set to 'color', body/skeleton tracking is simply disabled?

     There is something confusing but for me it is that the capture mode "color" or "both" give the same result at output. I think it will be more clear to have only 2 possibilities: "only depth" and "color+depth".

    I think it is the purpose of this actor to always track the body even if you only use the color picture as output.

    best

    Jean-François



  • @jjhp3 Here's my terminal response to simple viewer launch: Desktop-simple-viewer.rtf.zip

    John



  • @mark 

    sorry didnt realize about the signature thing.. i filled that in. but my main Isadora computer is:

    MAC PRO 2012 5,1 12 CORE XEON 3.46GHZ, 64G RAM
    RADEON 5770, PCIE USB3, PCIE ESATA, PCIE SSD
    MAC OS 10.13.6 , ISADORA 3.0.7

    Yes the 2013 MacBook Pro laptop I tested all works fine with the same Kinect, isadora, OS and plugins. 

    yes it did seem to work fine on the mac pro for 2 days before the guru session happened. i even tested a backup of my OS on a different physical drive from 3 weeks ago..before I did the ITUNES update that broke 32 bit, and the kinect didn't work on that either..But  then I restored the mobileframework on my current OS drive in /private frameworks and got 32 bit apps working again. i would be willing to try anything at this point.. so please send me the the homebrew info you are suggesting. thanks



  • @mark 

    Today so far first bootup of the day the kinect was working.. only for about 2 min again. and then data and depth image freeze. this time was able to get it reconnected with only restarting isadora not even unplugging the camera. now then got it working for about 10 min.. but the depth image is a bit choppy.. only running 15% load on isaodra. then it froze again. So far In my testing every time i actually get it recognized the image and data freeze up soon after. Also Im NOT having the power light on the kinect stop blinking no matter what USB port I try so seems like the power bug went away.. and I haven't done anything different today.. still currently testing with Open NI 096.. would you consider that the most reliable version or is 092? i dont need to record feature right now.

    p.s. also test delicode ni mate v2.14 and the app wont even open, it was the only and i think latest version avilable on their site.



  • @mark

    I've attached a screenshot of the details you asked for plus the information I am getting From the Isadora Open NI Tracker Beta.  

    I'm using Isadora 3.0.7.

    I'm have a 1414 Kinect Xbox 360 and have also downloaded the KinectSDK.  Doesn't seem to help sadly.


    Regards

    Gavin



  • @light-fx-uk

    It seems that it is somehow finding the Kinect because the 'sensor uri' output shows a meaningful value. The skeleton tracking is disabled however, which indicates the tracking component refused to load.

    Try turning the 'use callbacks' input off. Does it change anything?

    What if you turn 'body tracking' input off? Do you see the depth map image then?

    Best Wishes,
    Mark



  • @mark  I sent the results, check your messages.
    No hurry though, because your reply here was enough to help me solve the problem.
    play time :)



  • @mark  I have deleted the kinect f0r windows sdk 2.0 and installed 1.8 as somewhere i read that 1414 kinect only works with sdk 1.8.  I now have an image! :-)



  • So is anyone having good results with the kinect v2? i may get one if it works more consistently than the v1

    @mark I have done much more testing and I really want to get this working. I had some good results with my laptop which is on mac os 10.13.6 (17G65), so i figured I'll just clone that boot drive and see if the mac pro has better results seeing the kinect like the laptop is.. I did a couple tests, first 2 times worked right away but then all of a sudden 9 out of 10 attempts fail.. this is making not much sense any more. Further.. even my laptop which sees the kinect every time fails the simple viewer test script?? what gives? I have tested 3 different builds of 10.13.6 and 10.12 on my mac pro and can not get the simple viewer script working or the kinect to reliably connect to Open NI tracker. I can get it to see the kinect about 1 in 10 trys but then it always freezes within 5 min. 



  • @demetri79 said:

    I have done much more testing and I really want to get this working.

    I am doing all I can on this topic, but I am overwhelmed with numerous urgent tasks that require my attention and cannot devote more time to OpenNI Tracker until this coming weekend. You will simply have to be patient.

    In general, you seem to be the only one experiencing these problems and I am concerned that there is simply a problem with the older Mac Pro, and I will not be able to debug it because I do not have a machine like that.

    I would not be concerned about the test program. If the OpenNI Tracker works well on your laptop, then I would suggest using your laptop.

    I will try to come back later today with the instructions on how to compile your own libusb on the older Mac Pro. Maybe that will help.

    That is what I can offer at the moment.

    Best Wishes,

    Mark



  •  Everything is working like clockwork with my Kinnect and I have been piecing together interesting new scenes using Marks scenes as starting points. This seems to be the best way for me to become fluent in new pieces of the platform. Unless I put a motion blur actor on it the skeleton shows up as a shadow when I use the Kinnect as a Mask. The other question I have is whether the particles can be combined with an alpha mask somehow to created a way of wiping through one layer of video into one below it. THANKS FOR ALL YOU DO!! I'm using a Kinnect 1414 if anyone is looking for suggestions about what works in the Kinnect department  



  • @Demetri79 

    Here are the instructions for homebrew.

    1) Open a Apple's Terminal program (/Applications/Utilities)

    2) Install the Xcode command line tools. Enter this command and hit return.

    xcode-select --install

    As indicated in these detailed instructions, a dialog will appear asking you to install the command line tools. Follow the prompts and install them.

    3) Install homebrew. Enter this command and hit return.

    Detailed instructions can be found here.

    /bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"

    It will take some time for this to complete.

    4) Compile libusb on your machine. Enter this command and hit return

    brew install libusb

    This also may take some time.

    5) Finally you need to get the compiled libusb. Type this command and hit return

    open /usr/local/Cellar/libusb/1.0.23/lib

    This will open a Finder window and you should see libsusb-1.0.0.dylib. 

    Note: if the version number of libusb changes, then the command above will not work. To find out what that new version number is, enter the two following commands

    cd /usr/local/Cellar/libusb
    ls -al

    You will see the version number of libusb listed in the result -- in this case 1.0.24. You would use this number instead of 1.0.23 in the command above.

    drwxr-xr-x   3 xxxxxxxx  staff   102 Mar 29 14:38 .
    drwx------  41 xxxxxxxx  staff  1394 May  7 15:51 ..
    drwxr-xr-x  12 xxxxxxxx  staff   408 Mar 29 14:34 1.0.24

    6) With the finder window of the compiled libusb open, you now need to open a Finder window for the OpenNI Drivers in the OpenNI Tracker plugin. Enter this command and hit return

    open /Library/Application\ Support/TroikaTronix/IsadoraPlugins_x64/OpenNI\ Tracker.izzyplug/Contents/Frameworks/OpenNI2/Drivers/

    7) Now drag the libsusb-1.0.0.dylib from the lib folder to the Drivers folder.



    And choose to replace the existing libusb

    8) You now have a libusb custom built for your hardware inside of OpenNI Tracker. You can reboot Isadora and see if it improves the situation for you.

    So please follow these instructions and see how it works out for you.

    Best Wishes,
    Mark



  • @mark thanks so much for your help i know you are doing a million things.. I will try a different type of camera if this doesn't work solidly for me.

    is the orbbec astra the best most solid option?.. curious to hear form other users which camera they find to be the best overall. thanks everyone. 



  • @demetri79 said:

    orbbec astra

     I'd also like to know if there is a higher resolution depth camera compatible with MAC OS 10 and the new actors. None of the newer cameras seem insanely expensive but do they work?



  • yeah I understand the Kinect v2 has higher resolution than the V1 so the question is between the Kinect V2, the Orbbec Astra, and the Intel RealSense. which is the best quality camera and which one is the most stable on mac with the Open NI Tracker.. I may just buy them all and then sell off the all but the best of them. but curious if anyone has compared them in the real world with isadora 3.



  • @Astrid 

    Thanks for sending me the results of the search. I can see what's going wrong now.

    You seem to have placed a copy of OpenNI Tracker inside of your Isadora USB Key application at /Applications/Isadora 3/. To remove it:

    1) Find the Isadora USB Key app in /Applications/Isadora 3/
    2) Right click Isadora USB Key and choose "Show Package Contents" from the menu
    3) Go into the Contents folder
    4) Go into the MacOS folder
    5) Go into the Isadora Plugins folder
    6) Delete OpenNI Tracker.izzyplug

    The plugin should always be installed at /Library/Application Support/TroikaTronix/IsadoraPlugins_x64/ -- not in the Isadora application itself.

    Best Wishes,
    Mark


  • Beta Platinum

    @mark 

    I have no success with Mac OSX 10.15.4 installing the OpenNi Tracker Alpha 0.9.6. I tried a few times but I get a dialog telling me it is broken and a request to have it moved to trash. Is there a fix for that? I am very keen to try the capture feature.


    Kind Regards

    Russell 



  • @bonemap said:

    I have no success with Mac OSX 10.15.4 installing the OpenNi Tracker Alpha 0.9.6. I

     I am not sure what this could be. I downloaded the latest from this thread and installed it. No issues at all.

    Best Wishes,
    Mark


  • Beta Platinum

    @mark

    Could it be anything to do with the masquerade.txt file? I will try again.

    EDIT: FYI The dialogue appears after relaunching Isadora when the masquerade.txt file is added at the same time as installing the plugin. 

    If I install the Open Ni plugin without the masquerade.txt file the Isadora app launches and the Plugin is available. if I then install the masquerade.txt file i.e. restarting Isadora a second time it appears to function without the dialog appearing or the app crashing.

    I have tried this several times now and it appears I am unable to place the masquerade.txt file at the same time as the OpenNI plugin.

    Kind Regards 


  • Beta Platinum

    @mark 

    What is the status of beta testing with the Kinect 2? are you wanting feedback on that one?

    I have loaded the alpha 9.6 Open Ni on MBP 15" OSX 10.14.6 (second machine in my signature). The depth camera freezes at 2 - 3 minutes and takes down the Isadora app.

    Kind Regards