OpenNI Tracker v0.9.7 - Feedback and Bug Reports


  • Dear Mark,

    thank you for the new version. 

    For me (XtionPro Live) in a first try it works fine like 0.9.6 with the same problem: the picture of the color video output is frozen while body tracking is on. This on my macbookPro with USB 3.0. and for both situation: capture mode both or color. It works well (with some jump every ± 2-5 s) on the MacPro with USB 2.0.

    All other things are working well so far I can try (can only try with one person)

    best

    Jean-François


  • @mark 

    Working well on my Homebrew machine as in sig (Windows 10) with Kinect V2 with a quick test using your example file.
    As expected, no skeleton tracking until Masquerade Text placed in OpenNI Tracker.izzyplug folder.
    After that worked well: skeleton tracking great.

    When recording, I am finding that although the depth map recording starts instantly, it takes a few seconds for the skeleton recording to kick in.
    When I playback and hit 'stop' Isadora crashes as per the release notes.
    When I disconnect the Kinect 2 and play back the .oni file and hit 'stop' Isadora still crashes.
    Successful playback and stop happens if I close Isadora, disconnect the Kinect 2, restart Isadora, and then play back.
    Perhaps this is what you meant in the 'known issues' section of the release notes, and I misinterpreted?


    One observation is that, when recording, the depth image is recorded instantly, but there's a few seconds before the skeleton tracker starts recording. I can replicate this each time.

    (Am finding that unplugging and replugging the Kinect causes Windows to lose the input from the Kinect. Device Manager shows it's connected, but there are no lights on camera and neither the MS Kinect Studio app, or Isadora sees it. No cure but to reboot.)


    Nice work, thanks! Will test next week with two Kinect V2.

  • Beta Platinum

    Hi there Isadorables (Still love the ref), 


    My setup

    1. MSI GE73VR 7RF Raider (Windows 10, Isadora 3.0.7)
    2. Microsoft Xbox One sensor using the For Windows adapter kit.
    3. Microsoft Kinect SDK 2.0

    About my experience

    Love the new plugin ! It is so frikking stable now, the last time I had the issue that it crashed after a few minutes at random. Now it works like a charm, except from the issue that Izzy crashed after I stopped the playback of the recording. (That is noted in the Known issues) The dancer that I'm currently working with is really excited as well that we can now record her ! I will test it out tomorrow with 5 skeletons and see how that works out.

    Cheers !


  • After further testing, I find out that Isadora crashes if I record a movie with the "capture mode" set to "both". It crashes if I try to change the mode to another (depth or color) or if I directly try to play the movie.

    After the crash and a restart I can play the movie or change the mode without problem.

    I tested on MacPro and MacBook Pro

    best

    Jean-François


  • Dear Mark,

    thanks for this,

    Working for me on a MBP 17" 2009 and El Capitan with a Kinect v1 except for the play (managed once to reproduce)


  • I am copying/pasting this from @DanielPineiro 

    [DANIEL: please post bug reports and feedback in this thread!]

    Hello!

    I am testing the lastest version of the Open NI Tracker actor (0.9.7) with Kinect v1 1414, but it freezes all time (it works just for 10 or 20 seconds).

    I am using a basic patch just with the Open NI Tracker actor and a projector. When freezes, the reset input does not work. Some times changing scene makes it work, but sometimes ever not and Isadora just crashes.

    In my case, the former version of the actor worked better.

    Using MacOs Catalina 10.15.4 and Isadora 3.0.7

    Regards!

    MacBook Pro Retina (2013) 2,4 GHz Intel Core i5, 8 GB 1600 MHz DDR3, Intel Iris 1536 MB. MacOs Catalina 10.15.4 Located in Galicia, Spain.


    This is my response:

    I have been running OpenNI Tracker on Catalina 10.15.5 for the last 1 hour and 45 minutes, with no interruption in service.

    Please try setting the 'use callbacks' input to 'off' and see if that changes the behavior.

    Best Wishes,
    Mark


  • @jfg said:

    After further testing, I find out that Isadora crashes if I record a movie with the "capture mode" set to "both". It crashes if I try to change the mode to another (depth or color) or if I directly try to play the movie.

    I am frustrated by the fact that I cannot debug this because I do not have a Xtion camera. I am not sure how to improve your situation without getting access to one. I'll see if I can find one to buy on the internet.

    Best Wishes,
    Mark

  • Beta Platinum

    Hi,

    I still have the issue of the OpenNi Tracker 0.9.7 not parsing with the Masquerade.txt file in OSX Catalina. I am unable to effectively make any tests with the 2 x Orbbec Astra's that I have. When I select 'Move to Bin' i get a crash. Would like to run some tests if I can get around this.

    Using the Plugin 0.9.7 without the masquerade.txt file. With Kinectv2 attached to a multiport hub. The Kinect v2 camera is activated as soon as Isadora is launched (the power light and red camera lights all fired up on the sensor before placing the OpenNi Tracker into a Scene Editor). The Kinect v2 activates quickly initially but then turns itself off after a few minutes. If any of the settings associated with the camera resolution or capture mode are changed the camera immediately turns off and will not start again even after restarting Isadora a number of times. Restarting the computer appears to be the only way to get the Kinectv2 active again. I have run the Kinectv2 three consecutive times - having to restart the computer for each - and the camera activates on the launch of Isadora but then turns itself off after a few minutes, seemingly at a random interval. There does not appear to be any issues with heat of the sensor - it is not hot to touch. 

    Best Wishes

    Russell


  • @mark

    Dear Mark,

    I think it is not so important because there is only a few users of this old Xtion model and all is working well on the MacBookPro if I set capture mode to depth to record.

    There is a "new" (alrady a few years old) Xtion 2 but it is also unavailable. I think it is a dead path.

    Thank you for all.

    best

    Jean-François


  • @mark

    Hi Mark,

    I turned off "use callbacks" and now is working fine. (It is working for more than one hour and still working fine!)

    Thanks a lot!!!!


  • @mark

    I just tried with a very old MacPro running El Capitan (10.11.6) and Isadora 3.0.7

    2008, 2x2,8Ghz Quad Core Intel Xeon, ATI Radeo HD 5770

    Run perfect, also the color mode show the RGB picture not frozen. Only the same problem by recording in both capture mode: crash if I try to read the file directly after recording. Not after I restart Isadora.

    I think that the problem with the frozen color picture on the other MacPro (2012)  is coming from a conflict between USB 2.0 and the USB 3.0 card I have. In the 2008 I have only USB 2.0.

    Also the 3.0.8 version of Isadora is running well on El Capitan.

    NEW: I was confuse, sorry. There is no problem on the MacPro 2012 if I connect the Xtion to USB 2.0. I don't why I had this time no problem with playing directly after recording in capture mode both ??!!. It seams to be randomly.

    The problem with the frozen color output is on the MacBook Pro with USB 3.0. I think it is coming from the old XTION. There was a patch to update the XTION to USB 3.0 but the link is dead and I lost my download by a hard-drive crash. 

    Sorry for the confusion.

    best

    Jean-François


  • I am getting the same message as @bonemap, in addition/consequence Isadora can not load OpenNI Tracker (ID = '5F4F4E42') 

    Isadora USB 3.0.8b | OS X Catalina 10.15.4

    I didn't want to post a huge image but it won't budge, apologies.


  • @danielpineiro said:

    @mark
    Hi Mark,
    I turned off "use callbacks" and now is working fine. (It is working for more than one hour and still working fine!)
    Thanks a lot!!!!

     After 4 hours working like a charm, I decide to finish the test. 

    Thanks again Mark.

    Best regards

    Daniel


  • @mark

    I have updated/corrected my previous answer. Sorry for the confusion.

    Later: I have found a firmware for the Xtion but a PC is needed and I haven't one. It will take time until I can make it.

    best

    Jean-François 


  • @bonemap and @fubbi 

    I don't know why you are getting this "plugin is damaged" error on Catalina.

    To be sure that there wasn't some interference from homebrew (the package manager I use on OS X for development) I completely uninstalled it. Then I downloaded the plugin from the link given in the the v0.9.7 release thread and installed it. I also placed the masquerade file in the Resources folder (very important it is in this folder and no other!)

    On Catalina 10.15.5 (I don't have 10.15.4) it all worked as expected in 3.0.7. (Are you using the beta??)

    Do you have your security preferences set like this?


    I suppose you must otherwise Isadora itself wouldn't run. But please check.

    Also, I uploaded a second version of 0.9.7 at 10am Berlin time on Sunday. Could you have gotten the version before that? (If you're unsure, download and install again please.)

    I guess I need you to try the following:

    1) Right click the Isadora application.
    2) Go into Contents and then into MacOS
    3) Double click the file "Isadora" which will run Isadora in the Terminal window.
    4) Copy anything that appears there in that window up until Isadora is running (and you've gotten the error) and paste it here.

    Thanks for following up with this.

    Best Wishes,
    Mark


  • @mark

    I don't know if it is useful but I tried with Delicode Ni_Mate and both depth and color are working fine. But there is in the preferences a "default to USB 3.0" option:

    we can see when you are back in Berlin. I can bring my Xtion.

    thanks

    best

    Jean-François


  • Dear @bonemap, @fubbi and all on Catalina

    For those of you that need the masquerade.txt please try the following procedure

    1) Go to ~/Library/Preferences and delete com.troikatronix.isadora.scanned-plugins-v3_0.txt and all Isadora Preferences files (e.g, Isadora Prefs 3.0.7.izp)
    2) Install OpenNI Tracker.izzyplug fresh from the download
    3) Boot up Isadora. You should be able to add the OpenNI Tracker to the Scene Editor
    4) Quit Isadora
    5) Install masquerade.txt as instructed in the READ ME file.
    6) Restart Isadora and add OpenNI Tracker to a Scene. Does Catalina complain?

    Does that solve it for you all?

    Best Wishes,
    Mark

  • Beta Platinum

    @mark said:

    Does that solve it for you

    Yes it does. Clearing the preferences seems to have cleared the issue.

    Thank you

    Best wishes

    Russell


  • @bonemap said:

    Clearing the preferences seems to have cleared the issue.

    I don't think it's clearing the preferences by itself would have solved the problem.

    I think that it is because you must first get the plugin to successfully load (without any masquerade.txt file). Then you can quit add the masquerade.txt file and restart Isadora without Catalina freaking out.

    That said, I'm glad it's working.

    Best Wishes,
    Mark

  • Beta Platinum

    @mark said:

    I'm glad it's working

     Me too! 

    Best wishes 

    Russell