• Hi even though I have a new 16" mac pro with AMD Pro 55004gig graphics card my videos just jump really badly. The red load bar goes well over 1000.

    Having spent well over £2000 for the mac thinking it would handle videos beautifully I am really disappointed!

    How can I solve this problem?

    Stay safe and well

    Thanks, David

  • Tech Staff

    @vidasonik

    Please give us more information about the resolution and codec of the video. How many videos play at the same time. Are you just playing the videos or are you using any effects.

    Best Michel


  • @vidasonik said:

    Hi even though I have a new 16" mac pro with AMD Pro 55004gig graphics card my videos just jump really badly. The red load bar goes well over 1000.

    This is for sure not normal.

    As @Michel requested, please give us more information about the number of videos you are playing, their resolution and their codec so we can help you sort this out.

    Best Wishes,
    Mark


  • Thanks for your reply!

    I am trying to attach screenshots but it doesn't seem to work ..


  • @michel it seems to have worked! I'll try and send another ...


  • @michel hi can you send me an email address for sending the screenshots - it isn't working!

  • Tech Staff

    @vidasonik

    I can see the one screenshot. What I see is that you are using an cpu effect, this will definitely slow down your frame rate. As far as I know the explode effect is also available as a gpu actor. Try avoiding cpu effects. What we still don't know is the codec and resolution of your videos. What version of Isadora are you using?

    Best Michel 


  • @michel Hi Michel I'm using Isadora 3.0.7. The videos are Quicktime, some are MPEG-4. I usually edit in Final Cut and 'share' as H.264 1920x1080 though I select 'Apple Devices 1080p'.

  • Tech Staff

    @vidasonik

    Does using the gpu explode effect help?

  • Tech Staff

    @vidasonik

    As Michel said you'll want to use explode in gpu mode. Delete the links between your Movie Player, Explode, and Projector actors so none of them are connected, then connect a GPU effect to your Movie Player or Projector and it should mutate the video type to GPU. Then reconnect everything and each one should mutate to vid gpu in turn. If that doesn't solve the problem, it may be easier to assist you with this if you create a support ticket using the link in my signature. 

    Best wishes,

    Woland


  • @woland The only problem is that Displace doesn't seem to have a gpu option?

  • Tech Staff

    @vidasonik

    Sorry, there's not a Displace actor in the screenshot so I didn't know you were using it. Displace is CPU-only because couldn't be upgraded to GPU, but @jhoepffner made a GLSL shader that mimics displace's functions I believe.

    Best wishes,

    Woland


  • @vidasonik

    Just os you know, in the thread that @Woland pointed to above, I got into a lot of detail about why the Displace actor simply cannot be accomplished with a GPU accelerated shader.

    To quote myself there:

    This [shader] will not give the same results as Isadora's Displace actor.
    I have edited your code to add a comment to indicate this to avoid confusion among the users. In fact, your algorithm is much closer to the functionality of the Scanner actor.

    That said, it sort of does kind of the same thing. So that's what you should try working with.

    Best Wishes,
    Mark


  • @mark brilliant - thanks! The exact effect doesn't matter I'm just creating psychedelia!! Just please remind me what codec will take a lower toll on the processor. I tend to use Quicktime, some are MPEG-4. I usually edit in Final Cut and 'share' as H.264 1920x1080 though I select 'Apple Devices 1080p'. I've started to make them shorter as sometimes I use 2 videos at the same time through eg. the FX select (XOR). I also love the Rutt Etra! Thanks for al the help, Dave

  • Tech Staff

    @vidasonik

    I guess with Quicktime you mean .mov but thats not a codec. I made a small sketch to visualise it. On the left side are the so called containers, some a capable to hold multiple audio channels and subtitles others not. Knowing the container does not really tell you what codec is used. On the right side you see different codecs. Not all containers can hold all codecs. h.264 is fine on a modern computer, but for interactivity the best codec to go on a mac is either AppleProRes 422 or HAP. 


  • @michel thanks a lot! I need that education! I use H.264 cos the file size is much smaller than Pro Res 422 but maybe I should convert to HAP?

  • Tech Staff

    @vidasonik said:

    I use H.264 cos the file size is much smaller than Pro Res 422 but maybe I should convert to HAP?

     H.264 is smaller because it uses more compression. This also means that more resources are needed to decompress the video. This will be either CPU or GPU time depending on the system. H.264 also merges frames as part of the compression method This means that jumping to any specific frame in the video requires loading and decompressing a number of frames (since data is shared). This method works well for linear forward playback, but not much else.
    Pro Res and HAP both compress each frame individually, so jumping to any specific frame is a matter of loading the frame and decompressing the single frame.
    In the case of HAP, decompression occurs on the GPU, leaving more CPU available for Isadora. This makes HAP the best choice for highly interactive projects.


  • @dusx Great! So how do i convert my videos to HAP?

  • Tech Staff

    @vidasonik

    I corrected a typo in my post above. I did write "on the left side you see the different codecs" but I meant on the right side.

    The HAP codec will possibly give you larger files than AppleProRes 422. To convert videos to HAP you have to install the HAP Codec first (https://github.com/vidvox/hap-...) and then for converting you can use this batch converter (https://github.com/Vidvox/hap-...)

    Best Michel


  • @michel Hi Michel thanks so much! I've converted one video and replaced the original with the HAP version and it seems much better!