In the middle of tech: Issues with two patches running on two different stages

  • OS X 10.9. Isadora 1.3.1f02

    Macbook Pro Retina
    I have two patches loaded in Isadora, which I intend to run simultaneously and independently time-wise.
    Computer is connected to two projectors (using hdmi and display port).
    Isadora correctly recognizes the two stages in preferences, where I activate projector 1 as stage 1 and projector 2 as stage 2.
    I can only see projection output from one patch at a time: if I activate patch 1 and hit Contrl+G, stage 1 projects an image, but not stage 2 (driven by  patch 2). If I switch to patch 2 and hit Contrl + G couple of times, projector 2 starts to project, while projector 1/stage 1 goes dark.
    I can use both projectors outside Isadora fine.
    Are there any suggestions how to make both stages on all the time?
    (In the worst case, I could bring a second laptop, but the control room is crowded as it is ;-)
    BTW: This a WIP at Baryshnikov Arts Center, which will have open rehearsals/previews on Dec 18 so if in NYC come and see.

  • Dear Eight,

    You need to turn off "Floating Stage Windows" in the Stage tab of the  Isadora Preferences. (By definition, floating windows disappear when you deactivate the application. This is standard behavior on all Mac OS and Windows apps that have floating windows.)
    Best Wishes,

  • Thanks, Mark.
    However this setting does not seem to have any effect. Restarted Isadora etc.


  • Dear Eight,

    Maybe this is a new Mac OS 10.9 behavior. Try this tip from the discussion of Isadora and Mavericks on this forum:
    "Go to System Preferences > Mission Control >Turn “Displays Have Separate Spaces” OFF and then restart machine."
    See if this has any effect.
    Best Wishes,

  • Mark,

    That setting was always off, otherwise I'd have a bar on top of the screen. However, turning it on seems to "fix" the problem: both projectors started working.

  • Dear Eight,

    You say it's work, so if it's working then great
    But, it just dawned on me what the problem is. Remember, every patch opens it's own set of stages. So, if you have it set in the Preferences to show stages on both monitors, it would go something like this:
    1) Go to patch one, show stages. Two stages are shown on Display 2 and Monitor 3..
    2) Go to patch two, show stages. Two stages are shown on Display 2 and Monitor 3, which **co**_**vers the other previously shown two stages**._
    Because the stages shown in step one are covered, you only see video on one of the two stages. Make sense?
    Problem is, there isn't a good way around this. The only way I can figure to do it.
    1) Make two copies of the Isadora app
    2) Launch both, ignore the warning about simultaneous copies.
    3) Set up the Preferences in Copy A to show Stage #1 on Display 2\. Set Stage #2 to show on "none"
    4) Show the stages in Copy A.
    5) Go to the Copy B. Set the Preferences to show Stage #2 on Display 3\. Set Stage #1 to show on "none"
    6) Show the stages in Copy B.
    Unfortunately, there's only one copy of the Preferences file, so you'll pretty much have to go through this procedure each time you want to show the stages.
    You really can't do it in the same copy of Isadora, because every time you say "OK" in the Preferences, it hides and then shows the stages in the current configuration.
    I have no idea what impact running two copies like this will have on your patch. Please proceed with caution.
    Best Wishes,

  • Thanks Mark.

    It seemed to work, but the bar across the screen makes it unusable, of course. Also, I noticed other strange things, like pressing the bar to switch a scene seemed to switch the scenes in both patches. I do not have a lot of time to play with it (also that lighting guy makes it too hard to notice what exactly is happening with the projection ;-), and luckily, was able to convert everything into a single patch.