Routing audio to different outputs

  • Beta Platinum


    How can I route the sound to different outputs. I have a RME Fireface and I configured multiple speakers in audio preferences. I selected the channels in Isadoras sound output setup. 
    Is it possible to mix one sound inside Isadora to different outputs. I have the core upgrade and I´m looking at different actors like AU MatrixMixer etc, but I didn´t find one for changing the output, or mixing to different outputs.
    I managed to play from different outputs in the sound players play channel tab or movie players snd out, but this way, there is no mixing inside Isadora, so no interactive mixing stuff.

  • The total mix software that comes with your fireface is totally remote-able via midi. You can send a few sounds to a few outputs and generate complex routing and mixing via midi in the hardware. I found this to be a very reliable way of working and I feel it is more solid than doing audio with Izzy.

  • Beta Platinum

    Thanx Fred!

    Never done this before. I have the old Fireface 400 and I have no idea how to route the faders there. I´ve been into the preferences in the firefacemixer and chose Isadora virtual out and enabled MIDI. In the RME manual its written: "The channels being under MIDI control are indicated by a colour change of the info field below the faders, black turns to yellow." Here I´m stuck because I don´t see faders turning yellow.

  • It is in the manual - maybe you should up-date the driver and total mix as well.

    The mackie protocol is here
    you will need to send a ping to trick the system into thinking you are hui compatable hardware
    you’ll need to respond to its “active sensing” ping messages. The DAW sends note 0 with velocity 0 on channel 1, and expects to receive note 0 with velocity 127 on channel 1 in response. So you need to make a little patch that responds appropriately.


  • Beta Platinum

    @fred Thank you for your answer and link! At first it sounded a bit chinese, but after some days meditation I made some improvements ;-)

    First: I got the yellow thing in my fireface mixer, hurray!
    Then: I found the mackie control thing in cubase, made a midi track and the fader moved in the fireface mixer, can´t believe it ;-)
    Now I imported the midi file in Isadora and all 8 faders are moving. So I guess its the "you will need to send a ping to trick the system into thinking you are hui compatable hardware" Here it is still chinese for me, sorry ;-) No idea what this is, the ping?
    Can you explain a bit further?
    Thank you so much again for your help!
    All the best,

  • I am not sure if it is needed (I use a fireface UCX which has OSC control), but some audio devices use a standard midi protocol called HUI. When devices use the HUI protocol (just an agreed upon set of commands) there is a constant chat between the software and the controller. Ie the software sends sends note 0 with velocity 0 on channel 1 and every time this is received you should send  note 0 with velocity 127 on channel 1 back to the software. This way your software thinks it is talking to a HUI device. If you have the faders moving and it does not give you an error like HUI device is offline after a few minutes then I guess you don't have to worry about it. If you do lose connection I would try adding this to your patch.

  • Beta Platinum

    Faders are reacting if I´m sending the Midi from Cubase. The exported file also moves the faders. But sending directly from Isadora is not working till now. Maybe the newer Fireface UCX with OSC responds better to that workflow.

    So there is no other option working inside Isadora for flexible multichannel output routing?

  • You may have to send a note off for your note on commands if you use them ie send a following note with velocity 0. This will be by far the most reliable way to do the audio routing