assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

OSC anomaly



  • For an upcoming production, I want to use 3 laptops: 1 Master and 2 Slaves. The Master will be located in the control booth of a theatre, the Slaves backstage. The Slaves will render their own content independently.

    Master scene list: Each scene contains an Enter Scene Value actor patched to two OSC Transmit actors. Each OSC Transmit is sending a value to a Slave.
    Slave scene lists: Each contains an OSC Listener actor to receive the value from the Master. This actuates a Jump actor to the next scene. There is also video content in each scene, with each Slave holding unique content.

    The problem I’m having is that Slave 1 is receiving the jump correctly and Slave 0 (see below) will also receive the jump correctly, but Slave 2 is not receiving the jump correctly. When I open the Communications/Stream Setup dialog and click Auto-Detect Input, Slave 2 does correctly detect the value being sent. I used a Wave Generator Actor to test this; inside the Stream Setup dialog I can see the value changing. But when I click OK it doesn’t accept the new stream. The only thing that happens is that the ‘-‘  (minus) button on the left hand side of the box briefly greys. If I manually input the stream, I can click OK, but the stream isn’t active in the scene. There is still no response to the Master OSC Transmit at Slave 2.

    Slave 1 and Slave 2 settings are identical to the best of my knowledge. (EDIT: they have different IPs and different Computer IDs which I've confirmed are correct in scenes.) I have confirmed that the OSC Listener is listening to the correct channel (same as Computer ID) and that the ports agree. I have checked and double checked firewall and other settings, I’ve opened the Slave 2 file on Slave 3 and vice-versa, and I’ve uninstalled Isadora and then reinstalled it. No change.

    Master: Acer TravelMate 2420 notebook, Windows XP
    Slave 1: Asus N53S notebook, Windows 7
    Slave 2: Asus N53S notebook, Windows 7
    Slave 0: Asus G55V notebook, Windows 7 – which I have used only for testing. Using this for the performance is not an option.

    (edit 2: added tag.)



  • I use Osculator to manage OSC. best



  • It appears that OSCulator is a Mac-only application. Thanks anyway.
    Anyone have any help for my problem on Windows?

    Thanks.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.