Wiimote Osculator problem



  • Help please,

    I have a Wiimote linked to my computer via osculator (2.13) this is showing it receiving info from the Wiimote and it is set to send OSC on osc.udp://localhost:1234, (by selecting localhost:1234 (VDMX)) Isadora (1.3.0f24) is set to receive on 1234, but I just can't get anything in when I go to Communications/Stream Setup.

    Is there a common stupid "you forgot to do ..." getting really frustrated, I can get my iPhone to talk to Isadora using TouchOSC and MrMr directly but the internal OSC has really got me flummoxed.

    I'm running on a MacBookPro under 10.9.1

    Thanks in anticipation

    Pete


  • Tech Staff

    Try typing in 127.0.0.1 rather than localhost (its the same thing) but might be worth a try.

    In stream set up are you clicking auto-detect? 


  • I would use the most recent version of Isadora(1.3.1f06) if possible - always.

    Edit: However it may not solve the issue. I have not used Wii for some time and I can not discover osculator this way either.

  • Tech Staff

    @PedanticPete

    Can you post your osculator patch so we can check if your settings are ok?

    Best
    Michel



  • Try this out: midi setup, choose Osculator,

    EventType is MIDI CC,

    for OSC: EventType: OSC Routing  Value:  /wii/1/button/A,

    you have to route all messages you need for isadora or use Osculators midi out.

    best....



  • Hi there,

    Thanks for the ideas ..
    [Skulpture](http://troikatronix.com/troikatronixforum/profile/6/Skulpture) using 127.0.0.1 didn't help I am using auto detect in Isadora
    [vanakaru](http://troikatronix.com/troikatronixforum/profile/44/vanakaru) using 1.3.1f06
    [Michel](http://troikatronix.com/troikatronixforum/profile/9/Michel) its not allowing me to upload the osculator file
    [rainbow](http://troikatronix.com/troikatronixforum/profile/5840/rainbow) I'm feeling  a bit stupid I thought that value had to be osc.udp://localhost:1234
    Stuck would love for Michel to look at the patch but I get File upload failed. Reason (wii_test.oscd) Uploaded file type is not allowed
    Thanks in anticipation ... I have got until July to sort this out lol
    Pete

  • Tech Staff

    @PedanticPete

    Zip your file and you can upload it.

    Best
    Michel


  • Tech Staff

    @PedanticPete

    Here are a few screenshots to show you how to configure OSCulator.

    Best
    Michel
    d1a2b9-osculator1.png ff4c05-osculator2.png



  • @Michel

    Thanks very much for the images, I really don't think I understood the Routing, so I have copied yours but it still doesn't show up in Isadora when I do an auto detect in Communications/Stream Setup ...

    I have attached the OSCulator file, when I move the WiiMote it duplicates the Value ti a new message ...

    Thanks ever so much for looking at this

    Pete
    c0ffc9-wiitestmichel.oscd.zip



  • This is wierd. I tried to troubleshoot your problem. I was not able to get your OSCulator file to connect with Isadora. Then I created new one and it when trying to set up Isadora I got this really funny error message after routing was auto-detected by pressing a button on Wii and choosing /isadora/1.

    Then ignoring it in a threat of being shut down(clicking ”cancel” on stream setup window) I got the connection just fine.
    But when trying your file again I got nothing and my OSCulator file does not work any more either.
    Look at the bug report>>>
    Some 2 years ago I was using this method connecting Wii during 6 concerts without any glitch.

    8ba5c5-screen-shot-2014-02-06-at-22.05.23.png 8d116e-bug-osc.txt


  • Tech Staff

    @PedanticPete

    As what I see is that you set the OSC input Port in OSCulator to 1234, thats the same port that Isadora uses by default. This causes a problam and if you send a message you get something like a signal feedback. Thats why you have the Isadora entries in OSCulator on the top. I attached the corrected file.

    Best
    Michel
    8cfa53-wiitestmichel.oscd.zip



  • I tested Michel's OSCulator file. On my system Isadora connects without going to stream setup at all(maybe it remembers the last settings). But when I do go there I get my weird message again. Otherwise it works fine.



  • Dear All,

    First, in 1.3.0f24 Isadora did not prevent you from using the addresses /Isadora/1, /Isadora/2, etc. This was a mistake. These are "built-in" (i.e., always present) and you don't need to add them to the the Stream Setup window. That's why Vanakaru got the error  in 1.3.1f06.
    And Michel is right: you can't have Isadora using 1234 as an input port while OSCulator also uses 1234 as an input port. These numbers must not "collide."
    Hopefully that helps.
    Best Wishes,
    Mark


  • Thanks for all of that feedback ,

    I really feel bad when I put something up and get feedback and don't respond quickly as it might appear that I do not appreciate the generosity you are giving to me ...

    Been at work all day basically, including stupid corporate uni lunchtime meetings, and then an afternoon of interviewing students for next year (that's the good bit of the day!!), don't get me wrong I love it, but then I do need to have a drink and a cryptic crossword before I go home :)

    Thanks for your help

    Ive got some of the weekend to have a play and in the UK there is a University lecturers strike on Monday so I will see what I can do whilst Human Resources decide how much pay to dock ...



  • Thanks very much, you've all helped make my weekend, @Michel I really didn't read that it was the OSCulator OSC input port and just saw 1234 and thought that was good, not realising it would 'Collide' thanks @mark

    I love it when stuff happens

    Pete



  • might have spoken too soon ...



  • No its ok just panicked at the stream set up error and then reread all the replies, I'm in heaven :) now I just have to do something cool with it ... its going to involve a double pendulum but I don't get a studio space to build it in until our staff Summer lodge at the end of the academic year, will share when done

    Pete, thanks again //xx



  • Glad you got it working. Have fun. ;-)
    -- M


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.