Can't click media in Show Media window.



  • I'm having a problem. I'm using a Mac with OSX 10.9.1 and Isadora core version 1.3.0f24.  For some reason I can't edit the media in the Show Media window.  I can't click on anything and the only way to add media is to either drag stuff in or going through  the menu.  I can't right click and import media.  It is very frustrating.

    Let me know if you've seen this.

  • Tech Staff

    Close the window and then go back to it using Windows > Show Media.

    Sometimes when you import stuff and then leave the window it can behave strangely.


  • No go.  It was a good suggestion.


  • Tech Staff

    @RoccoD

    Download the neweset pre-release and check if the problem is solved there.

    Best
    Michel



  • Dear RoccoD,

    I am away from home and don't have access to a Mavericks machine, so I can't attempt to recreate this. But try Michel's suggestion (download the pre-release from http://troikatronix.com/download/isadora-pre-releases/) and see if it helps. If not, let me know here and I will look into this as soon as I can.
    Best Wishes,
    Mark
    P.S. Actually, if the prerelease doesn't solve it, send me a formal bug report please.


  • The pre-release didn't work.  This isn't a pressing matter for me.  I was more curious if anyone else has come across it.  Actually the show is already over anyway.  I'll submit the bug report.



  • I have more info.  This is really weird.  The problem only happens when I have the drahwerk's iwebcamera selected as my source in the capture control panel.  It doesn't matter if it is on or not.  drahwerk's iwebcamera is that app for iphone that lets you use an ipod as a webcam.  It also prevents me from changing settings in the live capture settings.



  • Dear RoccoD,

    Well, that is very strange indeed. I have no idea how that could be, but I'll buy the app and try it myself. Please send a formal bug report with this information in it.
    Best Wishes,
    Mark


  • Report has been sent.  Thanks Mark.  Now that I know what the problem is I can work around it.  I just change the input to none and I'm good to go.  I could be osx 10.9.1 that is the problem since I don't remember having this problem with previous versions of osx.



  • Dear RoccoD,

    Well, their VDIG (the component that brings video into QuickTime) is doing something quite dodgy. They are creating an invisible application window, with the dimensions of 26x22 pixels, right in the middle of the main display. Furthermore, it shows as the front most window in the list. Isadora thinks this is the selected, active window when you click, and is gets confused. 
    What they're doing is really strange. In my opinion, it's not an Isadora problem.
    I sent the letter below to the developer's this morning. I would suggest it's a good idea to write them too, as the more email they get, the more likely they are to respond.
    Best Wishes,
    Mark
    -----
    To the engineering team: my name is Mark Coniglio, and I am the creator of a software called Isadora (see http://troikatronix.com)

    One of my users has identified an incompatibility between my Carbon (i.e., pre-Cocoa) application and iWebcamera. I believe this is due to some unusual and not "by the book" behavior on the part of your app, not my program.

    After selecting the iWebcamera as an input device, the user can no longer click on certain windows. It seems your application is creating an invisible, unnamed window with the dimensions of 26 x 22 pixels at coordinate 916,942 on my main display -- and it is putting it at the front of the window list. For a VDIG to create a frontmost document window in the main application's window list would, in my humble opinion, be quite a dodgy practice.

    The following behavior occurs when Isadora is running, and iWebacamera is selected as the video input device:
    when the user clicks on a window, my app calls GetFrontWindowOfClass(kDocumentWindowClass, true)) to determine if the clicked Window needs to be brought to the front. This call returns the iWebcamera window instead of the actual front window.

    Furthermore, calling GetWindowKind() on your window returns a value of kApplicationWindowKind, indicating it is an application window.

    Can you comment on any of this behavior? I would like to support my user who is using your product any unable to work without deselecting iWebcamera as the input device.

    Thanks in advance for your response.

    Best Wishes,
    Mark



  • Wow Mark.  That is weird.  I'm glad you were able to recreate it.  I'll email them as well.


  • Tech Staff

    Wow that is SUPER weird!


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.