assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

HD video on SD stage



  • Hello,
    does anybody know if it is possible to place an HD-resolution video on a SD-resolution stage? The idea is to zoom in the video live, but without quality loss? So the movie should be bigger as the stage. At the moment the video is always scaled according to the preference settings.

    Hope somebody has experience in this!

    PS: what is the best codec for HD files on windows. I tried a *.mov with DNxHD but my frame rate in isadora  goes to much down.



  • Dear niknalm,

    Yes, this is totally possible. Just enable the 'keep aspect' input, and then use the 'zoom', 'horz pos' and 'vert pos' to control what part of the image you see.
    Best codec for HD files on WIndows is WMV or AVI. (QuickTime just doesn't perform as well as the native Windows media playback systems.) To use WMV or AVI, go to the General tab of the Isadora Preferences and enable "Play Windows Movie Formats Natively" checkbox. Then import your WMV or AVI files.
    Best Wishes,
    Mark
    Mark


  • Hi Mark,
    thanks for your answer.
    I hope I understand you right. I tried your suggestion, but it doesnt work somehow.

    I have a stage with 720x576 (I set this up in the preferences in the "default resolution")
    Now I want to import and play a HD-1920x1080-movie. So when the movie is on 100% size (zoom) it should be cropped, because the stage is smaller than that. But in isadora it is scaled down to 720x576, so that I have to zoom in (for exemple to 200%) to get the same effect. So I lose quality and the image doesnt look so nice anymore.

    In the end I want to do all that with the 3D Quad Distort projector.

    Greetings,
    Niklas



  • Dear Niklas,

    The default resolution is only meaningful when the Video Image Processing feature is set to "Scale to Default Resolution." But you shouldn't use this. It has no impact on the output resolution of the stage. If you changed the Video Image Processing settings, change it back to "Scale to Smallest" or "Scale to Largest." Don't use "Scale to Default Resolution" unless you know what you're doing with this feature. (There's more detail in the manual.)
    To check the resolution of your media, hover the cursor over a wire coming from the Movie Player actor. What resolution does it report? It should be 1920x1080 (or whatever the resolution of your video is.)
    If you set the Projector Actor to 100%, then the width of the image (1920) will be scaled to match the output device width (probably 1024.) So you will not lose quality since the image is being scaled down, not up. Going to 200% should look great if the source media is HD.
    Best Wishes,
    Mark


  • Hello Mark,
    I checked the video-resolution on the wire and it shows 1920x1080. As you explained me now it works fine. Thanks! So now I work on HD-resolution so I have to get theses files runnnig on my computer (8GB RAM. Intel I5, 3,1 GH) As I understood in your "optimise for speed"-article the graphic card is not so importend. I use my onboard one. Is that ok, or should I get an extra one?

    To go more in detail with the HD-movie compression. You said I should use avi, but wich codec is best for Isadora?

    Greetings,
    Niklas



  • If you're on a PC, yes, AVI or WMV is your best choice. But it is very important that you go to the General tab of the Isadora Preferences and enable "Play Windows Movie Formats Natively" checkbox before you import the movies.

    The onboard graphic card is fine.

    Best,
    Mark


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.