assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Sound player actor "pops"...



  • hey everybody-

    here's a funny glitch- playing audio (.wav files) through the sound player actor results in a "pop" at the end of each, regardless of how the play length is adjusted.  i'm using a keyboard watcher to trigger the sound player actor to play accent notes to follow the action on stage, pretty simple stuff.  
    granted, i started a new project and downloaded the 1.3.1f06 pre-release.  i don't recall having this issue in older versions so perhaps it's a bug?  it wouldn't hurt me to downgrade to the more stable version, thought i'd ask here first.
    ** okay, i went ahead and downgraded to 1.3.0f24 and now sound player "pops", plays the file and crashes altogether.  this is in the show file i was working on before and even if i create a new one native to 1.3.0f24\.  SO, perhaps i'll upgrade back to 1.3.1f06 and keep working, but still, the pops persist.  is there something simple i'm missing?
    running an imac, OSX10.8.5, 3.4 i7\.  
    cheers, alex.

  • Tech Staff

    I've had this every now and again. Ive found its a problem with the audio file not Isadora. Try setting the length to 99, or 98, does it still happen then?



  • hi- it happens with multiple files in multiple (sound player) actors, all set to different lengths. definitely not in the file as you can play them outside of isadora and there is no pop.  all are .wav @ 44100/ 8.

    thanks!
    alex.

  • Tech Staff

    Hmm ok interesting.



  • indeed!  :)  thanks for your help...

    ...i should also say that i get this behavior on my laptop as well, on which i'm running the show, an older macbook pro, OSX 10.6.8, 2.4 core2duo. 
    alex.

  • Tech Staff

    Yes very strange - I need to check this out when I get the chance. Any chance you could upload a small sample of the .WAV?



  • AHA!  a little digging/ fiddling reveals that a 16 bit .wav file does NOT pop at the end, while an 8 bit file will.  good to know!

    now to go and convert all of my 8 bit .wav files.  (sigh.)
    ---> alex.


  • I vaguely remember something about Quicktime or Isadora sound player needing to "turn off & on" at the end of a .wav. Solution was sending a zero volume to keep it on until needed again or converting .wav to .mp3 and using the movie player. All this sounds silly to me as I type it but it might trigger someones memory for the correct answer.



  • Are you sure that the sound level is at 0 at both the start and the end of the sound? If there's a DC offset (for instance) you can get a pop. I usually take all my .aiff or .wav files (at least the ones I'm going to loop) and use Audacity to make a very very short fade in at the beginning, and equally short fade out at the end. That way you're sure that the level is zero at the loop point.

    Try my suggestion and tell me if it makes a difference. You should be able to get clickless loops this way.
    Best Wishes,
    Mark


  • thanks mark.  i just made all the files 16 bit and it cured the problem.  adding a little short fade ramp to the files makes sense too, i'm just tight on time for this one.  you know how it is!

    cheers, 
    alex.

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.