assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Bump out of audio at bottom end of audio



  • So I've noticed something strange recently about the Movie Player volume control as I've started using Izzy in a new theatre.  It might be due to the better acoustics of this new space, or the fact that I'm running the sound system really hot, but here's the deal...

    In order to control the shape of the fade in and out of my movies, I attach an Envelope Generator to volume.  The volume fades as expected until it hits .1954, at which point the audio bumps out.  I can adjust the EG to compensate some to make it less noticeable, but I can't get a fully smooth fade out, and I can't drop the levels of the sound system, as I need the full range of extremely loud sounds to extremely quiet sounds.  Is this an actual bug, or am I just missing something?  I am running ver. 1.3.1f06 coreaudio/video on a mac mini on mountain lion, but I also tested on my MBP running mavericks.  Any ideas?


  • Hi,
    Try to curve the output of the envelloppe generator with curvature actor. Maybe it will help.

    Best
    Philippe



  • Hmm, thanks for the tip!  Using curvature helps to smooth out the curve, and makes it easy to adjust the shape on the fly.  I can certainly make it less noticeable, but there's still that hitch at the end of the fade.



  • i'm experiencing the same issue. even with a 20 second envelope fade going into a very curved curvature fed into another very curved curvature, the final bit of the fade sounds like the audio has been cut.



  • What exactly do you mean by "bump out" -- the volume goes to zero? Or jumps up to full? Or?

    What kind of file format are you playing? (Not that it should matter, but...) Photo JPEG? H264? How is the audio compressed for these movies?

    Best Wishes,
    Mark



  • Right, sorry if that wasn't clear.  The volume fades as normal until it reaches .1954 (in the movie player), at which point the volume cuts out completely and abruptly (even thought the integer within the movie player continues to fade all the way down to zero).  I've noticed it using several formats, specifically on this show with MPEG layer 3, stereo, 44.100khz with a data rate of 159.96 kbits/s and also Photo JPEG, Apple Lossless, stereo, 44.100khz with a data rate of 35.46 mbits/s.  Does that make sense?

    Thanks!
    Doug


  • I just tested this and it was hard to see but I could reproduce it. I had to make envelopes where the volume started at 5 or less going to 0 feeding the volume of the actor and running over a few seconds and then I hear the jump down.I would guess this is normal behavior although a little undesirable. My guess is that as you fade the very very low volume stuff passes under the threshold for the lowest bit of resolution. Unfortunately when you try and import 32 or 24 bit audio files into Izzy it says it can only handle 16 bit max so we don't have an option to work at a higher bit depth (increased and more accurate dynamic range is one of the major benefits of higher depth, this is especially noticed for reverb tails that have an unnatural curve in lower bit depth systems)

    I also tested with aiff and the quality of the fade was a little better- which is obvious, there is more resolution there.

    Can you tell us what the start and end volumes of your fade are?

    When I test it with the same perceivable start volume there is no problem when my fades start over around 8 of the 100 on the volume. When I go below this I really hear the abrupt drop in volume.

    Having this much volume variation is very large- do you have an audio engineer working with you for the production - to master the files for optimum playback? I would suggest re-mastering your audio- the dynamic range you have between 100% and 8% is huge, really really huge- If you are using well mastered audio tracks and you were not blowing the heads off the audience in the loudest parts I would be surprised if you can hear under 5% at all, even in a very quiet room. If this is done correctly your dynamic range (not perceived but what you are working with in terms of numeric values) could be reduced, you could turn the amps down, turn up the levels on the very quiet stuff and this problem would no longer be apparent.

    You can probably reproduce this by playing a fade out on a normal CD audio track and turning the volume way way up- you will hear clunky drops in what at lower volumes appeared to be a smooth fade.

    Audio level is a lot about perception, I was a professional audio engineer for film and TV for 8 years, in this respect we have to work with quite limited dynamic range- due to the broadcast and dolby spec for theatres. If you know what you are doing you can trick people into thinking there is a massive dynamic range when in fact there is very little (generally film and TV peak at -10db FS- by industry standard (this varies from country to country but only from -12 to -8), so we loose a huge part of our resolution), within this we can still blow people's heads off and have them straining their ears for tiny sounds. Using more intelligent ways of getting dynamic range is also a bit kinder on your audience, no complaints no headaches and generally less fatigue for all involved in the production.

    Using proper EQ technique - especially in conjunction with a calibrated mixing room and a good spectrum analyser and proper compression and good mixing (when preparing your audio) you should be able to avoid these problems. My guess is with properly mastered audio and a well set up good quality sound system you could get rid of this. You could avoid trying to get good resolution from the last one or two bits of information in a file. You can see the signal to noise ratios of various bit depths here http://en.wikipedia.org/wiki/Audio_bit_depth

    Having said that this jump in volume (down not up) as you go over the last 2-3% of the available volume is not so useful. It would be great to be able to use audio in Izzy at higher bit depths- or better yet floating point resolutions as employed by most audio software these days.

    Without re- mastering the sound to improve you gain structure you could try playing the audio from an external software that you can control by midi, one that employs floating point precision and has the ability to produce more resolution at this level. If you do so it would be advisable to start with high quality audio as a source - not mp3 or other compressed formats that employ variable bit depth, and then convert this with a high quality converter to 24 or 32 bit so you have the resolution at the low levels. Or as it seems your audio is attached to video use a container that allows for PCM audio- this is real audio. Although MP3 can sound ok, trying to get high resolution at low volumes is the place you will really notice the limitations- it is not a good quality format for working with but great for listening to from your phone as you take a walk.

    Fred



  • Oh and what is your gain structure do you run pink noise at unity with a DB meter to get your perceived max level and then set by changing the amps?



  • Thanks Fred. loads of advice. i'm using an mp3, with the level going from 85 to zero. the abrupt drop in sound is around 1 or 2 percent, so - in theory - it should be smooth, but in practice, it sounds a bit clumsy. i'll try to get hold of an uncompressed version of the audio and see what happens.

    john


  • I am curious to see what happens. To make the most of the bit depth you have your files should be normalised (well depending on what you are doing- this is not a rule for all audio). If your files are normalised (and well mixed) they will be using all the available bit depth- the 100% will be louder than it may be if the files are not normalised, thus meaning you can turn the amps down and you might not hear that jump.



  • If you are using a digital mixing desk (01V96, LS9, DM2000....) to feed your amps, maybe you should try not to fade into Isadora but automate your fades by sending Midi Control Change from Isadora into your desk.

    Philippe



  • Dear All,

    Would someone be so kind as to file a formal bug report on this so I won't lose it. Sounds like it's totally reproducible.
    http://troikatronix.com/support/isadora/ - select "Bug Report" for the Topic.
    Best Wishes,
    Mark


  • Sorry for the delay in responding.  Mark, I will go ahead and file a bug report just to cover our bases, but after Fred's incredibly detailed response, I do think it's the bit-depth issue.  My gain structure is set up via the techniques taught in SynAudCon (an amazingly simple yet thorough audio workshop, if you haven't heard of it...).  Remastering is definitely the way to fix the problem, and it really comes down to using quality source material.  But with cue changes being generated (or more often than not, found) nightly, with a wide variety of quality, remastering everything isn't always an option.  Audio is about perception, and when I have 20 cues to edit at 2:00 in the morning, sometimes adjusting the fade within Isadora sounds "good enough" (especially when I am probably the only one to notice the janky fade anyway) compared to remastering all 20 tracks. I think I was asking for Izzy to do something it just can't do.  Really, it's the same with video files; if you start with crappy input, the output's going to be crappy too.  That being said, 24 or 32 bit support would be a really nice added feature.

    Thanks again to all for your insight!
    Doug


  • I was plying around testing this against some.other fading methods. It seems the whole scale is a little strange. If I make the same fade over time with linear reduction in Isadora it is quite different to a linear fade of the same time with pro tools. I don't expect them to be identical but I thought they would be closer. I will find some time.to render out the difference and post it when I can..



  • Dear All,

    I think I've worked this out, and Fred was most definitely correct.
    In terms of Movie volume, i am simply telling the QuickTime API to set the volume -- QuickTime does the amplitude change internally. The volume value is an integer (not a floating point number) with 0 being silent and 256 being unity.
    Remember, the volume is specified as a percentage. To calculate the volume, I multiply the percentage x 256 and round the number up to the next integer if the decimal is 0.5 or greater (i.e., 1.25 becomes 1.0, 2.53 becomes 3.0)
    The key here is the percentage value 0.1954.
    256 * (0.1954 / 100) = 0.50 -- after rounding you get 1.0
    256 * (0.1953 / 100) = 0.49 -- after rounding you get 0.0, and the sudden drop off.
    If you have the Core Audio feature, you might use the AUAudioFilePlayer and the Audio Device Output actors to control the volume. I would suspect that Core Audio handles the volume changes much better, and is likely to give you what you want.
    Best Wishes,
    Mark
    Best Wishes,
    Mark


  • thanks Mark


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.