assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Glitch with the Picture Player



  • Often times when I try to project a picture, the bottom part of the image comes up black. This problem appears to be totally random. I can try to bring up the same image, and some days it glitches 50% of the time, some days it glitches 75% of the time, and some days it doesn't glitch at all. Also, the amount of the image that isn't shown varies each time I try it (sometimes it's just a small black stripe at the bottom, some times most of the image is obscured). I can make the whole image come back by turning "visible" off and on for the picture player, but by that point it already looks very unprofessional. This problem only started happening a few months ago, and has been a persistent nuisance ever since.

    Can anyone help me with this?
    Thanks


  • Here's an image of what happens. f8aa58-screen-shot-2014-05-06-at-4.20.46-pm.png



  • you reminded me: i have experienced this as well. preloading, bypassing and unbypassing seemed to help a bit, but not every time. sometimes a picture just will not appear whole. this happened during a tour. i had to work around it by adding each picture to the bin twice and selecting a the other one if there was a problem.

    i've only experienced this on my new MacBookPro Retina running Mavericks 10.9.1 - what OS are you working on?


  • What is the resolution of this picture? And what is the storage format (JPEG, TIFF, PNG, etc.)

    Best Wishes,
    Mark


  • i was using JPEGS, all standardised to 1280x800 - the size of my stage. i tried to recreate the problem yesterday using a stage preview, but all pictures were displaying properly. if i get time i'll try with a projector.



  • I've been using JPEGs at 800x600. I've found that toggling "visible" off and on on the picture player solves the problem, so I created a work-around where the image starts off with "visible" turned off, and use a trigger value to turn it back on again before I fade it in. This solution has been working, but it's a little cumbersome so I was wondering if there's a simpler thing I could do to fix it.

    Also, when I have the problem it does show up on stage preview.


  • I'm finally following up on this problem.

    Just to get the facts straight about what happened.
    1) What version of Isadora are you working with? 1.3.0f24 or 1.3.1f06?
    2) Which operating system you are using and what version?
    3) The original desired resolution of the pictures is 1280x800, yes?
    4) The codec used to compress the picture is Photo JPEG.
    5) Were going straight from the Picture Player to the Projector, or if you had any effects between the two. (Post a screen shot of an example if it wasn't a direct connection.)
    6) What was the "default resolution" in the Video tab of the preferences, and what was the setting for "When Combining Video"?
    Let me know. I'll be able to work on this during the coming days.
    Best Wishes,
    Mark


  • Dear All,

    I'm trying to recreate this problem right now on Mavericks, but the pictures always load correctly. Please answer my questions above, and also, @topherbb, please send me your .izz file and let me know which scene has the problem most often. (I assume it's when you go from one scene to the next, so tell me those two scenes.)
    You can send the file to mark [atta] troikatronix [dotta] com
    Best,
    M


  • Dear All,

    And other question: do you have movies playing at the moment you're doing the transition from one scene to the next? Was it a cut (fade time = 0.0) or a crossfade?
    -- Mark

  • Tech Staff

    Mark, I think this is related to another issue I was working on and outlined in a document for you.
    Unfortunately I can't test it easily yet.



  • Same problem Mark...

    I use 1.3.0f06 on mac OS 10.9.2\. The pictures' resolutions are 1280X800 and they are jpgs and pngs.
    The default resolution in video in preferences is 1280X1024 and set to "scale to default".
    The previous scene has a video and the cross fade between the scenes are 0sec.
    I toggle the visible on/of switch with an enter the scene trigger but even that fails from time to time.


  • @Bozzy

    Thanks. Will use these parameters to try to recreate again.
    Best Wishes,
    Mark


  • Hi Mark,

    its difficult to post a screenshot of the patch where this happened, its basically all picture players going through sprites into a complex alpha mask into a projector. (my first attempt at mapping onto an odd shaped and angled screen)
    i was using 1.3.1f06
    default res is 1280x800
    most of the scene jumps were made at the end of fade out envelopes, so i don't think there was ever a movie playing during a scene fade - mainly picture players.
    i can't get the patch to recreate the issue today either. it happened a few days on tour, but not all the time. and i remember the pictures were incomplete in the little preview window when hovering over the patch line coming out of the picture player. the only way to guarantee a picture would play would be to re-import it and choose the new picture number.


  • By the way for what it's worth it's not happening on Mac OS 10.8.5 but definitely on Mac OS 10.9.2...

    bozzy


  • Dear All,

    @bozzy's information allowed me to recreate the problem. It has to do with settings in the "Video" tab of the Isadora preferences.
     It only seems to happen when the default resolution does **not** match the resolution of the pictures, and the "When Combining Video" popup is set to "Scale to Default Resolution."
    In Bozzy's case, the pictures were 1280 x 800\. Yet (and why one would do this is a bit confusing to me) the default resolution is set to 1280x1024\. When loading the picture, this causes it to be scaled to a resolution of 1280x1024\. Apparently this functionality provided by Apple's "Graphics Importer," worked up until 10.8 but is no longer working under Mavericks.
    Does this apply to your setup too @dbini?
    And why, @bozzy, did you have the default resolution set to something other than the resolution of your pictures? (Mostly I'm just curious, because I don't understand why one would choose to do this.)
    For everyone's information: when you choose "Scale to Default" resolution **every** v**i**deo, picture, or generator (e.g. Text Draw) is forced to the resolution specified by the default resolution. I really don't recommend this. It is a brute force solution and may actually cause Isadora to run more slowly depending on the source material. A much better way would be to organize your media so that it is a the right resolution in the first place, and to use the "Resizable Bkg" actor as a input to generators like Text Draw to explicitly control the resolution.
    In any case, for an immediate workaround, do one of the following:
    1) change the default resolution to match your pictures
    2) scale your pictures to match the default resolution
    3) change the "When Combining Video" popup to "Scale to Largest" or "Scale to Smallest."
    I am looking into a long term solution.
    Best Wishes,
    Mark


  • i had everything (movies, images, renderers and stage) set to 1280 x 800 and yes - scaling to default. maybe i missed something somewhere like a shapes actor -   i have never thought of using a resizable background as an input. maybe that will help. and i'll make sure i scale elsewhere in the future. just in case it returns. thanks Mark.



  • Dear @dbini,

    Well, if all of your content is pictures were 1280 x 800, and there was still a problem, it blows my theory. Because in my tests, if the pictures were not the same resolution at the default resolution, there was a problem. If they were the same size, there was no problem.
    Are you triple sure all the pictures were the same resolution as the default resolution? If so, I need to go back and test further.
    Best Wishes,
    Mark


  • Aha! don't worry Mark - i think you're on the right track. i just carefully went through all my source materials and found a couple of images at 1280 x 720 that must have managed to sneak into the patch.

    well spotted,


  • I don't own a Mac but I also have this (or a similar) bug in Windows (XP, didn't try on 7), and yes, it could be a scaling problem, as I couldn't reproduce it with only one image, only with 2 of them with different sizes. Unfortunately, changing "When combining video" in the Video Tab doesn't seem to solve anything concerning this bug on my computer.

    Here is what I noticed: when clicking on the slider to select another image in the picture player actor, the stage shows these strange black shapes, then the stage refreshes properly (the picture looks normal), displaying the new image. But when clicking outside the slider makes them appear again.
    I also noticed that it's not always black rectangles, but sometimes one part of the preference window. It seems to happen when the preference window opens on top of the stage. Bypassing the picture player and activating it again displays the same exact artifacts again, so there might be a refresh problem (too?).
    Hope this helps.

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.