Movies won't play (Mavericks)



  • Hey all…

    I discovered a quite troublesome thing today and can't find a way out…
    It's seems I'm not able to play correctly video files in Isadora and can't even find out what is the problem.
    In Izzy 1.3.1f06 no file format works… I tried to load AVI, MP4 and MOV with the Movie Player Actor and nothing…
    With the Movie Player Direct, the AVI just the progress bar runs, with MP4 and MOV I get only sound.
    In Izzy 1.3.0f24, AVI only gives me the progress bar and MOV and MP4 works, but really slow and jittery with the Movie Player Actor.
    And with the Movie Player Direct, the AVI just the progress bar runs, with MP4 and MOV I get only sound.
    Don't know what can be the problem… Don't know if it can be a configuration problem or other thing.
    I'm using Mac OSX 10.9.3 (Mavericks) and Isadora with Core Audio and Core Video.
    Thanks in advance,


  • Dear Paulo,

    I can verify that there is a problem with certain mp4 movies on Mavericks with 1.3.1f06\. I just tried it, and the movie plays for a few seconds and then stops. Is that your experience?
    But other movie types play fine.
    QuickTime will only play .AVI files that were compressed using the DV codec. If you open you're AVI movie in QuickTime player, I believe it also will not play the movie. Please try this and let me know if it is true. For sure, if QuickTime Player can't play the movie, Isadora also won't be able to play it.
    To help me follow up with this, please do the following:
    1) Open one movie of each type (.mov, .mp4, .avi) in QuickTime Player
    2) Choose **Window > Show Movie Inspector**
    3) Take a screen shot of each and post them here.
    I am especially curious about the .mov file.
    Regardless, I tested the MP4 movies in my working copy of the new version (coming officially at the end of May) and the MP4 movies play fine. I am currently working on the Live Capture part of Isadora, b/c I will update this to a newer system provided by Apple. As soon as I feel this is stable enough, I will make this new version the pre-release. This will happen in one or two days.
    But please post the screen shots as I requested above.
    Best Wishes,
    Mark


  • I tested movie player with 10.9 and many weird things happened. You see I do not go to Maveriks usually.

    I will not bother Mark with this right now, so he can get the update ready. I just would stay away from Maveriks if you have no special need to use it(like LeapMotion and such). On 10.6.8 everything works fine.


  • Well, I would still like the screenshots so that I can be very sure all is well.

    Best Wishes,
    Mark


  • I'll make an more extensive test and post my findings later today.

    But I confess I was a bit lazy and used some old video sample files I had lying around to show some of Izzy's actors and came up to this… 
    And about Mavericks… I can't really go back now. Unfortunately… 
    Thanks for the attention.


  • Dear Paulo,

    Again, please send me the screen shots I requested so I can test this. I am sure we can get things working for you, if only by getting you a copy of what I'm working on right now. (i.e., after 1.3.1f06.)

    Best Wishes,
    Mark



  • BTW, my weird things were caused by QuickTime 7 interferring with QTX.



  • So… I got it tested with pretty much all types of media I had here and I uploading a file with some media specs.

    It appears the problem files are the first two, named "1 um.avi" and "2 dois.avi"
    Both encoded with H.264
    From my tests, whenever Izzy tries to load these two files, it messes up everything… If the movie player is already playing a file, it keeps playing it forever… however, if the first file you trie to load up is one of these problematic ones, nothing happens.
    Strange enough, all the other files included in the media spec report can't be played be QT, however, Izzy does plays them (except the audio of A.Bit.of.Fry.and.Laurie.Pilot.avi).
    Let me know if the MediaSpec report is enough or you still need the screenshots.
    Thanks,

    b75e3a-videospec-report-2014-05-22.txt



  • Dear Paulo,

    Well, if you're on a Mac, using AVI files is just not a good idea. It would be much better to encode them as MOV files. I am frankly surprised that Isadora will even try to play the H264 encoded files. But suffice to say that the only AVI codec that for sure works on the Mac is DV encoding. I really cannot make any guarantees about AVI movies on Mac OS X.
    Also, I'm now wondering you have [Perian](http://www.perian.org/) installed? This would allow the AVI files to play, but I really can't recommend it. It's now a dead project, and they say on their own website "_**It may -- or may not -- work on 10.8.**_" If you have Perian installed, I strongly recommend you remove it. But I think that will also mean that these AVI files will not play.
    If you don't have Perian installed, then please send me (via WeTransfer or something like that) one of the movies that **does** play. I want to open this up and analyze it. My email is mark [atta] troikatronix [dotta] com
    Best Wishes,
    Mark


  • Don't worry about this files Mark…

    It was one old video loop sample that I had laying around from before using Izzy, now I try to re-enconde all the media files to MOV and the specifics of each project… including resolution, fps and codec.
    But when I tried to play these files and all hell broke lose, I got curios because it used to work before… probably because of Perian.
    I used to have Perian, but when upgraded to Mavericks I made a clean install, so no Perian.
    Do you want the AVI files that does play in QT or the ones that doesn't play in QT but play in Izzy?
    Again, thanks for all the attention

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.