assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

OSC Transmit dropping messages



  • Hi!

    I've been sending OSC messages to an Arduino board, connected with a RJ45 cable, and it's working most of the time, but about 1 out of 6-10 times, nothing happens.
    To be sure it was not coming from my Arduino, i'm now sending in parallel, through wifi, the same message at the same time to another computer running Isadora.
    It appeared that:
    -Sometimes the message doesn't reach neither the board or the computer
    -Sometimes it reaches the computer and not the board
    -sometimes the board but not the computer
    -and fortunately enough it most of the time reaches both, as expected.
    I really see can't where it's coming from since it's so random...
    Does anybody experienced some similar troubles?
    I'm using Macbook Pro 2,4 Ghz i5 Mac OS 10.7.5
    Tried with Isadora 1.3.0f24 and 1.3.1f06


  • Ok sorry problem solved, no Isadora issue involved.

    The servo I was piloting with my Arduino was taking to much power, and so disconnecting the ethernet interface. Obviously, no OSC message could be send before my board had enough power to reconnect to the network.
    Work just fine with external power.

  • Tech Staff

    Glad to hear you figured it out.. and its also a good troubleshooting lesson that may be able to help others.. so thank-you for sharing.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.