assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Full screen with auto start with isadora



  • Hi all

    I am setting up a gallery installation and wish to run the demo mode of isadora for this purpose.
    I have 2 x HDMI screens with a mac mini running mavericks 10.9.3\. This is a new unit bought for the purpose.
    The video set up and full screen playing is fine and I am happy with that.
    My issue is to with isadora entering full screen mode when it turns on. I plan to leave the mac mini in a roof space and run the schedule software. When Isadora boots up from the start up, it enters full screen mode but leaves the main screen finder bar active. I have disabled the 2nd space option on the mac. It is like isadora is running in the back ground etc. When I click on the main screen, it enters full screen properly. This is a tad annoying and the "feature" I wish to disable/get rid of etc.
    Due to my not being present all the time, the application is intended to be stand alone.
    Is this a mavericks thing or is there a workaround to enable isadora to enter full screen mode across 2 x screens upon start up?
    Can anyone help?
    many thanks
    eamon
    Comp:
    Mac Mini
    OSX Mavericks 10.9.3
    2 x 22" HDMI screens.

  • Tech Staff

    @eamon

    What version of Isadora are you using?

    Best
    Michel



  • Hi Michel

    I am using ver 1.3.1f06\. Just updated today
    I have the full version and wish to run the show in demo mode etc.
    thanks
    eamon

  • Tech Staff

    Just a thought.. but are you launching Isadora at system startup?
    If so you might be better off to let the system start (add a 5 to 10 minute delay) and then launch Isadora.
    It might be that a system process that opens takes over system focus for a moment and pulls the bar to the foreground, the dealy may allow this to occur before Isadora goes full screen.


  • Tech Staff

    The thing is that OS X doesn't put Isadora to the front it just gets launched and the finder will stay in front.
    I made an apple script and placed it in an automator workflow. Just put it in your startup items next to the Izzy File you want to start and the script puts Isadora to the front.

    Best
    Michel
    2130c2-setisadorafrontmost.zip



  • Hi

    Many thanks for the input and the script.
    I took DusX idea and looked at mac's automator. It worked!
    I have set up ical with my dates and set it to trigger the automator file. I placed ical in the login start up folder and this triggered it all perfectly.
    Thanks for the tip re the delay. It gave me the idea to look at automator. I have never used it before but a handy piece of software. Very smart indeed.
    @Michel: Thanks for the script. Much appreciated.
    Thank you all for the help.
    eamon


  • Great solution.
    Meantime when you said "I have disabled the 2nd space option on the mac."... Do you mean that that you did uncheck in MIssion Control in System Preferences 'Displays Have separate spaces'?
    (screen grab attached) That should normally prevent the menu bar from showing when in full screen mode on Mavericks.
    Jamie

    e560ab-full-screen-mavericks.png


  • Tech Staff

    @primaldivine

    It is like @eamon says I tested it. The "Displays Have separate spaces" solution doesn't work for the main screen and that was his problem.

    Best
    Michel



  • Hello, I’m running Izzy on 10.9.4 and I also can’t get the menu bar to go away by disabling the 2nd space option on the mac in mission control. I tried Michaels script but it didn’t work for me though maybe I don’t understand it. Is there an easy way to fix this since it makes Izzy unusable on this OS if we can’t get fullscreen like every mac OS ever before this one;-) Any help is appreciated.

    • John -


  • Now it works. Thanks Michel I think I just needed to restart my computer;-) Maybe there is some way to embed that code in Izzy so if it detects 10.9 it just makes it work from the beginning all by itself;-) Thanks for the fix

    - John -

  • Tech Staff

    @john you are welcome, glad it works.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.