assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Midi "note off" not being received



  • ey there!

    I am triggering a midi note with Ableton Live, and sending this data throught midi yoke to isadora.
    Isadora is receiving the "note on" data, but when the note ends, I receive no "note off" data
    I see with Ableton´s "midi track out indicator" that both "note on" and "note off" are being send, so the problem is either at midi yoke, or isadora.
    Any idea?
    Attached a screenshot of the set up

    35aa0d-untitled-1-copy.jpg



  • I have just tried the same but sending the note on and off signal with a midi controller, and "note off watcher" is not responding, but also "status" is not showing me that a "note off" is being triggered, so the problem is probably not from the "note off watcher" actor, but before...



  • Dear @camilozk,

    I just tested the pre-release with a software called MULAB using Isadora's virtual MIDI input, and both MIDI Note On and Note Off messages were being shown the the Status window, as well as being received by the Note On and Off Watchers. (You did not say what version of Isadora you are working with by the way.)
    Open the Monitor window from the Windows menu in Isadora. Do you see the note off's appearing there?
    If not, then please download http://www.snoize.com/MIDIMonitor/ and connect it so that Ableton is a source. Do you see the note off messages in MIDI Monitor?
    Report back here after you've tried these things.
    Best Wishes,
    Mark


  • Thanks for your support @mark

    I am using v2.0.0b4 in Win XP. Both the Status window, and the Monitor window are not showing me any "note off", but I do see the "note on" activity.
    Snoize midi monitor wont do the job for me since I am on XP, but I have just monitored the midi activity with MIDI-OX, and I see correctly the "note on" and "note off" signals from both Ableton Live and my midi controller, so they information is there, but isadora is not seing it.
    NOTE: I opened another discussion where I expose that I am not seing several functionalities from the new v2.0, even thought I am an early adopter (Isadora's virtual MIDI input and output are between them). Perhaps we should check this first?
    http://troikatronix.com/community/#/discussion/1518/missing-features-on-my-v2-0-0b4
    All the best


  • I have just tried it with v1.5.3f28, and I still dont receive "note off" signals, even MIDI-OX is showing me that they are being triggered by the midi controller, and by Ableton Live


  • Tech Staff

    ... I was going to post... but when I did.. I saw I had been beaten to the punch.  This forum is always active.. I love it.
    I just moved, otherwise I would do a quicktest(midi controller is still packed).. I will pull it out later this evening.. and do a couple quick tests.. I have XP machines I can test.


  • for "Note Off" the MIDI standard allows two implementations: 1) Note On (St = 1) with velocity = 0 2) Note Off (St = 0) with velocity = 1...127 (release velocity) live gives a true output for both. Note On with velocity = 0 has the advantage that the status byte in a pure note on/off sequence does not change and therefore can be omitted



  • OK. I tested on Windows. @DusX please find out what's happening on Windows, and file a bug report for this so we'll get it fixed. Danke.



  • thank you very much @mark

    I am preparing a gig with this set up and I will be anxiously waiting for the fis.
    Have a nice week!


  • Hi, I am experiencing similar issues, however

    for MIDI signals I am using a Korg Volca Bass
    sequencer (modded with a midi out). Isadora
    sees the the note on, but does not react to the
    note off. Any ideas why that would happen?
    Thanks


  • Dear @vienastadas,

    There was a bug in older versions of Isadora where the Note Off was ignored. But that was fixed some time ago and that fix is definitely in 2.0.5\. The bug did not exist on Mac OS.
    What platform are you on and what version of Isadora are you using?
    Best Wishes,
    Mark

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.