assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Sounds of movie player playing when jumping to a new scene



  • Hello everybody,

    i'm a new in isadora programing and i sometime have a strange bug:  When i jump to a new scene, i can hear the sound of the movie as the movie player "visible" input is set to off. There is no way to stop the sound, even if i jump to another scene.

  • Tech Staff

    What version of isadora are you using, and are you mac/PC?

    A screen shot of the patch might be handy also.
    Thanks :)


  • Dear @Olivier,

    I am assuming that the movie has sound in it. If you are working on a Mac, there is a bug in the operating system that can cause a problem if you go from a scene in which no audio is playing, to one that is.
    Read this thread and see if it helps:
    http://troikatronix.com/troikatronixforum/discussion/916/tip-mac-os-x-audio-random-pops-workaround/
    But also, it is very possible that you are simply getting a pop because you are stopping the sound when the output level is not at zero -- which is very likely in fact. Because the output level at the sound card goes instantly from some non-zero value to zero when the sound stops, you get a pop.
    So, the thing to do is to fade out the sound using an Envelope Generator (100 to 0) or Trigger Value (set to 0) connected to the Volume input of the Movie Player. You need to do this _before_ you turn off the movie.
    Let us know if this helps.
    Best Wishes,
    Mark


  • Dear Mark and Skulpture, thank you for responding.

    @mark : it is not a "pop" problem. I can hear the entirely the sound of the file at full volume while the movie player is not playing. Otherwise i had the pop issue also, so thank you for your response that is useful for me.
    @Skulpture :  I'm using the 1.3.0f24 on MacBook Pro Retina i7 2.0 Ghz. I have the same issue with the 2.0.0b3 demo version.
    Here are two screenshots of two scenes that have this issue...
    Thank you for helping :)

    Another scene :
    [Insert Image](http://troikatronix.com/troikatronixforum/uploads/FileUpload/22/564cff-patch-oliv2.tiff)

    b90769-patcholiv.tiff 564cff-patch-oliv2.tiff



  • @Olivier
    In your scenes your keyboard watchers for the jump forward and jump backward by one scene are both set to the same keyboard watcher.  Infact it looks like the Keyboard Watcher is not set correctly. Did you try to set it to the spacebar? If so it looks like it didnt take the setting correctly, but also it would cause Isadora to attempt to jump BOTh forwards and backwards at the same time which could lead ot unexpected behaviour.

    Can you try to use keys for those two jumps and see if this fixes the problem?


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.