• Hi there.

    I'm trying to create a simple alpha mask for 3 flat surfaces, rectangle. circle and triangle. I'm playing one video and tried the alpha mask with the shapes actor. I want the video to play with no additive effect basically. Transparent mode switches two surfaces off. Any clues on this easy task?


  • Another thing, concerning alpha. If I have animations with a black background, does it make any difference exporting with alpha channel? I'm using photo-jpg codec for all my exports for now. I have an animation say of a white line on black. Should I export animation codec with alpha channel?

    Thanks for the advice.

  • Shape actor have video IN  connector that is not additive, just link shape actors between em and then put last video out into alpha mask.

  • My experience is that it would be more easy to export movies with alpha(transparent parts) than to create alpha inside Isadora. But be aware of Animation codec quirks - if you have a lots of movement it will not play smooth what ever you try and this codec will not be supported in the future at all.

    I would encode into HAP+(millions colors+) if you stay with cpu-vid. Latest prerelease will play this rather well. Or PNG+(with alpha).
    Or if you use Isadora v.2 you could try ProRes with alpha.
    Then you can use transparent mode with your Projector Actors and using layers you can put one onto another.

  • I may have misunderstood what you want to achieve, but it looks like you should be adding the Shapes together to form the Mask before using them as an alpha channel for your video stream. Then pipe this into a single projector.

    The bottom Shape is acting as a black background to the comp.
    p.s. You could use CI Maximum instead of CI Additive if you need a solid matte when the shapes overlap.


  • @Unfenswinger Thank you very much! I had a look at this, it really helps.

    Now, with the same set up I have another alpha related issue. I'm trying to blend two movie players masked with the shapes actor with a third projector that plays underneath. I would like blending mode to be set to transparent, but once I set it as such, I get the background of the shapes actor. Sorry to ask this, it's pretty simple, but I've tried a couple of things and can't seem to get my head around it. I don't recall having such a problem with blending different movie player sources before...
    Thanks again for the help. :-)


  • If i undrestand well what you need you have just to set a different layer for the third video. positive value place it in front, negative place it in back.67f731-alpha-mask.jpg

  • Sorry, but what I'm trying to do is use the shapes actor (oval and polygon) as a mask and then place it on top of the main (large) image on transparent mode.

    What I get for now is the background black of the shapes actor when I change the setting to transparent instead of additive. 

  • Can you draw a picture of 3 layers and what these have on.

  • This is what I'd like to do. As mentioned before, when I'm setting the mode to transparent, the shapes in front appear with a black background.  9731d2-projection-plan-1.png

  • OK I think it is doable with alpha masks twice like this - altho there is a quirk with shapes to alpha:

    But Shapes appears to work only with 640x480 clips. Otherwise you can not place the shape anywhere on the background movie. I do not use shapes usually, so if someone wants to investigate or knows the reason then you are welcome respond.


  • BTW please do pictures in PNG if possible. I can not view JPG/TIFF directly in my browser for some reason.