• Tech Staff

    I most definitely have this issue on PC with b16.

    I will enter a bug ASAP.
    I spoke too soon, and entered the text quickly in the wrong field.
    Perhaps you did the same an me, and you need to double click the center of the actor to enter the input text.
  • Tech Staff

    Regarding the 'allow network' prompt, perhaps @Michel has thoughts..

  • Thank you DusX.

    I didn't realise you had to double click on the centre of the actor, I entered my text in the output field which came up with a mini text input field like in the Text Comparator Actor input so I didn't know this was the wrong place to add text. Sorry for the noobism.
    I've tried everything I know to kill the allow network connections prompt. I've repaired permissions, deleted and manually added Isadora to the firewall rules. Isadora is the only App that is giving this prompt, it was also giving the prompt in Mavericks and has continued in Yosemite. Isadora 1.3f06 also gives me the nag too.
    I hope this network nag doesn't present itself on an installation so if anyone has any idea how to kill it once and for good I'd be very grateful to hear of a solution.
    Thanks for your help.

  • As for the network promt. I do not have this on Mavericks.

    It may be something that you have in System Pref with Network, Bluetooth, Sharing or Groups. Or your Isadora patch has something that require network connection at the startup.
  • Tech Staff


    I found a thread in the internet talking about this. Maybe you can try some of the steps they are talking about.



  • Thank you all for your suggestions.

    I have previously deleted caches and plists to no avail but I have read posts that claim the prompt can be caused by code signing issues and there are suggestions to create your own certificate, [http://forum.kodi.tv/showthread.php?tid=67494](http://forum.kodi.tv/showthread.php?tid=67494) I'll leave it for now as I'm not sure what the ramifications will be down the line.
    The Allow connections prompt appears to be quite a common issue but it's no big deal just a minor annoyance and may well clear in due course with another update.
    Thanks again.
  • Beta Platinum

    I stopped it by turning firewall off.  51b4b2-screen-shot-2014-11-19-at-12.08.05.png

  • Hi Skulpture,

    Yeah that worked for me too but I kind of like the firewall being there.

  • I have all security tools off on my performing machine. Most of the time I do not connect to the net at the site in anyway. So why hamper the system by dealing with all the restrictions of security. Also I do not have any personal data on the computer that could be stolen.

    Just a thought.

  • Vanakaru,

    That's fine but that doesn't explain why all my other software plays perfectly fine with the OS X firewall settings and Isadora does not.
    I'd also be a little concerned if I were to have a computer running an installation that would require the firewall to be disabled to avoid the Allow Connections nag, I might have to reassess the use of Isadora because in the event of a power cycle I'd want Isadora to boot automatically and carry on the show without being held by a nag screen.
  • Tech Staff


    I don't think this is a Isadora bug, but more a OS X bug. As you said their are many other people in the web talking about the same problem with other software.


  • Dear All,

    Regarding the "Allow Network" connection prompt, when Isadora starts up, it creates a multicast send/receiver port. This is used to allow the Net Broadcaster actor to send messages without knowing the IP address of the other computers on the network. Perhaps it is the multicast part of the connection that OS X doesn't like.

    The multicast address used is 0xE1000001, which

    Maybe that allows you some clue as to how to get around the prompt. But it could also have to do with the fact that Isadora is not "code signed" -- see this article in Stack Overflow about Java apps.


    I've been meaning to do the work to code sign Isadora so that Gatekeeper won't throw fits when you to try to install it. But, as always, I'm prioritizing features and the important bugs

    I hope that helps in some way,