assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Live video and stuttering video playback helppp!!!!



  • Hello there,

    i am a very new in isadora, this is just my second show, i want to design with it.
    I discovered long loading times of the clips (or scenes) and stuttering while isadora played the clips (especially after starting them)
    I think i did something logically wrong in programming.
    So I want to describe what the project is about. The simple idea is to mix live cam and videoclips in a theatre-play. we decided not to do it with a Pal-Video-Mixer, but with a computer to get a better resolution and to use isadora to design several scenes with GO-Ques.
    The projector has the resolution of 1280x800.
    The isadora patch handels with video capturing from a Blackmagic intensity shuttle via HDMI and a 1080i signal. In the capture settings i set the size to Half.
    To get the most out of the projector i created the videoclips in the resolution of the same size: 1280x800 with a photo-jpg codec and 30fps.
    The clips are very long about 4-5 Minutes and should be played just forward. Out of After Effects I got very huge file sizes, about 2-3GB. So i considered to convert them to  smaller file sizes in Quicktime Player 7 Pro.
    In the Preferences i set the default resolution to 1280x800 as well and general services to 8 and activated the threatened playback Button with read-ahead of two frames. To tell the truth, i am not really know what this threatened playback really does, but it seemed to perform better with it, but the stutter seems to appear really randomly, so i am not really sure!!!!

    i created a patch with several scenes:
    First of all i activate live capture and a scene, which should run the hole show through and starts to play a png picture, which is with alpha channel and black bars at the left and right borders. The picture should function as a mask, because the ratio of the projector is 16:10 and the surface on stage, which should be projected on, has the proportion of a square. The projector actor is set to layer 3 to play the picture always on top of the others.
    There are several scenes i want to mix pictures, video and live -video with different opacities(intensities). I used different projector actors on different layers with different opacities. Would you recumbent to use a mix actor for better performance or doesn’t it matter?
    In one scene i have a video-clip, which i don’t want to play after entering the scene, so i set the speed to 0, and added a play button, which sets the speed to 1. Now after pressing the play button, the videoclip jumps some frames forward before starts playing. I think there is a problem loading the file. I added some load scene actors without any result. But i entered the number of the video in the movie player via trigger value actors and not with a initialize value/number in the movie player. Could that be the problem?

    So i hope there is someone out there who can help me
    Iam really desperate and under pressure because the opening should be in 1,5 weeks.
    Helppppp !!!:)

    Should i reduce the resolution of the videoclips or is there a fatal error in my isadora patch??
    preferences, ci actors, projector layers???

    All the best and Thanks

    Oliver a257ff-2woche09.izz


  • Tech Staff

    What codec are the videos encoded with?
    And what version of Isadora are you running?


  • Tech Staff

    I am pretty sure this a codec thing.

    But also: 
    What resolution is the live video coming in? If it's HD 1920*1080 then Isadora will be heavily processing mixing 1920*1080 into 1280*800 that a lot of pixels!
    (p.s - I deleted the other thread to avoid confusion)


  • try to avoid the 1080i 720p is really what you are looking for, no interlaced problems, a higher source framerate etc.

    and it doesn't make sense to capture with a ci actor transform it to a video stream and then back to a image stream
    texture and image streams are handled on the gpu, video streams are cpu based so the data travels far to often on the pci bus resulting in a reduced framerates
    try to use prores proxy as the codec it is highly multithreaded by the os
    hope this helps
    clemens


  • The Isadora 2.0 release notes contain some important tips on this topic. Take a look.

    http://troikatronix.com/isadora-2-0-release-notes/
    and get the latest version.
    Best,
    Mark


  • Thank you all a lot!!!
    I use the photo-jpg codec with isadora 1.3.0f24.
    @Skulpture: Yes it is a Full HD signal via HDMI, but i set the resolution to Half in the capture settings. Does that change anything? Or produce that heavily processing twice?
    What do you recomment. I just can capture full hd via hdmi out of that camera.
    I also think it could be a codec thing, because i experienced stuttering without video capture before. Which codec should i use for that resolution. i dont scroll/jump through the movie. Just playing, Stopping, Playing again.

    ahh and thanks for deleting the other thread

    @m_theatre: thanks, will try the prores proxy but i think i will get huge file sizes, right?
    Ok i will change the ci video in watcher to video in watcher!!!

    What about a preload video actor?

    Could anybody take a look in the patch i made. I think it could build more clever!
    I am little desperate. Next week it should work. Would even pay for it.
    Is there anybody near Magdeburg, Germany

    Thanks to all

    Best

    Oli



  • ah and working with aMBP 2,8 GHz Itel Core i7 16GB, Graphiccard NVIDIA GeForce GT 750M



  • I'm getting very poor video playback in Isadora, particularly with ProResLT files, it's so poor that it's unusable ATM. The FPS counter is reading just under 50 fps but the video is very stuttery. I think it is a codec issue as HAP files I've tried don't exhibit the stuttering.

    I recreated the same multi-layer scene in VDMX and no such stuttering occurs which rules out HDD.
    As a quick test I created A HAP version of the same file and it plays back smoothly in Isadora, in fact, I dragged 6 versions of the file (@1080p) onto the canvas and there was no stutter at all apart from the very obvious stutter when the file is looped which isn't present with VDMX.
    BTW, love the ability to drag n drop and the integrated media window in B28.
    Cheers


  • @Unfenswinger
    Yes, its is very important that users in 2.0 read the support docs about codecs, before panicking! ;)
    I am having extremely good results myself on a MBP with SSD drive using HAP codec.



  • @oli
    Just realised you are working with Isadora 1.30f24 is an old version of Isadora and is not optimised for running HD video files in the same way that version 2.0 is.  I strongly recommend that you upgrade to using the latest version.



  • @primaldivine

    Not sure why ProRes should playback so poorly in Isadora? ProResLT has a nice file size/quality ratio which is why I've been using it and I've never encountered playback issues with anything else.
    PhotoJPEG is the best codec I've found that will loop without a stutter at the beginning which affects HAP files I've tested. So it's swing and roundabouts for your choice of codec in Isadora.
     


  • @primaldivine an all others:

    Thank you all a lot: do you recomment me to join the early adopter program, or should the pre-release version also  solve my problem ? i will try the hap codec as well.
    But correct me if am wrong, i red in the release notes, that i should set the ‘optimize’ input of the Movie Player to ‘performance’ with H264 codec. But could´t find it in the pre-release version. That means getting an early adopter ?
    Best Oli

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.