assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

No BM's capture since 2.01



  • hi guys,

    i've downloaded b.028 yesterday and everything was ok... great work !!! especially the BM tools which are really appreciate here ...
    but since today and the use of the 2.01 version  i have an issue with the BM's capture >>> nothing, just a black field.
    I use it to capture PAL signal with the intensity Shuttle thunderbolt
    I've tried many different settings, download the latest version of BM's tools but still the same...
    so i went back on b.028 to continue my work.
    don't know if it's a bug or something else...

  • Tech Staff

    My intensity shuttle USB 3 works with Isadora 2.01

    I am on OSX 10.9.5


  • Dear @artoo,

    I also have a shuttle. But you didn't mention if you're on Mac or PC. I am out of town today, but will be back where I can test tomrrow. So let me know if you're on Mac or PC and I'll test again with my computer.


  • yes, excuse me...

    i'm on mac (Mac Pro 2013 - maverick 10.9.2)
    I try again this morning but the problem still the same.
    BM Pal capture don't work (just like it was before the b028 version)
    I also have in the patch 3 usb cam
    and a syphon input (via TCP syphon)
    here's the patch:

    811bc1-new-adb_suite.izz


  • Tech Staff

    Hmmm... I can't open this patch. My izzy crashes.



  • that's strange... it's a pretty small patch without any heavy effects (just 5 live feeds going into ffgl blending actors and send into 3 differents stages/outputs)... it works great on b.028 (25 fps and no crash)...



  • @artoo,

    Your request is in the cache. I'll have a look at it as soon as I am able.
    Best,
    Mark


  • well, i think i found the reason why Black magic's capture didn't work since the 2.01 version. in fact it works but i need to set up the general video resolution to exactly match the capture resolution... for exemple if i'm capturing a Pal signal, i'll get the stream only if my project's resolution is set to 720/576 ... i won't get any stream if i'm in 800/600 or 1024/768 or ... that's pretty strange... by the way, am i the only one with this problem? as i said before i work with a macpro under mavericks and izzy 2.05., a thunderbolt intensity shuttle, and all Bm's tools in their latest versions...



  • (and... i've download resolume just to see his behaviour with the Black magic capture and i can't recreate the izzy bug... everythings works perfectly whatever the resolution is... )



  • Hi Artoo,
    I'm using BM Intensity Shuttle USB3.0 and native capture in Isadora works fine.
    I'm capturing composite video PAL signal. latest Isadora, OSX10.9.5, latest BM desktop video drivers (10.3.7), it works great with project resolution set to 1280720, but I have to set Isadora's live capture resolution to "native" (720576) otherwise I get no image. I think BM desktop video driver is not so great..

    Best
    Philippe



  • Dear @fifou and @artoo,

    First, let me say that I was using Blackmagic's Media Express as my "baseline" in terms of how things should operate. As @artoo points out, the first thing is that the capture setting must match that of the camera's output. So I went through this and compared Isadora against Media Express again, to make sure it is behaving as I intended.
    The camera I have only outputs 1080i at 59.97 via HDMI. So, to see an image from my camera, I open Media Express, click "Log and Capture" and then open the Preferences. There I set the "Project Video Format" to "HD 1080i 59.94" and the image appears. If I try any other setting, I see nothing. (Well, actually if I try 1080p 29.97" I see a weird split image, but that seems to be an accident related to the interlacing.)
    So, I made Isadora work in same way, mostly because I assumed people who had Blackmagic devices were used to Media Express as a tool. In Isadora, to see an image from the Blackmagic device, you must set the input format to match the signal coming from the camera. If you choose a non-matching format, you see nothing.
    @fifou, you used the term "project resolution" -- what are you referring to here? A BlackMagic setting, or to something in Isadora? If you are referring to the "Default Resolution" in the Video tab of the Isadora Preferences, then this setting has nothing to do with the video capture resolution. (Have a look at the Isadora manual.) If you are referring to the setting in BlackMagic item in the Apple System Preferences, (labeled "Set Default Video Standard As") not that below the popup is says "Final Cut Pro X and startup video will use this setting. In other words, Isadora does not pay attention to this setting either.
    So, if given all I've said above, you think something needs to be is not working as it should, please let me know and I'll see what I can do about it. But given that Blackmagic's own software doesn't show an image if you don't select the right format, I would say that Isadora's behavior is correct.
    Finally, the fact that it doesn't scale is a bug. It worked for me during testing. But given the "fog of war" we were all in as we headed towards release (meaning, there was a lot going on), something must have happened that broke this. You are the first bring it up.
    I've filed a bug report about the scaling and will prioritize getting it fixed. Thanks you for pointing it out.
    Best Wishes,
    Mark



  • Dear Mark,

    I'm was talking about "default resolution" in video image processing - preferences in Isadora. As it seems to be a problem  for Artoo. If I understood him well, he has to match Isadora's processing resolution to the capture resolution to make it work.
    I just wanted to point that with a capture resolution set to "native" and any Isadora processing resolution, it works with my configuration.

    It seems to me that Isadora is working properly with my BM Intensity shuttle usb3.0.
    Thanks for this great function.
    It's only BM driver which is not very handy.

    Best
    Philippe



  • Dear Phillipe,

    The "Default Video Resolution" in the Isadora Prefs has nothing to do with capturing _unless_ you set the "When Combining Video" input to "Scale to Default Resolution." But given that the scaling is broken right now, this won't have any effect anyway -- at least for the Blackmagic input. In addition, I can tell you that I'm capturing right now from my Intensty Shuttle at 1080p with the Default Resolution set to 640x480, and the video coming from the Video In Watcher is 1920x1080.
    Maybe I'm wrong, but based on your comments I think you have a misunderstanding about the function of the Default Resolution. This setting is explained on page 123 of the Isadora PDF manual. Please take the time to have a look.
    Instead, I think what he's saying is that the "Input" popup on the Live Capture Settings has to match the camera's output, which is what I was saying above.
    @artoo ? Do I have it right?
    Anyway, the thing is, that the BM driver is many, many times more efficient that the one you can access via QuickTime. And the latency is noticeably lower. (For the QuickTime input, BM took some code called iWebcam and ported to grab frames from their hardware; it is not an optimum solution.) I think the only real issue that needs fixing is the scaling.
    Best Wishes,
    Mark


  • The BM capture API has no scaling, this is not wrong or unusual, it is a pro product that is used in broadcast and many other situations. If you want to use a scaled size the hardware allows for scaling, this can be set in the control panel where  you can upscale SD to HD on input or downscale HD on input. This is normal functionality.

    Any real scaling will have to make a copy of the frame data every frame and algorithmically scale it. The above mentioned scaling ratios have been optimised by blackmagic to look great, any other scaling is arbitrary and may not look so good- eg HD camera in 320x240 capture resolution. 
    The normal workflow I use when working with the API is to get the closest resolution I can with the blackmagic system and then manually scale to the resolution I need. This is what happens anyway when other capture devices (through quicktime for example) offer custom resolutions. The cpu or gpu power is still used in scaling the image and it comes in only at hardware defined sizes.So you will get exactly the same result if you scale the image afterward. 
    Dont worry about the blackmigic driver, @marks implementation is perfect and it works exactly as it should. Just the scaling is off and dont forget about the optimised resolution scaling in the hardware control panel.


  • Thanks @Fred; you're expertise is always appreciated.

    That being said, I can see that we need two GPU based things: a de-interlacer and scaler to allow to change the size of something. That would allow people to at least do stuff with the larger image once it has come in.
    Also, Fred makes a good point: if you want to work at lower resolutions, use the built in downscaling algorithm to get 480p. That should help if bandwidth is an issue.
    Best Wishes,
    Mark


  • well, thank you guys...

    I'm afraid Mark but I think phillipe is right concerning my issue ... my english is so bad that i took 2 screen pictures to show you my problem: 
    (forgot the way to post picture here...)
    - https://www.dropbox.com/s/m66a5zpeeaeqyd1/Capture%20d%E2%80%99%C3%A9cran%202015-03-19%20%C3%A0%2015.40.12.png?dl=0
    - https://www.dropbox.com/s/mllltrxm57o4067/Capture%20d%E2%80%99%C3%A9cran%202015-03-19%20%C3%A0%2015.41.13.png?dl=0
    I think I know how to use/configure isadora or the BM tools to import a live feed and as i said before every thing worked fine until the 2.01 version (in fact in b 0.28)
    anyway thanks a lot
    artoo.


  • Artoo,

    In Isadora prefs "when combining video" is set to "scale to default resolution", it scales all video streams including live streams. Since BM capture scalling isn't working, in this mode, setting the resolution in the capture window to "native" has no effect.

    Switch "when combining video" setting to "Scale to largest image" or "Scale to smallest image" and it will work.
    That's why I could recreate your problem. Now I can !

    Is that right Mark ?

    Best,
    Philippe



  • Dear @fifou,

    Yes, that's probably right. I'm away from the BM device now, but sounds like the right answer.
    Best Wishes,
    Mark

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.