IzzyMoviePlayer64 crash



  • Hi TroikaTeam,
    First of all, Izzy2.0 is great ! (I hope I will soon have some projects to play with it )
    Yesterday, I was working on a very simple patch without video (a timer controlled via OSC).
    When I tried to reopen it I had a hard crash of the mac.
    Since, I cannot open Izzy2.0 : Isadora window opens but IzzyMoviePlayer64 crash messages are endless appearing. (Izzy1.5.3 is fine)
    Is it a bug ? Is it my machine ?
    Attached the crash log of IzzyMoviePlayer64.

    Best
    Philippe

    1d2639-izzymovieplayer64-crash-log.txt



  • Sorry, I was talking about Isadora 2.0.1f00 of course and running under osx10.9.5 ..



  • Dear @fifou,

    Well, it thinks you have a video movie with a resolution of 0x0\. (That's OK for Audio Only movies, but not OK for video movies.)
    Is it simply the act of booting up Isadora with an empty file? Or is it trying to automatically load the most recent patch; automatically opening the most recently used file is a "feature" of recent versions of Mac OS. (You might not even know it's trying to open the old file.)
    If you think it might be trying to open the file, move your media into a different folder so that Isadora can't find it. Then try booting up Isadora again.
    You didn't do anything unusual, like rename a jpg picture file with a .mov extension or anything like that, did you?
    Now, it could be part of the "warm up" procedure for the new, separate Movie Players apps. There are some tiny movies inside the Movie Player application that are automatically played when the app boots up -- this is to ensure that the most frequently used codecs are pulled into RAM before Isadora starts telling the player to play any movies. But these aren't causing problems for others, so somehow I don't think that's it.
    So try moving any recently used media files someplace else, and see if you get the "Locate Media" dialog. If so, tell it to "Skip All" and see if you can get your file open.
    You could also just throw away the old version and download and reinstall 2.0.1 again.
    Report back here and we'll find out what's going wrong.
    Best,
    Mark


  • Hi Mark,
    I launch Isadora by clicking it's icon, not trying to open a patch. While IzzyMoviePlayer64 processes are craching, Isadora window opens blank. This shows (I think) it doesn't tries to open my most recent patch. 
    In my project, there weren't any medias of any kind. I tried to rename the folder where the patch is located, just in case, no luck.

    I tried to reinstall Isadora 2.0.1, still no luck.
    I can remember that near before the hard crash I had problems duplicating and modifying comments in the control window of the attached patch.

    Hope it helps
    Thanks
    Philippe

    d4fcd9-osc-counter_as_150208_142920.izz



  • Dear @fifou,

    Now, this bug should have already been fixed. But, do you by any chance, have non-ASCII characters in your hard drive name? Things like russian characters, the french c with the little thing below it, anything like that?

    There was a bug like this that I thought was fixed. But, maybe it's not.

    If so, try temporarily renaming your drive to something like "mydrive" with out the quotes and see if that makes a difference.

    Best,
    Mark



  • Hi Mark,
    I'm sorry, IzzyMoviePlayer64 is still crashing with v2.0.2f00.
    I don't think I had/have any Non ASCII characters in pathes.
    My hard drive's name is "Mini OSX", my account folder is "fifou", I checked all..
    The only weird thing is that I move Isadora application folder into "applications/video/"
    But with a fresh install, with Isadora folder into "Applications" folder by default it doesn't work either.

    It seems Izzy doesn't tries to open previous projects.
    I tried to delete prefs files (com.troikatronix.isadora.plist ...).
    I tried to reverse to demo mode.
    I tried to reinstall..

    All 2.0 crash IzzyMoviePlayer64, Izzy1.5.3f28 works well, which seems logic since it doesn't use new playing engine..

    Attached, IzzyMoviePlayer64 crash log with Isadora v2.0.2f00, in case.

    Thanks
    Philippe

    f07a03-izzymovieplayer64-crash-log-izzy-2.0.2f00.txt



  • Dear @fifou,

    I will work with you to solve this. Please check your normal email for a message from me.
    Best Wishes,
    Mark


  • Dear All,

    @fifou and I found a solution to this. Please read
    http://troikatronix.com/troikatronixforum/discussion/1831/isadora-2-0-izzymovieplayer64-crashes-solved-with-apple-download
    Thanks again @fifou.
    Best Wishes,
    Mark

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.