Problems with drahtwerk's iWebcam and Isadora



  • Hello all,

    my first post on the new forum, and I must admit I didn't post much on the old one either, so, hello.
    I'm working on a show at the moment that's in rehearsal stages. The show will probably end up needing a really simple, no clever tricks or effects live feed from a single fixed camera to two monitors. We're having to move around a lot during rehearsals and as, for the time being, quality of video isn't hugely important I was looking for a flexible wireless way to stream video from stage back to Isadora. After looking at various wireless 'webcams' I found an iphone app called [iwebcamera](http://www.drahtwerk.biz/EN/Products/iPhone/iWebcamera.aspx) made by a firm called drahtwerk.
    This app is installed on the phone and then, after installing a couple of drivers on your mac, streams video over wireless LAN. It works with Skype and other such apps so I thought I'd try it with Issy.
    First, I was very impressed, the picture isn't great, but I didn't need it to be and the lag wasn't too bad either (not noticeably different than say a standard DV/firewire connection).
    The problem I'm finding is that now the 'Live Capture Settings' window seems to have completely frozen. It opens as usual but I can no longer change any settings, or, most annoyingly, select a different source than the drahtwerk camera. I'm locked in to it.
    I asume this is because the drivers I installed are behaving in a way that forces Isadora to see that video source and prioritise it over other sources. I'm sure it's a problem with their software, however, other programs, such as Skype, don't seem to have the same problem. The drahtwerk camera appears as a video source but can be selected and un-selected in the usual way. I can switch to the built in camera on my mac for example and back without a problem.
    I wondered if anyone else had come accross this kind of thing before?
    I will, shortly, be trying to remove the drivers and (hopefully) restore Isadora to full functionality. To be honest, I'm not sure how to do that as it's never been something i've needed to do before but I'm sure there's a way.
    Oh, I'm running 1.3.0f24 on a Macbook Pro 2.26 GHz intel core 2 Duo, 8GB, still on Lion 10.7.4


  • Sorry, I've just read this discussion started by bonemap who mentions some irregularities in 1.3.0f24. I wonder if these are the same problems?



  • Hi,

    I have used drahtwerk's iwebcam, and had the same problems as you. In Isadora, you can still use the menu Input/Stop Live Capture (or the keyboard combination) while the live capture settings window is frozen; after stopping the capture, live capture settings are active again. Also, you might want to check under the iwebcam settings (click the question mark) whether you have enabled the Broadcast option. The app works usually fine if you did. There may be other problems with specific routers (see Manual in the app for further info).

    Another idea: have you tried EpoCam HD? Works as well (little lag) and good HD image quality from my iphone 4S, and doesn't freeze the Isadora Live Capture Settings window...

    Best,
    Stephan



  • Please submit a formal bug report about the iwebcam problem and I will see what I can do about it.

    Best WIshes,
    Mark


  • Thanks for your help stj and Mark,

    You're quite right, if you start and then stop the capture, the window becomes active again. This is a bit confusing as _before_ the live capture starts (ie when you start Isadora) the window remains frozen if the drahtwerk camera was the last one selected.
    Bug report submitted, anything else I can do to help let me know.


  • Now I just need an iPhone so I can try it myself. Will try to come up with one here in Berlin so I can give it a go.

    P.S. Does anyone know if this app will work the same on an iPad with a camera? (Don't have that either, but might be easier for me to get a hold of it.)

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.