assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Problems with demo version for installation



  • I am working for a video installation, 1 macMini, 2 doublehead, 1 motu soundcard, 4 Led screens, 4 Loudspeakers

    4 x 1280x720 25p h264 clips + 1 x 4 tracks sound movie, same length and linked by "position"
    It will run with gallery staff during 2 weeks, everything works well but 3 problems:
    – when I want to quit Isadora, there is a screen with 3 possibilities: "register", "quit anyway", "return to editing", even if there is no change to the patch. Unfortunately the default choice is "return to editing". There is a way to avoid it, because it's not easy for staff to manipulate the mouse? Or a shortcut to choose "quit anyway" instead of "return to editing"?
    – I put the patch inside "opening" in system preferences, as to open it automatically, but unfortunately the Finder stay in front, showing the menu. I used a little appleScript to avoid that:

    tell application "IsadoraCore"

    activate

    end tell

    It worked well before but now the image on one screen is hidden by the Isadora application, any idea to avoid that?

    – the third problem is not related to demo. Sometimes the patch start perfectly, sometimes one or two of the player don't show the image or a stopped image. If I turn the visibility off and on, it works normally.

    Thank you in advance for your help, Jacques

    d25823-ohmyghostpau02.izz e134a8-isadorafirst.app.zip


  • Tech Staff

    @jhoepffner

    I just tried your patch and if I open it it playes the movies everytime and after quiting it does not ask for saving or anything even in demo mode. Are you using the most new Izzy version 2.0.2?

    Best Michel



  • Hello Michel,

    Yes, it's the "ultimate" 2.0.2 version. Even if I just open the patch and close it, I have the screen.
    Perhaps it's because no license was never installed on this brand new computer?
    I continue my research, but if you have a shortcut to choose "Don't save" it can do the job, for the moment the only solution is to force quit, not very elegant.
    Best, Jacques


  • I found the solution for the second problem.

    I do not tick "Automatically show stages", I added a init scene, waiting 5 second before to show stages and then jumping to the "player" scene. So the apple script put Isadora in front before and when Isadora show the stages, the Isadora working window is hidden.
    For the third problem, I initialize with visible off on each movie player and after 1 second, I turn on, and it works.
    I am still searching for the closing screen… A beer in Paris for the solution maker!
    Best, Jacques

    0b0be1-ohmyghostpau03.izz



  • I will drink my beer alone, pressing escape choose "Don't save"

    So everything solved!


  • Dear Jacques,

    I think I know why the document is asking to save. When you open Isadora, it automatically looks for the movies and other media as you know. If it is forced to "remap" them because they are not in the same location as they were when the document was saved, it will mark the document as "dirty" (needing to be saved) since something inside the document has changed.
    If you are using a licensed version, this would be a good thing -- so that the file gets saved with the current path to the files and Isadora doesn't have to search when opening the file. But I can see that this feature needs to be disabled in demo mode.
    I have submitted a bug report in your name so this problem will get handled.
    As for the finder staying in front problem, I thought I had solved this, but clear I have not. I will reopen the bug posted by Bodo on this and see what I can do.
    Best Wishes,
    Mark


  • Dear Mark,

    Thank you for your quick and clear answer! As usual.
    As you can see, I found the way to manage it, but certainly it could be good to solve it.
    One great strength of Isadora is the demo mode, allowing to use many computer at the same time.
    All the best,
    Jacques


  • Dear J,

    It's in the bug list now. It will get handled. Probably for the next release, which will actually come rather soon as there are other bugs that are fixed that everyone should have.
    Best Wishes,
    Mark


  • Dear @jhoepffner,

    Can you give me a few more details on the startup problem you mentioned, i.e., the Finder is in front?
    First, do you have Isadora set to automatically show the stages in the Preferences?
    Second, I want to be sure that you added an Isadora documents (.izz) to the Login Items under System Preferences > Users & Groups > Login Items. Is that right?
    Third, after starting up in this way, the result is that Isadora is not in the foreground, i.e., the Finder's menu bar is visible and the Isadora menu bar is not.
    Finally, what version of Mac OS are you running? 10.9? 10.10? I need to know so I can test on the right platform.
    Are all of these assumptions correct?
    Best Wishes,
    Mark


  • Dear @jhoepffner,

    Well, it seems that this "Finder in Front" thing is somehow a new "feature" of Mac OS 10.9 (and thus probably 10.10)
    As an experiment, I created a text file in TextEdit and saved the file. Then I added this TextEdit file document into System Preferences > Users & Groups > Login Items, and finally, I restarted my computer.
    Te TextEdit application is in the background after loading the document, and the Finder is in front with it's menu bar showing. So it's not an Isadora problem, it's a change in Mac OS. :-(
    Oh Apple.
    Anyway... this means I am not sure what I can do about this. I don't know if it's possible to simulate the AppleScript activate event you mentioned. But I'll see what I can do.
    Such a bummer!
    Mark


  • Dear Mark,

    There is 2 problems, first one is "finder in front", I know it since a long time and I resolved it with an apple script saying to Isadora to be in front. (I put the script here)
    The second is, if I choose in Isadora preferences "Automatically show stage", after the script, the working panel of Isadora come in front of the scene, showing tools in front of video.
    For the moment I resolve it unticking "Automatically show stage", having an "init" scene waiting 5 seconds (time to Isadora to come in front with the apple script) and then an actor show the scene.
    It works, but it could be a more elegant way?
    Thanks, Jacques

    307381-isadorafirst.app.zip


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.