assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Movie Player vs Classic Movie Player Interactions issues



  • Hello TroikaTeam,
    Today I made some test for a forthcoming project where I will have to slighlty modify speed of a movie during playing without notice.
    I made some test in PhotoJPEG 720p and ProRes 720p. And I must say that it doesn't work as expected.
    When fading speed from 1 to 0,9, I can see hangs in the movements. I am of course in interaction mode.
    Then I tried with Classic Movie Player, It works well.

    Maybe there is something wrong in the new Movie Player in interaction mode.

    What do you think ?

    All the best 
    Philippe
    f0ac64-capture-decran-2015-03-07-a-10.44.23.png



  • Dear @fifou,

    Background

    For everyone's benefit:

    The 2.0 Movie Player and the Classic Movie player are very different.The Classic Movie Player plays the movies "inside" the Isadora application. But we needed to change this in 2.0 because QuickTime is no longer supported by Apple, and QuickTime will often crash if you're playing more than one movie on 10.9 and later. That wasn't something that we could live with obviously.

    To prevent these crashes in 2.0, movie playback is handled by several "faceless background applications" -- basically, separate apps run in parallel to Isadora. This allows the multiple movies to exist at the same time without causing each other to crash. So, while we've tried to make these background apps function as closely as we can to 1.x, some things are a bit different.

    It is also important to understand that speed ramps (like the one you are trying to do are are almost useless) in AVFoundation and DirectShow (i.e., 'performance' mode.) There is a glitch every single time you change the speed. This is not an Isadora limitation, but a limitation of these systems. That's why we're trying to keep QuickTime alive as long as we can. Because QuickTime is superior AVFoundation when it comes to interactive control.

    Possible Solution

    The main application has to send the numbers from the Envelope Generator to the background app. So, I suppose it's possible that you are overloading the pipeline that feeds this data to the background apps. Try putting a Multi-Blocker actor with a time of 0.1 between the Envelope Generators and the 'speed' input. If that prevents the hangs, try reducing the time to 0.05. Experiment with this value to see if you can get a smooth fade.

    If that doesn't work, then file a formal bug report and one of the team will follow through with you.

    Best Wishes,
    Mark



  • Mark,

    That was too much useless data for the speed control.
    With a multi blocker, it works well now ! (with 0,1s and with 0,05s)
    Thanks for your explanations.

    Best

    Philippe


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.