Struggling with BlackMagic UltraStudio Mini Recorder

  • Dear @nick,

    I'll alert you as soon as I get this handled.
    Best Wishes,
  • Beta Platinum

    Hey Mark & Nick,

    I'm testing the same device and not having any luck w/Apple or Black Magic settings.  Any advice appreciated.

  • You need to set the resolution to the resolution of the input to get it to work. If you don't know the resolution then you have to try all the options to see if one works, if it doesn't then I think the most likely problem is the video is a resolution that isn't supported. (assuming all the leads etc are checked as well of course)

  • @Nick,
    Are you using the BM Software to test/set the resolution? If not, would you mind to outline your steps for that?

  • @ckim,

    I also notice that the supported codecs list is not that broad, so that might also present an issue depending on your source.

    Supports:  AVC-Intra, AVCHD, Canon XF MPEG2, Digital SLR, DV-NTSC, DV-PAL, DVCPRO50, DVCPROHD, DPX, HDV, XDCAM EX, XDCAM HD, XDCAM HD422, Apple ProRes 4444, Apple ProRes 422 (HQ), Apple ProRes 422, Apple ProRes (LT), Apple ProRes 422 (Proxy), Uncompressed 8-bit 4:2:2, Uncompressed 10-bit 4:2:2.

  • I used the black magic desktop app to test the unit worked, and tried Madmapper when izzy was having trouble.
    I then used the izzy capture dialog box to set the resolution izzy is trying to capture in from the drop down options.
    Apple worked for me, for the reason Mark described above.
  • Beta Platinum

    @primaldivine + @Nick:

    I thought I tried all the settings but will test again soon and get back.  btw, it worked OK with other apps just not Isadora.

  • I had to use the apple settings to get at the bit depth options

  • Beta Platinum

    OK, got the Apple Settings to work.

  • Beta Tester

    Hi there. I have gone trough a few threads about the BlackMagic UltraStudio Mini Recorder. In Resolume Arena the capture function works great, but there I also have the option to chose SDI or HDMI in put. But in Isadora the Input Settings... is greyed out. Any one have a solution to this? 

    I use a camera that outputs: 1080i 59.94

    I have tried both the Apple Drivers and BMD Drivers and I'm on the MacOS 10.12.5

    All the best. Erik

  • Tech Staff


    You have to set SDI or HDMI in your system preferences. In the last row there is a blackmagic icon. You also have to close other applications that are using the Mini Recorder, only one can have access at the same time.

    Best Michel

  • Beta Tester

    Great! Thanks for the quick reply Michel! Now it works like a charm : )